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How to start

1 How to start?
1.1 How to Start ImageView?

1. Invoke the Windows metro start screen with keyboard button E, locate
ImageView and click it to start the application.

2. Click the Start button (At your screen bottom left corner) and a Start menu will

bring up. Move your mouse over the menu and try to locate ImageView ,
click to start it.

1. Double click on the desktop icon l@ (If installed) to start ImageView;

1.2 How to start the camera?
ImageView will detect all of the cameras that your computer has installed (Here, it is
XXXXX, a 3.1M pixel USB3.0 CMOS camera) and will list all the camera names under
the Camera List group on the Camera Sidebar

Click the Camera Sidebar (If it is not activated) and the Camera List to expand the
Camera List group (if not expanded). Click the camera name (Here it is XXXXX) to
start the video window and the camera will begin to stream the video. The video
window will be associated with a name called “Video [XXXXX]" (i.e., its title bar name
will be “Video [XXXXX]").

B Camera List

XENEX
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2 Video window GUI
2.1 Video window GUI

3 Cose
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A:ImageView;

B: Menu;
C:ImageView toolbar
D:Camera Sidebar ;

E: Folders Sidebar ;

F: Undo/Redo Sidebar ;
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G: Layer Sidebar ;

H: Measurement Sidebar ;
I: Measurement Sheet;
J:Statusbar;

K: Auto Hide button

L: Horizontal ruler;
M:Vertical ruler

N:Frame Rate

0O:Frames captured
P:Current Video sizes
Q:Selected microscope Magnification
R:Current Unit;

AA: Sidebar right mouse button context menu;

AB: Video window right mouse button context menu;
AC: Browse window right mouse button context menu;
AD: Image window right mouse button context menu;
AE: Frame window right mouse button context menu;
AF: Double-click bring up Video Properties dialog;

AG: Double-click bring up Magnification dialog;

AH: Double-click bring up Measurement dialog;

AI: Horizontal Ruler or Vertical Ruler right mouse button context menu

2.2 How to close the video window?

1 Double-clicking the tabbed video window title or clicking x on * ¥ will close the
video window directly;

Close Ctrl+W
Close All m

File Properties...
Copy Full Path
Browse Containing Folder

Open Containing Folder

B New Horizontal Tab Group
M New Vertical Tab Group

2. Choose the Windows>Close All command to close the video window;
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3. Click the right mouse button on the video window title to invoke the context menu

and choose Close to the video window.

4. Press Ctrl+W.
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3 Image window GUI
3.1 Image window GUI

A v - oEN
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OK || Cancel Apply K Cancel

A:ImageView;

B:The opened file right mouse button context menu on status bar;
C:The opened file name and directory;

D:Double-click bring up opened file Properties dialog;

E:Current image width and height;

F:Double-click bring up Scale Image dialog;

G:Image Zoom ratio, double-clicking will zoom the image to 100%;
H:Zoom ratio right mouse button context menu;

I:Currently selected Unit;

J: Double-click bring up Measurement dialog;

K:Image BPP & Resolution;



Image window GUI

L:Double-click bring up Resolution Setting dialog;
M: Unit right mouse button context menu.

3.2 How to close the image window?

1. If you have modified an image before attempting to close it, double-clicking the

tabbed image window title or clicking x on * > will bring up a ImageView dialog:

The App X

o Image has been modified. Do you want to save changes?

Yes No Cancel

Clicking Yes will save the changes with its old name and close the window quickly, No
will close the file immediately with no changes and no warning, or Cancel will cancel

the Close command and leave the window there with no changes;

2. If the Image window is snapped from the video window and with number as its
title, double-clicking the tabbed image window title or clicking x on * * will bring up

a warning ImageView dialog:

The App X

o Image has been modified. Do you want to save changes?

Yes No Cancel

Clicking Yes will bring up the Save As dialog. In the Save As dialog, user can:

Save in: Select the driver and folder to which you want your image file saved in

the Save in combobox and enter the file name in the File name edit box;

Save: Click Save to save the captured image with the specified directory and file

name;

Cancel: Click Cancel to close the Save As dialog and return to image window.
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Save As X
Save in: | Sample v‘ Q2 Er
*+ U ;
Quick access " e E
\ N
m § )
Desktop 55 2009-largejpg 2nd2003exlarge,jpg 04-200-largejpg 4th2007exlarge jpg
m
Libraries
T "
a RTF: :
~ \)\. 4
This PC ) S
o~
‘ 4x_02jpg 06-2010-large.jpg 6th2002exlarge.jpg
= v
Network
File name: || V| [ save |
Save as type: JPEG ("jpa;jpeg:” jpe:”jf;" ff) v Cancel
[Mindude calibration information pticn
[Jsave as the default option

Click No on the ImageView dialog will close the file immediately with no changes and
no warning

Click Cancel on the ImageView dialog will cancel the Close command and return to
image window.

3. Ctrl+W;

Note: Choosing the Window>Close All command can also close the tabbed image
window. Please check the Window>Close All for detail.
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4 Ul toolbar
When the camera is started or the image is opened (or captured), most of the icons
on the toolbar will be available for the quick operation of the video or image window.
1 5 9 11 13 16 17 19 21 23 ,5 27 : 29 31

3 7 7
5 i @ & | Micrometer (um) [v 10X | 100% SlE= Ly Lo 8% L-OO-@ R~
2 1 6 8 10 12 14 16 18 20

1: Open (Ctrl + O)

2: Save (Ctrl + S)

3:Quick Save (Quick Save)
4: Browse (Ctrl + B)

5: Unit

6: Magnification

7: Zoom

8:Video/Image Select

9: Track(enabled only when the video/image size is larger than the window size)
10: Object Select(will be enabled when an object is overlaid on the background layer
11: Angle

12: Point

13: Line

14: Parallel

15: Two Parallel

16: Vertical

17: Rectangle

18 Ellipse

19: Circle

20: Annulus

21: Two Circles

22: Arc

23: Text

24: Polygon

25: Scale Bar

26:Arrow

27:Calibrate (for both video/image window)



UI toolbar

28:
29:
30:
31:

Gray Calibration (for video window)
Image Stitch(for image or video window)
Manual Fusion(for image or video window)
High Dynamic Range(HDR)
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5

Camera Sidebar

The Camera Sidebar is used for the control of camera, it includes many groups. The

group can be expanded by a) clicking the group name or b) clicking the Down Arrow

at the right end of the group name.

5.1 Camera List group

@ Camera List
@aCapture & Resolution
E4Exposure & Gain

| White Balance

@ Color Adjustment
“Frane Rate
AColor/Gray

ALFlip

“ Sampling

|/ Pover Frequency

“ Histogram o

The down arrow to
expanded the group

B Camera List

-0 0.9.4.4

Camera List will list all of the cameras connected
to the computer that support the ImageView
application. Click the camera name will start the
camera video window.

5.2 Capture & Resolution group

&

B8 Capture & Resolution

Live:

O

Snap Record

[2048 x 1534 -]

Snap:

|2EI48 x 1534 v‘

Snap: Continuously Snap images by clicking it;
Record: Record video stream in wmv/asf or avi
format;

Live: Set the video resolution;

Snap: Set the Snap resolution for image capture.

5.3 Exposure & Gain group

4 Exposure & Gain
|| Auto Exposure

Exposure Target: 120

10.000ms|

Exposure Time

0

Gain:

Defaults

1. When the Exposure & Gain group is expanded,
a green rectangle marked with “Exposure” will be
overlaid on the video window This marked region
is a reference region for judging if the image
brightness reach to the Exposure Target value.
Drag or resize the Exposure ROI to the dark area
will increase the video brightness and drag it to

the brighter area will decrease the video

10
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B: I g brightness;
2. Uncheck the Auto Exposure box to switch the
f f Auto Exposure mode to the Manual Exposure.
e = 5 The Exposure Target slider will be disabled in this
Rectangle for Auto Exposure mode;

3. Tune the microscope light source to a bright state, and then drag the Exposure
Time slider left or right until the image brightness is normal;

4. If and only if the microscope light intensity is too low to meet the Exposure Time up
limit, drag the Gain slide right until the video brightness is normal;

5. The exact Exposure Time can also be entered by clicking the edit box at the right of
the Exposure Time. This will bring up a dialog called Exposure Time. You can type the

number in the field to set the exact Exposure Time value.

5.4 White Balance group

1. Click the White Balance bar to expand the
2] White Balance group and a red rectangular

la. White Balance 2
Temperature: 6719

i marked with White Balance will be overlaid on the

0]
Move the ROI (Marked by a red rectangle) to a pure white or gray object and 2_ Drag or resize the red rectangle to a pure

click "White Balance" to establish the white balance for future video.

video window;

white or gray area and click the White Balance

\White Balance ] l Defaults ]

button to establish the video White Balance for
future

video streaming process;

3. If the automatic setting and the actual result still has deviation, drag the

Temperature and Tint slides to left or right to manually correct the White Balance.

5.5 Color Adjustment group

11
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1. Hue: Adjusts the Hue of the video. Drag the

& Color Adjustment

fe ‘| slider to the right to increase or drag to the left

Saturation: ’ s | to decrease Hue;

— ' , | 2- Saturation: Adjusts the Saturation of the
8 video. Drag the slider to the right to increase or

e 0 ’ drag to the left to decrease video Saturation;

e ; wo | 3, Brightness: Adjusts the video Brightness.

Drag the slider to the right to increase or drag

Defaults

to the left to decrease the video Brightness;
4. Contrast: Adjusts the video Contrast. Drag the slider to the right to increase or drag
to the left to decrease the video Contrast;
5. Gamma: Adjusts the video Gamma. Drag the slider to the right to increase or drag
to the left to decrease the video Gamma;
6. Defaults: Click the Defaults to clear all the changes and reset them to default ones;

7. All of your settings will be saved for future Color Adjustment group.

5.6 Frame Rate group

(& Frame Rate % Drag the slider to the right (High) to ensure
Low High )

3 that the camera can run the video at the fastest
T O D B e P e Frame Rate that the computer USB hub
fastest frame rate that the computer USB hub supports. T live video fails to
display, move the slider to the left to decrease the frame rate. SUppOI‘tS. If the video fails to display, drag the

slider to the left (Low) to reduce the Frame

Rate and this will enable the video to stream in a low speed mode.

5.7 Flip group

If the video on the screen appears in different

4k Flip

B} directions from what is viewed under the

[ vertical

camera, check the “Horizontal” or “Vertical” box

to set the video direction to the right one.

5.8 Color/Gray group

m If you wish to preview Color video, select the

A Color/Gray

Oz “Color” button, otherwise, check the Gray

- button.

If you wish to preview Gray video, check the “Gray” button.

5.9 Power Frequency group

12
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1. A CMOS sensor captures each row of pixels

W Power Frequency
@hc (50 1) (from top to bottom) in sequential order,

ren creating a rolling effect, hence the name

DC

"Rolling Shutter". Instead of being relatively
constant, so for example, as the commercial main frequency in Europe is 50Hz,
fluorescent lights in Europe flicker at 100 times per second and as the main frequency
in US is 60Hz, so in the USA they flicker at 120 times per second;

2. This flickering problem is solved by capture row pixels in over the duration of
integer number of (n) flicker periods;

3. check 50HZ will delete the rolling dark band for the 50HZ light fluctuation;

4. check 60HZ will delete the rolling dark band for the 60HZ light fluctuation;

5. For DC power, no light fluctuation is existed and no compensation is needed.

5.10 Sampling group

1. Bin: Pixel binning refers to the method of

¥ Sampling

®sin combining (averaging) pixels of blocks of

(©) skip

neighboring same color pixels to resize the
video to the lower resolution;
2. Skip: Also called "Decimation", means that a certain amount of pixels are not read
out but skipped (horizontally, vertically or in both axes). This reduces resolution of the

resulting video but introduces subsampling artifacts.

5.11 Bit Depth group

® Bit Depth A Switch between 8 bits and 12 bits. 8 bits is the

Oseis basic Windows image format. 12bits will have
(®) 12 Bits

higher image quality but moderate FPS.

5.12 ROI group

ROI, Region of interest. This function can set
the ROI on the video window. When the ROI

group was expanded, a dotted rectangle with

I ROI

Apply Defaults

"Handles" will appear around the video window that will let you alter the ROI. Use
mouse button to adjust the ROI size. If ROI is ok, click Apply will set the video to ROI

size, Defaults will return to the original size.

5.13 Histogram group

13
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2 Histogram ‘ 1. A Histogram illustrates how pixels in an

image are distributed by graphing the number
of pixels at each color intensity level. The

Histogram shows detail in the shadows (shown

in the left part of the histogram), midtones

S (shown in the middle), and highlights (shown in
Right: 157 (=
. the right part). A Histogram can help you
determine whether an image has enough detail

to make a good correction;
2. This group shows the Histogram of current active video. Two vertical line markers
show the upper and lower limits of the intensity levels. These markers can be dragged
with mouse. If you are looking at a color image, the Histogram will reflect the
RGB(red, green and blue channels histogram at the same time) R(red), G(green), and
B(blue) values with lines of the same color;
3. You can also enter directly the desired values in the Left or Right boxes below the
Histogram chart for both Left and Right Histogram boundaries;
4. Click the “Refresh” button to update the Histogram display if the sample under
observation is moved or changed;
5. Clicking the Defaults button will return the Left and Right Histogram boundaries to
its original ones;
6. Click the Auto button to locate the two boundaries automatically to get the best

video quality.

5.14 Dark Field Correction

To Enable the Dark Field Correction, one should

[€) Dark Field Currecli;n *
Enable capture the dark field image first. After the
Capture Quantity: |10 = images are captured, the Enable button will be

enabled. Check it will enable the Dark Field

Cover the lens, and then push the "Capture" button to
capture the dark filed. Check the "Enable" button to enable . . . .
"Dark Filed Correction’. correction. Uncheck is will disable the Dark

Field Correction.

5.15 Misc

14
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s Negative will reverse the pixel values of the

[ egate active video without going through the lookup

Defaults table.

5.16 Parameters group

Parameters group is used to save the camera control

2

.| parameters adjusted for further application.

i Parameters

o Click Save will save the current camera control parameters

with new parameter file; The Load and Overwrite buttons

o

verwrite Management...

will be enabled.
Click Load will load the saved camera control parameters;
Click Overwrite will overwrite the current camera control parameters to the current
loaded active camera control parameters file;
Click Management will invoke a Management dialog and in this dialog, one can

manage all of the saved Parameter files.

15
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6 File

,.
“u

=

6.1 Open Image(O)eee Ctrl+0

Choose the File>Open Imageeee command to open an existing image file. The Open
Imageeee command can also be used to preview an image in small size, or to view its
statistics and information without actually opening the image itself. These

capabilities can be used to quickly locate a particular image.

ImageView supports and can open many image formats. These are identified in the
Files of type list box. You may also open an image file type with ImageView File Type
(*.tft) format which can save Measurement Objects (for simplicity, only Object or
Objects will be used to represent Measurement Object or Measurement Objects)

overlaid on the image.

Open X

Looknn:l Sample V‘ (< W5 =)

*

Quick access

Desktop

Libraries

S|

This PC

N h
@ 4x_02,jpg 06-2010-large.jpg 6th2002exlarge.jpg
Network

File name: [02-2008+arge jpg v [Coeen |

Files of type: All supported formats e Cancel

Image Information/Preview

Current File:

D: \bEmoI;nage\éampie\52-2009-iarge .jpg

Width: (700 Height: 500

More than one image can be opened within ImageView simultaneously by a) with Ctrl
+ left mouse button method and b) Shift + left mouse button method to highlight the

files to be opened. In this mode, the Preview window will be disabled.

When opening an image, ImageView places it into a new image window. It then

becomes the active image.
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Note: ImageView maintains, at the File>Recent Files submenus, a list of the last
4(Can be 1-8) opened files. Any of these files can be accessed by simply clicking on
file name. If no files are listed in the File>Recent Files submenu, the Open Imageeee

command must be used to open the file.

Also, the View>Browse can be used to view images in an Icon format under any

selected directory. Brief information is given in the View>Browse menu.

File name: From this list box, select the name of the file want to open. Either the type
of the file name (with its entire path, if it is not in the current folder), or selecting Files
of type to obtain a list of file names. Double-clicking a file name in the large combo
box (where both folder and file names are listed) will automatically open it.

Note: If just type in the file name, be sure that the Files of type field correctly identify
the format of the file to open. Otherwise error messages will bring up when
ImageView tries to open the file.

Files of type: In this list box, select the image format of the file to open. If one selects
All supported formats, ImageView uses the file's extension to identify its format.

ImageView supports the following file formats:

. . . Windows Bitmap (% bmp:% dib.# rle)

Window Bitmap(*.bmp,*.dib,*.rle) TREG [+ jpsit. jpegi®. dpeik, JiEi# JELE)
Portable Hetwork Graphies (¥.png)

Tag Image File Format (¥ tif;# tiff)

JPEG(*.jpg,*.jpeg,*.jpe,*.jif, *.jfif) Conpuserve GIF (v 2i6)
i Targa (¥, tga)
Portable Network Graphics(*.png) ‘I’lgggﬂiﬁﬂl;j;‘ »sd)
Exbanced Vindors Hetafils (% enf)
Tag Image File Format(*.tif, *.tiff) [

Wirelsss Bitmap ( »Ebmp) )
. TPEG 2000 Standard (%, jp2
Compuserve GIF (*.gif) TEEG 2000 Codentrean G 2k}
Digital Imaging and Communications in Medicine (. dom)
Digital Negative (k. dng)

PCX(*DCX) TFT (v tft

A1l Files (% %

Targa(*.tga)
PhotoShop(*.psd)
Icon(*.ico)
Enhanced Window Metafile(*.emf)
Window Metafile(*.wmf)
JBIG(*.jbg)
Wireless Bitmap(*.wbmp)
JPEG 2000 Standard(*.jp2)
JPEG 2000 Codestream(*.j2k)
Digital Imagingand Communication in Medcine(*.dcm)
Digital Negative(*.dng)
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ImageView File Type(*.tft)

If the image file does not use standard format-identifying extensions, the file in the
File name field must be typed, and then select its format from the Files of type list
box. Otherwise, ImageView will select a format based on the file name extension.
Preview: Click this button to preview image in small size. In preview mode, statistics
and information about the image (i.e. image Width, Height and image location) will
be displayed. The default is no Preview.
Current File: Current File location on your computer;

Width: Current File image width;

Height:Current File image height;

6.2 Open Video(V)eee H
The File>Open Videoeee menu will be enabled only when there is no video file opened

in the ImageView frame or no camera was opened.

1. Choose the File>Open Videoeee command to open an existing video file;

Open x
« v 4 || « Data(D:) » Demolmage » Stack v/ | Search Stack )

Organize v New folder =~ [ o

ImageCount
Sample
SCMOSO5100KPA
Stack

12(000002158-000
Stitch . 021222).avi

File name: |12(DDDDD21 58-000021222).avi v| Video Files (*.wmv;*.asf*avi".r »

2. Select the name of the file you want to open. If the file does not appear, select the

option for showing all files from the Files of Type combobox. The video file type can

be *.wmv*;*.asf* or *.avi* format.

3. Click Open to open a video file, this will create a video window and begin to start
the video stream. The video window will be associated a name called “Video
[XXX.XXX]” (i.e., its title bar will display “Video [XXX.XXX]", here, XXX.XXX is the

video file name).
4. Click Cancel to return to the application.

Note: Only a single video can be opened at a time. ImageView takes camera as a
18
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special video file, if the camera was opened, this menu will be disabled and the video

file cannot be opened anymore.

6.3 Open Broadcast(C)eee
Users could receive the broadcasting video by ImageView from the other user by the
Address and Port. For example, if a user starts a broadcasting service via Address
192.168.0.20 and Port 2080, the other users could share the video that is opened on
192.168.0.20 by inputting the right Address and Port. If the receiver and the
broadcaster are in one intranet, the performance will be excellent. If not, the

performance will depend on the bandwidth.

Open broadcast

Address: |

Port: 2080 =

OK Cancel

6.4 Save(S) H Ctri+S

Choose the File>Save command to immediately store the current window image to
its file (the file name is listed on the window's title bar) while leaving the image still

active in its window.

If the image is untitled or titled with a digit, ImageView will issue the File>Save Aseee
dialog automatically. The default “Save as type” will be “Window Bitmap
(*.bmp,*.dib,*.rle)". If there are Objects overlaid on the image, the default Save as
type will be “ImageView File Type (*.tft)".

The File>Save command can be used to save the most recent changes to disk. It is
often performed as a precautionary measure during lengthy or involved processes to
reduce the amount of reprocessing that might be required in the event of a system
failure or operational error. When an image is closed and not to save its changes is

chosen, ImageView discards all changes made since the last File>Save operation.

Note: a).The File>Save command always saves the contents of the entire window,
even if there is an AOI (Area of Interest) defined on it; b).The File>Save command

will be disabled if the file is not changed or the changes have been saved.
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6.5 Save As(A)eeeo
Choose the File>Save Aseee command to store the contents of the current window to
a specified file format. At the end of a File>Save Aseee operation, the image window
will be associated with the new file and the new format (i.e., its title bar will display

the new file name).

Save As X

Savein.l Sample Vl 0fPE
*

O
Quick access " ~
\ e,
2 ) 5,

Desktop 02-2009-large.jpg 2nd2003exlargejpg 04-2009-largejpg 4th2007exlarge.jpg

"

Libraries
Lol “
ﬁ 4x_02,jpg 06-2010-large,jpg 6th2002exlarge.jpg
= v
Network
File name: || v | [ save |
Saveastype:  |JPEG ("jpa:"ipeq: ipe: i i) > Sy

ti
Indude calibration information Optin
[[Jsave as the defauit option

ImageView supported file save formats are:

Window Bitmap(*.bmp,*.dib,*.rle)
JPEG(*.jpg,*.jpeg,*.jpe,*.jif, *.jfif)
Portable Network Graphics(*.png)
Tag Image File Format(*.tif, *.tiff)
Compuserve GIF (*.gif)
PCX(*.pcx)

Targa(*.tga)

JBIG(*.jbg)

JPEG 2000 Standard(*.jp2)

JPEG 2000 Codestream(*.j2k)
Digital Imaging and Communication in Medicine(*.dcm)
ImageView File Type(*.tft)

Save in: Find the folder where the file wishes to be saved. A new folder may be
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created using the New Folders button;

File name: The file name to be saved. To specify the file's location, either enter its

entire path (disk and folder), or specify its location using the Save in list box;

Save as type: In this list box, select the format in which the image wants to be saved.
Save Aseee is also used to convert a single image from one format to another. For
example, if a TIFF file needs to convert to PCX format, open the TIFF image first, then

choose Save Aseee command with the PCX format to save it to a new file.

The default “Save as type” will be "Window Bitmap (*.bmp,*.dib,*.rle)”. If there are
Objects overlaid on the image, the default Save as type will be *ImageView File Type
(*.tft)"

The Save As command has several important uses beyond simply storing an image to

a new file name. Click Option to select the different parameters to encode the file.

6.5.1 Option for JPEG
For JPEG (*.jpg,*.jpeg,*.jpe,*.jif, *.jfif), Option has the following items:

JPEG
Image quality
Best Best
compression quality
00 2
[ progressive Smoothing |0 %
Optimize coding
[] Save these settings as defaults
conel | | oers

Image quality: If one save an image in JPEG format (*.jpg), one may adjust image

quality in the edit box. The values range from 0 to 100. Default value: 75;
Progressive: The default is unchecked;

Optimize Huffman codes: The default is unchecked;

Smoothing: The values range between 0 and 100. Default value: 0;

Save these setting as defaults: When saving a file, the current settings will be saved
21
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as defaults for the next file save operation.

6.5.2 Option for PNG
For Portable Network Graphics (*.png), Option has the following items:

Interlaced: The default is unchecked;
Save these setting as defaults: When saving a file, the current settings will be saved

as defaults for the next file save operation.

PNG

[[Jnterlaced

[] save these settings as defaults

6.5.3 Option for TIF
For Tag Image File Format (*.tif, *.tiff), the Option has the following items:

TIFF n

[]Append pages
Compression: L7W (default) v

Image quality

Best Best
compression quality

00

[] save these settings as defaults

Appended pages: Determine whether the current image will be saved in multiple

pages style or not;

Compressions: Specifies a method for compressing the composite image data. For
saving a 32-bit TIFF file, one can specify that the file be saved with predictor

compression, but have no option to use JPEG compression. Predictor compression
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offers improved compression by rearranging floating point values, and works with

both LZW and ZIP compression;

Image quality: If choosing Compressions as "JPEG", the Image quality can be

adjusted by the slider bar. The values range between 0 and 100. Default value: 75;

Save these setting as defaults: When saving a file, the current settings will be saved

as defaults for the next file save operation.

6.5.4 Option for JPEG 2000 Stanndard, JPEG 2000 Codestream
For JPEG 2000 Standard, JPEG 2000 Codestream, Option has the following items:

JPEG 2000 X

Compress ratio

[[Lossless wo [

[ save these settings as defaults

Conce Deuis

Lossless: Can check the Lossless or its right edit box with spin button to choose the
wished compress ratio. The default value is 100(1~100);
Save these settings as defaults: Save the current settings as defaults and application

and need not to reset is again in future application;

6.5.5 Option for Digital Imaging and Communication in
Medicine(*.dcm)

For Digital Imaging and Communication in Medicine, Option has the following items:

Compression: There are 3 terms in the drop down box, they are Lossless
JPEG(default), RLE, None, The default is Lossless JPEG;
Save these settings as defaults: Save the current settings as defaults and application

and need not to reset is again in future application;
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DCMm X

Compression: Lassless JPEG (default) v

G (default)

[]save these settings as defaults

Conce et

6.5.6 Option for the other formats
For Compuserve GIF (*.gif); PCX(*.pcx); Targa(*.tga); JBIG(*.jbg); ImageView
File Type(*.tft), There is no Option.

Note: a) Detailed information of the above academic terminologies can be found in
books about image processing and image compression or internet; b) The file saved
directory can be restored for future use. To keep the directory unchanged when
ImageView is started again, choose Options>Preferenceseee command, click Misc

page and check Restore the current directory when startup under the Privacy item.

Preferences x

Quick Save (O German (Deutsch) ~
(O Indonesian (Bahasa Indonesia)
File O Japanese (BFE8)
(O Korean (2H=01)
Print (O Polish (Polski)
(O Russian (Pycaarii)
Grids (O simplified Chinese (& {&d37)
() spanish (Espafiol)
Cursor (O Thai (lna)
(O Traditional Chinese {288rh 37)
Capture (O Turkish (Torkge)
#2 Enable GPU accelerated image processing
Misc ®ro
(O Yes (Intel(R) HD Graphics 530)
{3 privacy
[@] The maximum number of Recent Files: 4
Clear the Recent Files when exit the application
[ Restore the current directory when startup |

Cancel Apply

6.6 Batch Save(B)eeeo
The File>Batch Saveeee menu will be enabled when a) an image is opened; b)an
image is captured from the camera; c)an image window is created by choosing the
File>Paste as New File command; d)an image window is copied from the Undo/Redo
Sidebar with the copy button as show below:
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| Ga
Current Index Operation
1 Open
6.6.1 Batch Save for a) style image window
1. If the image is modified, choosing the File>Batch Saveeee command will save the

file with its opened file name and file extension;

2. If the image is modified because of the Objects, choosing the File>Batch Saveeee

menu will save the file with its opened file name but with “ImageView File Type (*.tft)

file extension format;

6.6.2 Batch Save for b), c) or d) style image window
If the image window has been created with b), c) or d) style, choosing the File>Save
Aseee command to realize the file saving task will be time-consuming. The Batch
Saveeee command will runs File>Save Aseee command with the name automatically

specified according to the paradigm specified in the Batch Save dialog

To start the File>Batch Saveeee command for b) style image window, you have to
1. Start the camera;

2. Snap at least an image first;

3. Choosing the File>Batch Saveeee command will bring up a Batch Save dialog:

Batch Save
Directory:

D:\Test Image
Cancel
File:

Name Format:  nnnn (sequence) v

File Prefix: test

File type: png ~ Option

Sample: test-000L.png

Directory: Enter the name of the drive and directory where your captured images will
be saved. You may either type the path information, or use the Browse button to

locate it from a standard Browse Folder dialog.

Name Format: The year, month, date, hour, minute and second or nnnn(sequence)

are used to as part of the file name. If more files are saved with in a second, a (xx)
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suffix is attached to the end of Name Format to avoid the possible name conflict. For

the nnnn(sequence) “Name Format”, no suffix is needed.

File Prefix: Enter a file name prefix for Batch Save when generating files names for a
series of images. This prefix will be combined with Name Format to form a final file

name naming paradigm.

File Type: In this combobox, select the format in which you want the image to be
saved (can be BMP, JPG, PNG, TIF). Click Option button to set the different
parameters for encoding the file (For BMP format, the Option will be disabled. See
File>Save Aseee menu about the details of the format encoding methods); If there
are Objects over the image, the File Type will be chose as “ImageView File Type
(*.tft)"” by ImageView.

Sample: The final file name is shown at the right of the Sample label for reference.

4. If the setting in the Batch Save dialog was finished, click OK button to begin the
file batch save process or Cancel to cancel the Batch Save command and return

to the application.
For the c) or d) style image window, only steps 3 and 4 are needed.

Note: a) In the process of the File>Batch Saveeee command, the title on the image
tab or image window will be modified with the file name paradigm in the Batch Save
dialog. b) The File>Batch Saveeee will perform no saving operation if the file is not

modified or unchanged.

6.7 Quick Save(Q) d CTRL+Q
The File>Quick Save menu will be enabled when a)a new image captured from the

camera; b)an image window is created by choosing the File>Paste as New File menu;
d)an image window is copied from the Undo/Redo Sidebar with the copy button as
show below:

|y

Current  Index Operation

1 Open
File>Quick Save can save the file at quick way with no need to specify the file
directory, file name and file format. All those are specified in Options>Preferenceseee,

Quick Save property page. The file name can be renamed according to the setup in
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the Options>Preferenceseee, Quick Save property page’s Show the rename dialog
item.

Preferences n

N Directory:
Quick Save

D:\Test Image
File
File:
Print
Name Format: | nnnn (sequence) v
Grids

File Prefix: [tesd

Cursor
File type: png v Option
Capture
sample: test-0001.png
Misc
[¥] Shows the rename dialog

The above settings will be applied to "Quick Save" menu and the
corresponding butten in the toolbar. When calling "Quick Save", images will be
saved quickly according to the above settings in the specified directory.

6.8 Paste as New File(N)
The File>Paste as New File menu will be enabled only when there is valid image data
on the clipboard first (see the Edit>Copy menu). If there is no image data on the

clipboard, the File>Paste as New File menu will be disabled.

Choose the File>Paste as New File command to place the contents of the clipboard

image into a new image window, which becomes the active image.

The new image type will be the same as that of the original image. ImageView will
accept image data from other applications via the clipboard as long as it is in
Windows Bitmap (DIB) format.

Note: ImageView will assign a digit to the Paste as New File command created image

window title bar.

6.9 Twain: Select Deviceeoe
Twain is a cross-platform interface for acquiring images captured by certain scanners,
digital cameras, or frame grabbers. The manufacturer of the Twain Device must

provide a Source Manager and Twain Data Source to work with ImageView.

Select the active device for the Twain: Acquireeee menu from all devices available in

the device combobox which are enumerated by the application.
One must install the Twain Device hardware and its driver first. See the
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documentations provided by the device manufacturer for the installation

instructions.

Before begin to start the Twain: Acquire at the 1st time with ImageView, choose the
File>Twain: Select Deviceeee command first, this will invoke a dialog called Select

Source as shown below:

Select Source x

Sources:

Cancel

Source: Choose the right device from the Source window (Highlight it)

Select: Click Select to select the device. User does not need to repeat this step for

subsequent choosing of the Twain: Acquireeee command.

Note: All of the ImageView cameras are integrated into one Source called Twain

Camera. This will greatly reduce the list item and easy to choose for the user.

6.10 Twain: Acquireeeeo
6.10.1 Introduction
There are basically two techniques used to capture the video images from video
devices such as a PC camera, digital camera, and scanner. They are the Twain:

Acquireeee technique and the DirectShow technique (previously called VFW).

The most obvious characteristics of the Twain technique is that it previews the video
in smaller resolution but captures the image with higher resolution. The ImageView

series cameras support all of these two video preview techniques.

6.10.2 Steps for Twain Acquire
Here we illustrate how to capture the image using a XXXXX (3.1M pixels, USB3.0)

camera as an example.

1. Install the camera Twain driver provide by the supplier (for example driver for
XXXXX hardware);

2. Install ImageView;
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3. Plug the cameras XXXXX (USB3.0) into the computer;

4. Start ImageView;

5. Choose the File>Twain: Select Deviceeee command to select the device from the

Select Source dialog (If never selected before);

6. Choose the File>Twain: Acquireeee command. There should be a dialog box like

below:

snap

‘ Full Screen i

Live:

|2048 = 1534 v

Snap:

2048 = 1534 v
[“]RGB/BGR
[ ] Negative .

In this dialog, the video Resolution can be chosen. The Video Source Property can be
set by clicking the Settingeee button. Click the Snap button to capture an image. This
will create a new window and its title bar will be assigned a digital as the image

window name;

Check the RGB/BGR box to ensure the correct color encoding format compatible with

your application.
Click X on the window’s upright cornor to close the Twain: Acquire dialog.

6.11 Print Setup(R)eee
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Choose the File>Print Setupeee command to access the setup panel for the printer
that has selected. ImageView will present the standard setup panel for the particular
printer (this is the same panel one would receive if one were setting up the printer
from the Windows Control Panel). Change printer's setup to satisfy the requirements,

click OK button to return.

6.12 Print Preview(V)eee Ctrl+Shift+P
Choose the Print Preview command to see the real-time effect of the printer without

actually printing it out.

A

6.13 Print(P)eee - Ctrl+P

Choose the File>Printeee command to print one or more copies of the current image
to the selected output device. The ImageView File>Printeee command lets one take
full advantage of the printer's capabilities. If the printer has built-in half-toning or
color dithering capabilities, use them or instruct ImageView to perform these

processes before sending the image to the device.

The File>Printeee command also has facilities that let one adjust the size and position

of the image on the printed page.

6.14 Recent Files
ImageView maintains 4 (default) most recently opened document files under the
Recent Files menu. Choosing one of these submenus will reopen that file

immediately.

Note. a) The maximum number of Recent Files can be modified by choosing the

Options>Preferenceseee command and clicking the Misc page as shown below:

Here, clicking the 4 (default) edit box will allow you to enter the number of the Recent
Files submenus that you want. The value ranges from 0 to 8, the default is 4; b) One
can also check the Clear the Recent Files when exit the application to clear the Recent

Files after exit ImageView application.
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Preferences x

Quick Save O German eutsch)

(O Indonesian (Bahasa Indonesia)

File O Japanese (BFE8)

(O Korean (2H=01)

Print (O Polish (Polski)

(O Russian (Pycaarii)

Grids (O simplified Chinese (& {&d37)

() spanish (Espafiol)

Cursor (O Thai (lna)

(O Traditional Chinese {288rh 37)

Capture (O Turkish (Torkge)

# Enable GPU accelerated image processing

Misc ®ro
(O Yes (Intel(R) HD Graphics 530)

{3 privacy
The maximum number of Recent Files: 4
] Clear the Recent Files when exit the application
[ Restore the current directory when startup

Cancel Apply

6.15 Exit(X)

Choosing the File>Exit command will close video, all of the image windows and

Browse window. After all of the windows are closed, ImageView will end itself.

Note: If an image has been modified before attempting to Exit it, ImageView will
issue a warning to ask if user want to save the image or not first.

The App x
o Image has been modified. Do you want to save changes?

Yes No Cancel

If multiple images have been modified before attempting to Exit it, ImageView will

issue Save Files dialog to direct the user to save changes in different ways.

Save Files

File has been modified. Do you want to save changes?

Yes No Cancel

Yes to All No to All Batch Save

See Window>Close All for details.
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7 Edit
$

7.1 Cut(T) Ctrl+X
The Edit>Cut menu will be enabled only when a) an Object or Objects on the Layer
over the image is or are selected; b) an image or images in the Browse window is or

are selected.

7.1.1 Cut for Objects

Check the Measurements>0Object Select X or Edit>Select All menu to find how to

select Layer Objects for the Edit>Cut command.

Choose the Edit>Cut command to a) copy the selected Objects to the clipboard and
b) delete the selected Objects on the image. Any data already exist on the clipboard

will be replaced.

The Objects copied to the clipboard can be pasted into the active window or into
another opened video/image window on the layer overlaid on the image using the
Edit>Paste command (when there is no Layer overlaid on the Background,

ImageView will create a new Layer first).

7.1.2 Cut for Browse window selected files
When the Browse window is active and the image files in the Browse window are
selected, the Edit>Cut command will be enabled. Choosing the Edit>Cut command
will delete the selected files and copy it to the clipboard.

Note: The Edit>Cut command does not support Background Layer (image) Cut
operation.
<3

7.2 Copy(C) Ctri+C

Choose the Edit>Copy command to Copy the highlighted Objects (on Measurement

Layer) or an image's selected area on the Background Layer to the clipboard.

Note: When a) the Object(s) is (are) highlighted or b) the Current Layer is the
Background Layer and an image ROI is selected, the Edit>Copy menu will be

enabled.
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7.2.1 Copy the selected area on the background layer to the clipboard.
1. Select the image area using the Image Select @ button on the toolbar. The
Edit>Copy menu will be enabled;

2. Choose the Edit>Copy command to copy the selected image area to the clipboard.

7.2.2 Copy object(s) on the measurement layer to the clipboard.
1. For the Layer operation, see the View>Sidebar>Layer menu in Sec.8 and the

Layer menu in Sec.14 for details;

2. For the Measurement operation, see the View>Sidebar>Measurement menu in

Sec.8 and the Measurements menu in Sec.15;

3. After the Measurement operating has been done, choose Measurements>O0Object

Select command or check the Object Select button E, the cursor will change to E
in the video/image window;

4. Move the mouse until the cursor becomes 8, this means the cursor is right on
the Object. Clicking it will highlight Object and select the Object;

5. Option 1: Continue to move the mouse until the cursor becomes again, this
means the cursor is right on another Object again. Clicking it with Shift+left mouse

button and the second Object will be selected and highlighted;

6. Option 2: a) Move the cursor over the image, click down the left mouse button; b)
Drag the mouse to draw a rectangle on the image. A dotted rectangle will appear
around the selected area; c) Release the mouse and all of the Objects within the
dotted rectangle will be highlighted and selected;

7. After the Objects are selected, the Edit>Copy menu will be enabled;

8. Choose the Edit>Copy to Copy the Object(s) to the clipboard. Then the Edit>Paste
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menu will be enabled. One can then Paste the objects onto the Current Layer or onto
the other Measurement Layer in the same video/image window. If one switches to
the Background Layer, the Edit>Paste menu will be disabled, but if one returns to the

Measurement Layer again, the Edit>Paste menu will be enabled again.

7.2.3 Copy for Browse window selected files
When the Browse window is active and the image files in the browse window are
selected, the Edit>Copy command will be enabled. Choosing the Edit>Copy
command will copy the image files to the clipboard. After the Edit>Copy command,

the Edit>Paste and the Edit>Paste shortcut menus will be enabled.

Note: a) The Edit>Copy command will not delete the Objects over the image. Any
data existing on the clipboard will be replaced with the new data; b) The copied
Object(s) can be pasted into the active window or into another opened window using
the Edit>Paste command as long as the current window is not on the Background
Layer (the Edit>Paste menu will be disabled if the Background Layer is active). See
the View>Sidebar>Layer command in Sec.8 and the Layer menu in Sec.14 for
details; c) the copied files on the clipboard can be pasted into the Browse window by

choosing the Edit>Paste command.

7.3 Paste(P) e Ctrl+V
If a) there is (are) Object(s) on the clipboard and the Current Layer is not the

Background Layer, or b) there is (are) image file(s) on the clipboard and the current

active window is Browse window, the Edit>Paste menu will be enabled.

7.3.1 Paste for Objects
Choose the Edit>Paste command to Paste Objects from the clipboard onto the active
image's Measurement Layer. One can also choose Edit>Paste command to transfer a
layer's Objects from one image window's Measurement Layer to another image

window's Measurement Layer.

7.3.2 Paste for Browse window selected files
When the Browse window is active and the image files in the browse window are
selected, the Edit>Paste command will be enabled. Choosing the Edit>Paste

command will paste the clipboard files to the Browse window.

Note: The Edit>Paste command does not support the image area Paste operation.
34



Edit

7.4 Paste Shortcut(S)
This command is for Browse window only. This menu will be enabled when files in the
Browse window are selected and the Edit>Copy command is executed to copy the file
shortcut to the clipboard. Choose this command will create the selected files

Shortcut(in *.Ink format) in the current Browse window.

The App X

This folder already contains a shertcut named
"14th2006exlarge.jpg.Ink".
Overwrite, Cancel, or Abort?

Yes No Cancel

If the to be pasted *.Ink file has been existed in the current Browse window,

ImageView will pop up a prompt dialog.
One can click Yes, No or Cancel to Overwrite, Cancel or Abort the command.

7.5 Delete(D) X Delete
The Browse>Delete File menu will be enabled if a) the file(s) is (are) highlighted in

the Browse window, b) the Object(s) on the video/image are selected. This

command is for Browse/Video/Image window only.

You can Delete or remove one or more files from the Browse window. The steps are

as follows:

7.5.1 For Browse Window file delete
1. Select one or more files by a) Clicking the displayed file icons, a single file will be
highlighted; b) Clicking the file one by one with Ctrl + left mouse button, all of the
clicked files will be highlighted; c) Clicking the displayed file icons, the first clicked file
will be highlighted, clicking the end file with Shift + left mouse button, all of the files
among the first and last will be highlighted. d) Dragging the mouse to draw a dotted
line rectangle across the files you wish to delete, all of the files in the rectangle will be

highlighted; e)Ctrl+A to select whole files in the Browse window

2. a) Press the Delete key to delete the selected files; b) Click you right mouse button
to bring up a context menu, choose the Delete command to delete the highlighted

files. A Confirm File Delete dialog will bring up.
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In the Confirm File Delete dialog, click Yes to move the files to the desktop recycle bin,

or No to cancel the Delete operation.

7.5.2 For Video/Image Window Object delete
If the Objects on the video/image are selected, choosing Browse>Delete File or

pressing delete button will remove the Object from the video/image window.

7.6 Image Select(S) o
The Edit>Image Select command can be used to mark ROI and Copy the selected

ROI to the clipboard. This command is only used to select the ROI on the Background
Layer.

Choosing the Edit>Image Select command will check this menu (or click EE on the

toolbar will keep H down) and the cursor will turn into + The ROI selection
steps are described as below:

1. After the Edit>Image Select command is chosen (or click the Image Select button

I onthe toolbar), the Background Layer will be checked automatically regardless of
if the other Layer is checked or not;

2. Drag the mouse cursor across the image with the left button held down until the

area is selected;

3. Release the left button and the area will be marked. Handles will appear on the

area that will allow altering the selection after it is marked.

Visible Current Name
Background
[ Layer1

K

|
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7.7 Select AlI(A) Ctrl+A
7.7.1 Select all on the background layer
When the video/image window is active and the Background Layer is checked,
choosing the Select All command will select all pixels on the Background Layer within
the canvas (shortcut: Ctrl+A).

7.7.2 Select all objects over the background layer
When the video/image window is active and the Background Layer is not checked,
choosing the Edit>Select All command will select all of the Objects on the Current
Layer (shortcut: Ctrl+A).

7.7.3 Select all files in the Browse window
When the Browse window is active, choosing the Edit>Select All command will select
all of the files in the Browse window under the specified directory in the Folders
Sidebar.

7.8 Select None(N) Ctri+D
Deselect a) any selected area (ROI) on the image; b) the Objects on a Layer; c) the
file listed in the Browse window.

7.8.1 Select None for Background Layer
When the Current Layer is the Background Layer and an image area is selected, the
Select None menu will be enabled. Choosing the Edit>Select None command will

delete the dotted rectangle representing the selected area (ROI).

7.8.2 Select None for Objects
When the Current Layer is not the Background Layer and the Objects are selected,
the Edit>Select None command will be enabled. Choosing the Edit>Select None

command will deselect all of the selected Objects.

7.8.3 Select None for Browse window
When the Browse window is active and the image files in the browse window are
selected, the Edit>Select None command will be enabled. Choosing the Edit>Select

None command will deselect all of the selected files in the Browse window.

Note: See Edit>Image Select, Edit>Select All and Measurements>O0Object Select k
to understand how to perform select operations.
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8 View
8.1 Browse(B) = Ctrl+B
8.1.1 Open the Browse window

1. Choose the View>Browse menu or click the Browse toolbar button = open or
active browse images under the specified directory in the Folders Sidebar;

2. Click the Folders Sidebar to activate it and double-clicking the listed directory in

the Folders Sidebar will create the Browse window.

After creating the Browse window, ImageView will display a Browse window that
looks like windows explorer. The child window on the left part of the Browse window
called Folders Sidebar is used to locate the directory on the hard disk. Images in the
current directory are displayed in Large Icons or Small Icons mode on the right side

of the Browse window.

Image file’s order can be set in Ascending or Descending order according to Sort by

Name, Type, Size, Width or Height et al.

8.1.2 Browse window right mouse button context menu
Clicking the right mouse button on the listed Icon in the Browse window will bring up

a right mouse button context menu as shown below:

Open

% Delete File
—
Sort » v | sort by Name
I
2 B e Sort by Type
[£] Refresh STallons Sort by Size

5] Properties... Sort by Width
Sort by Height
Stitch Shift+T
A e
24| Ascending
High Dynamic Range (HDR

%1 Descending

These context menu functions are described in

Browse>Delete File
Browse >Sort>Sort by Names
Browse >Sort>Sort by Type
Browse >Sort>Sort by Size
Browse >Sort>Sort by Width
Browse >Sort>Sort by Height
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Browse >Sort>Forward
Browse >Sort>Reverse
Browse >Icon>Large Icons
Browse >Icon>Small Icons
Browse >Refresh

Browse >Properties
menus. Please check them for details.
There other menu can be found in Process menu in Sec.13.

Note: The Folders Sidebar and the Browse can be used to perform tasks such as
creating new folders, renaming, moving, and deleting files. Individual file
information and import data from digital cameras can also be displayed.
Double-clicking the left mouse button on the icon will open the image as an active

image in full size. See Image window GUI in Sec.3 for more details.

8.2 Measurement Sheet(M)

The App
File Edit View Browse Setup Capture Image Process Layer Measurements Options Window Help

Z o 4« = | Nanometer (nm) |v| NA V| 50% v {3{"7‘ .- /2 7% L-000

Measurement va2HE«q Browse  2004-hm-14-large.jpg*
- Appearance
Nane B
Label Type Length

Line Vidth 4

Line Color W ooo0ff

Line Style =
=l Calculation

Length 731.13

[l Coordinates

v

Measurement Sheet v o

Index Name Center Diameter  Area Length Angle Start End Distance

136 Export to Html
6551, Auto Hightlight

Settings...

Bca. [Hrol. [@un. [Rlay. TEMe.

D:Derolrage Saraple2004-hao-14-large jpg 700 x 504 % Zoom: 50% & Pixel BPP: 24, Resolution: NA
When choosing the View>Measurement Sheet command, the Measurement Sheet
will be active. The Measurement Sheet shows the Object's possible features, such as
Name, Center, Radius, Area, Perimeter, Angle, Start Point, and End Point overlaid on

Background Layer.
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Clicking the right mouse button on the Measurement Sheeteee and the right mouse
context menu will bring up on the Measurement Sheeteee window as shown above.

They are explained below:

8.2.1 Export Html
Export all the Layer Objects to the *.html file in a tabbed format.

;:“:: Index |Name Center Diameter Area Length Angle Start End Distance
Layerl | 1 (124.86, 239.18) 218.54 37509.04 | 686.55
1 (578.19, 249.50) 205.15 33055.73 | 64451
Layer2 (579.00 (122.00
- 2 2 > ] i)
2 (350.50, 246.50) 457.13 178.62 252.00) 241.00)
Length Unit:Pixel, Angle Unit:Pi

Note: This menu will be enabled only when there are Objects overlaid on the

Background Layer (video/image).

8.2.2 Auto Highlight
When this menu is checked, clicking the item in the Measurement Sheet will highlight

the corresponding Object overlaid on the Background Layer.

8.2.3 Settingseeoe
1. To modify the Measurement Sheet’s item order, click the item to highlight it, the Up
or Down button will be enabled (If the item is in the third position, the Up button will
be disabled, if the item is in the last row, the Down button will be disabled). Click the

Up or Down button to modify the item order;

2. Checking/Unchecking the item will show/hide the item in the Measurement Sheet;
3. Clicking Default will return to the ImageView's default settings;

4. Item 1(Index) and item 2(Name) cannot be changed (in grayed state).

Note: The item Index and Name are always in grayed states, this means these two

items cannot be modified (Both their hide/show states and their positions).
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Measurement
General Define the columns of the measurement sheet:
Length Unit [Windex up
) []name

Angle Unit ] center
- [V]Diameter b

[V]Area

[V]angle

[V]start

[V]End

[V]pistance

8.3 Sidebar
There are 5 Sidebar in the ImageView frame window in tabbed style. They are
Camera Sidebar, Folders Sidebar, Undo/Redo Sidebar, Layer Sidebar and
Measurement Sidebar.

8.3.1 Sidebar overview

BA BB BC BD BEBF CACBCCCDCE DA DB DC DD DE DF EA
o & € g EEIREIF T i !!
B Descop & 68 ofiton R P wRL Libel e sl
-2 Libraries, O 1 Open [ Background Line ¥idth
-y Fei-hoph YU O 2 Brightness/Contras. o u ti:: g‘:;: Wzeczo0
514 Computer (] 3 Curve Adjustment O iz © Calculation EC
51 Y Network v 4 Smooth M ™ L2 Angle (Rad... 0.84
-8 Control Panel Angle (Deg... 48.32
4 Recycle Bin ngle (PL) 0,27
© Coordinates £[)
Pointl. X 240
Polntl. ¥ 128
Point2.X B2
Point2 ¥ 338
Polnta X 300
Pointa. ¥ 320

AA: Camera Sidebar;
AB: Camera Sidebar groups for the control of the camera.

BA: Folders Sidebar;

BB: Back to the previous folder;

BC: Forward to the next folder;

BD: Browsing the pictures under the application’s file directory;

BE: Open the Browse window if it is not opened (Double-clicking on the selected
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directory will perform the same functions.);

BF: Folders to locate the Browse window'’s file directory.

CA: Undo/Redo Sidebar;

CB: Forward to the previous step;

CC: Backward to the next step;

CD: Operation Copy: Copy the highlighted operation in the Undo/Redo Sidebar to a
new image window; User can also drag the selected operation in the Undo/Redo
Sidebar to the window area to create a new image window;

CE: Remove the highlighted operations from the Undo/Redo list (This button will be
enabled only when the operation(s) is (are) selected, the opened image(the first
operation) cannot be removed;

CF: Indicating the Current operation displayed in the image window;

CG: Operation Index;

CH: Operation name.

DA: Layer Sidebar;

DB: Make a New layer;

DC: Remove a layer;

DD: Set as the Current layer;

DE: Show/Hide a layer;

DF: Rename a layer;

DG: Visibility control of the layer items;

DH: The Current active layer for operations;

DI: The layer Name. The image layer is always named as “Background”.

EA: Measurement Sidebar;

EB: The Appearance of the highlighted Object on the Current layer; you can edit the
Appearance by clicking its item and editing it;

EC: The Calculation of the highlighted item on the Current layer;

ED: The Coordinate of the highlighted item on the Current layer; you can edit the
Coordinate by clicking the item.

8.3.2 Sidebar>Camera(C)
The Camera Sidebar is mainly used for the control of camera, it includes many

groups. Each group can be expanded by clicking the group name or the arrow button
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at the right of the group name.
Checking the Sidebar>Camera menu will activate/show it on sidebar group.
Please check Camera Sidebar in Sec.5 for details.

8.3.3 Sidebar>Folders(F)

The Folders Sidebar is mainly used for the image Browse control.

Checking the View >Sidebar>Folders menu will activate/show the Folders Sidebar.

Clicking its tree can navigate the file directories.

Double-clicking the directory in the Folders will create the Browse window. If there
are image files under the directory that ImageView supports to Browse, the image
files will be displayed in Large or Small icons mode.

Their orders can be set in Ascending or Descending styles according to Sort by Name,
Type, Size, Width or Height et al.

Clicking the right mouse button on the directory will bring up the right mouse context
menu as shown below:

Folders a & Stop sharing
Q Bl & DELTAOPTICAL
B0 Music = UpdatusUser
#- J. Photo B Specific people...
b sw
J, TestImage / Open -
J. Composite Pin to Start Documents
J. EDOF / & Music
N0 o St : S picres
4 ). EDOF_02 Include in library » B Videos
#- ). EDOF 03 Send to >
#- ), EDOF_04 . Create new library
& ). EDOF_05 z“'
opy
-l EDOF.06 i Compressed (zipped) folder
#- ), EDOF_07 Create shortcut
%), EDOF.08 Delete Bl Desktop (create shortcut)
i ). EDOF_09 Documents
5 ). EDOF_10 fropeucs & Faxrecipient
- b EDOF_11 .J Mail recipient
% EDOF12 % MaximDLS
#- J. EDOF_13 Q s
i ). EDOF_14 kype
- ). EDOF_15 v & DVD RW Drive (E)

Folders directory right mouse button context menu

This is the basic window explorer menu and will not be explained in this manual.
8.3.4 Sidebar>Undo/Redo(U)
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The Undo/Redo Sidebar is used to list the Undo/Redo operations for the Image and

Process menus’ command.

Checking the View>Sidebar>Undo/Redo menu will activate/show the Undo/Redo
Sidebar.

8.3.5 Sidebar>Layer(L)
Layer Sidebar is used for the management of Layer operations. These operations
include making a New Layer, Removing a Layer or Renaming a Layer and Layer

visibility controlling et al.
Checking View>Sidebar>Layer will activate/show the Layer Sidebar.

8.3.6 Sidebar>Measurement(M)

The Measurement Sidebar is used to check or edit the selected Objects on the Layer.
Checking View>Sidebar>Measurement will activate/show the Measurement Sidebar.

In this sidebar, the Object Appearance, Calculation and Coordinates characteristic
are listed. The Appearance and Coordinates can be edited.

8.4 Grid(G)

The Grid menu has 5 submenus, they are:

8.4.1 Settings(S)eee i

Choosing the View>Grid>Settingeee command, or choosing the Preference>eee

command and clicking the Grids page realize the same function.

Choosing the Preference>eee command and clicking the Grids page can set the Grid
Style, Line Style, and Line Color for the Grid overlaid on the video and image window

can also be set.
Style: The Grid Style can be No Grid, Auto Grid or Manual Grid. Default is No Grid;

Line Style: The Line Style for the grid can be Solid, Dash, Dot or DashDot et al.
Default is Solid;

Color: The color of the grid line. Default is Red (255,0,0).
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Preferences

Quick Save
Style: No Grid v
File
Line Style: Solid
Print

— Line Color: ‘D Default

Cursor
Capture

Misc

8.4.2 Grids>No Grids(N)
Choosing this command will remove both Manual Grids and Auto Grids overlaid on
the video/image window.

8.4.3 Grids>Auto Grids(A)
Choose Grids>Auto Grids command to overlay the grids on the video/image

automatically.
The Auto Grids can be set in the View>Grids>Settingeee menu.

8.4.4 Grids>Manual Grids(M)

Choosing this command will display two small Right Arrow and Down Arrow overlaid
on the top of the Vertical Ruler and on the left of the Horizontal Ruler as shown
below:

Down Arrow: Move the mouse over the Down Arrow will show a horizontal drag icon.
Drag the Down Arrow along the Horizontal Ruler to where ever you want. When it is
dragging over the video/image, there will be a Vertical line appeared to let you judge
where to release this line on the video/image. You can drag any lines to overlay them

on the video/image.

The overlaid lines can be adjusted by dragging the specific Down Arrow again on

Horizontal Ruler.

Right Arrow: Move the mouse over the Right Arrow will show a vertical drag icon.
Drag the Right Arrow along the Horizontal Ruler to where ever you want. When it is

dragging over the video/image, there will be a Horizontal line appeared to let you
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judge where to release this line on the video/image. You can drag any lines to overlay
them on the video/image.

Right arrow or
down arrow for
Manual Grids

The overlaid lines can be adjusted by dragging the specific Right Arrow again on
Vertical Ruler.

4 2008-hm-20-largejpg b ox
0

Right arrow or

dawn arrow for
antar s

Choose the Grids>No Grid command to remove the Manual Grids overlaid on the
video/image window. The menu will be checked.
Choose the Grids>Manual Grids command again (If it is unchecked) to display all the
previous Manual Grids overlaid on the video/image window. The menu will be
checked.

8.4.5 Grids>Remove All Grids(R)
Remove (Delete) all of the Manual Grids or Auto Grids overlaid on the image/video

window.

8.5 Best Fit(E) Num *
Choose View>Best Fit command to automatically resize the video/image to fit in the
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window.
Note: Choosing this command will enable View>Actual Size menu.

8.6 Actual Size(A) Num /
Note: This option will be disabled if the image is currently viewed at 100%. At any

other zoom ratio, View>Actual Size will be enabled.

Choose View>Actual Size command to set the active image to its Actual Size (e.g.
100%).

8.7 Full Screen(F) ESC
Choosing the View>Full Screen command will display the video window in full screen

style. Press the ESC button will restore the video window.

8.8 Track(k) V7
Note: If the video/image size is smaller than the window size. The track operation will

be disabled.

If the image's actual size is larger than the video/image window, check this
command to position the video/image that does not fit entirely within in the
video/image window. Its function is similar to the scroll bars. It is an alternative to
using the arrows on the scroll bars for positioning the video/image within the

window.

Checking the View>Track menu will change the cursor to Y and the button on the
toolbar will be checked.

Then keep down the mouse button to drag the region of interest on the video/image

to any location in the video/image window.
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9 Browse
9.1 Sort(S)
9.1.1 Sort>Sort by Names(N)

This command is for the Browse window only.
Sort the image files in order of names in the Browse window.

9.1.2 Sort>Sort by Type(T)

This command is for the Browse window only.
Sort the image files in order of file type in the Browse window.

9.1.3 Sort>Sort by Size(S)

This command is for the Browse window only.
Sort the image files in order of file size in the Browse window.

9.1.4 Sort>Sort by Width(W)

This command is for the Browse window only.
Sort the image files in order of image file width in the Browse window.

9.1.5 Sort>Sort by Height(H)

This command is for the Browse window only.

Sort the image files in order of image file height in the Browse window.

9.1.6 Sort>Ascending(A) Gl
This command is for the Browse window only.

Sort the image files in order of the Ascending mode (i.e. 1, 2, 3 and 4) in the Browse

window.

9.1.7 Sort>Descending(D) it
This command is for the Browse window only.

Sort the image files in order of the Descending mode (i.e. 4, 3, 2 and 1) in the Browse

window.

The Sort settings are saved until they are changed. For example, if you sort images in
the Browse window according to the Type, the images will remain sorted according to
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Type until the Sort settings are changed.

9.2 Icon(I)
9.2.1 Icon>Large Icons(L) @

This command is for the Browse window only.

The Thumbnail mode displays small preview images; you can select different view

modes in the Browse window.

Choosing the Icons>Large Icons will display the image files in Large Icon mode in the

Browse window.

9.2.2 Icon>Small Icons(S) =
This command is for the Browse window only.

The Thumbnail mode displays small preview images; you can select different view

modes in the Browse window.

Choosing the Icons>Small Icons will display the image files in Small Icon mode in the

Browse window.

9.3 Refresh(R) ﬂ F5
This command is for the Browse window only.
If the files under the Folders Sidebar’s directory are altered outside of ImageView,

after switch back to ImageView, one can Refresh the image files in the current

directory to update the Thumbnails with Browse>Refresh command.

9.4 Properties(P)eoeo

If an image file listed in the Browse window is highlighted. Choosing the
Browse >Properties command or clicking the selected file in the Browse window with
the right mouse button context menu Properties will bring up a Properties dialog as

shown below:
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& 10-2008-large,jpg Properties e & 10-2008-large.jpg Properties
General Security Details  Previous Versions General Security Details  Previous Versions
L] Object name:  D:\Demolmage'\Sample'.10-20084arge |
"\D-Zﬂmﬂarge.]pg | i g P rge jpg
Gi
Typeof file:  JPG File {jpg)
] B SYSTEM
Opens with:  Photos Change... B2 Administrators (DESKTOP-ILEO3R3\Administrators)
HR Users (DESKTOP-ILGD 3RS Users)
Location: D:\Demolmage™.Sample
Size: 87.4 KB (89,597 bytes) To change pemissions, ik Edit Edt..
Size ondisk:  83.0 KB (30,112 bytes) Permissions for Autherticated
Users Alow Deny
Created: Tuesday, May 17, 2016, 7:58:12 AM Full control
Modify
Modfied. Sunday. February 6. 2011, 3:10:40 PM Read & e
Accessed Tuesday, May 17, 2016, 7:58:12 AM Read
Write:
Atrbutes:  []Readonly [ Hidden Advanced Special pemissions
For special permissions or advanced settings,
click Advanced. fvioed
S SR
& 10-2008-large,jpg Properties ® & 10-2008-large,jpg Properties
General Securty Details  Previous Versions General Security Detals FPrevious Versions
A Previous versions come from File History or from
Propeny Value restore poirts
Description
Title:
Subject File versions:
Rt —
" MName Date modified
Tags
Comments There are no previous versions available
Origin
Authors
Date taken
Program riame
Date acquired
Copyright
Image
Image ID
Dimensions 700x 500
Width 700 pixels
Height 500 pixels
Umimmemd ol mimm s dimim. 0L i &
Remove Propeties and Personal Information Open [* | Restore |v
G | [ Gros |

The file Properties dialog including 3 pages. They are General, Security and Details
pages. These Property pages may depend on the operating system and we will not
discuss it in this help manual.
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10 Setup

10.1 Start/Pause(U) Pause

If the video in video window is playing, one can choose the Setup>Start/Pause
command to pause the video and choose the Setup>Start/Pause command again to

start the video again.

10.2 View Properties(V)eoeo Shift+V
The Setup>View Propertyeee will help you to understand the camera statistical
properties. Choose the Setup>View Propertyeee command to invoke the View

Property dialog as below:

B View Properties X
Property Value oK
Device Name EXIXK
Productld TP161226140048CB541A758DD44A038

Production Date 20151226
Hardware Version 1.0

Firmware Version 1.4.0.20160912
FPGA Version 0.0

Pixel Size (2.400, 2.400) pm
still Image Capture Yes

Still Image Width 3072

5till Image Height 2048

Video Width 3072

video Height 2048

The items in the dialog are described in the following table:

Device Name: Readable string to identify the name of the camera device;
ProductId: Unique ID to identify the camera device;

Still Image Capture: To identify whether or not the camera supports Still Image
Capture. Still Image Capture is used for high resolution camera to capture an image
with a different resolution from the video. This feature is mainly used to capture high
resolution image under low resolution video to compromise between the frame
speed and the image resolution;

Still Image Width: The to be captured image width;

Still Image Height: The to be captured image height;

Video Width: The actual video window video width;

Video Height: The actual video window video height;

Time (second): Seconds elapsed after the camera video has been started;

Frame: Frames acquired after the video has been started;
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Actual Frame Rate: The camera frame rate of the video stream, which is the Frame

by Time.

10.3 Video Overlay(O)eee
10.3.1 Video Overlay>Overlay
Choose the Setup>Video Overlayeee command, this will invoke a Video Overlay
dialog. Click the Overlay page on the Video Overlay dialog can set Scale,

Magnification, Date Time and Clarity Factor to overlay on the video window.

Video Overlay
Lozl Fosition: Left Top v Sackground: | Trensparent v
Marker FoSize: | Lerger v|  Fontweight: |Bold v
scale
[+ shaw [ ] Show magnification

Date Time

Type: ‘Short Date Format (Sample: 3/26/2015 08:24:54) v
Calor: O Default ¥
Clarity Factor
[+] shaw
Color: | | Default v
oK Cancel Apply 3 s >, T y =1
- e VAN /. L

The Position, Background, Font Size, Font Weight of the Scale, Magnification and
Date Time, and Clarity Factor can be defined together. Their Colors can be defined

separately.

Clicking the OK button and the Scale, Magnification and Date Time, and Clarity Factor

will be overlaid on the Video window.

The Clarity Factor can tell if the sample is in good focused state or not. The larger the

Clarity Factor, the better the sample focused.

Note: To enable the Scale bar, the Magnification must be defined and chosen first in
the Unit combo box on the toolbar. The Unit can be any unit except Pixel. There are
two methods to set the Unit, they are: a) Choosing the Unit in the Unit dropdown
combobox (Maemeterum) ] KA “% "y on the toolbar which is just on the left of the
Magnification dropdown list box; b) Choosing the Option>Measurementeee
command, a dialog called Measurement will bring up, click the Length Unit page and
check the Unit in the Current to set the Unit.

10.3.2 Video Overlay>Markereeoe
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Choose the Setup>Video Overlayeee command, this will invoke a Video Overlay
dialog. Click the Marker page on the Video Overlay dialog to set the Marker on the

video window.

The Video Marker type can be None, Cross, Rectangle, Circle, Cross+Rectangle, or

Cross+Circle. The Video Marker page is shown as below:

Video Overlay

i v — Er—

Marker Cross

Cross Width Cross Height Rectangle
Circle

50 = 50 = Cross+Rectangle
Cross+Circle

x Offset y Offset

0 z 0 :
Rotate: ) =

coor: [l Default N

Choosing “Cross+Retangle” in the Type combobox and Video Overlay: Marker dialog

will change to the following style:

Video Overlay

Overlar
Y -¢- Type: Cross+Rectangle v

Marker

Cross Width Cross Height

50 = 50 =3

Rectangle Width ~ Rectangle Height
50 S 50 S
x Offset y Offset

0 = 0 -

Rotate ) =

colr: [ Default v

Edit the Cross Width and Cross Height, Rectangle Width and Rectangle Height, x
Offset and y Offset, in their specific fields. Click Color to define the Video Marker

color.
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Click OK to end the Video Marker setup page and a Cross+Rectangle Marker will be

overlaid on the video window as shown below:

Click Cancel to cancel the Video>Overlay: Marker setup and return to the application
area, or Apply to overlay the Marker on the video window and keep the Video Overlay

dialog there for further setup.

10.4 Video Watermark(W)eee
Fig.1 shows a micro ruler. The dark lines can be extracted as Video Watermark and

overlaid on the video window. The steps are as follows:

Snap

1. Choose the Capture>Capture Image command or click = to capture the

micro ruler image as shown in Fig.1;
2. Choose the Process>Binaryeee command to binarize the image as shown in Fig.2;

3. Choose the Image>Adjust>Invert command to invert the image and choose the
Image>Color Quantizeeee command to convert the image to 24 bits as shown in

Fig.3. Choose the File>Save Aseee command to save the image in 24 bit BMP format;

(O T T

Fig.1 Captured Micro Ruler Fig.2 Micro ruler after being binarized
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Video Watermark

Image File: —

Di\Test Image\Sample\VideoWatermarker.bmp E
cancel

Transparent(%): 50 B

Tips

Use Shift + Up/Down/Left/Right arrow key to move the watermark.
Use Shift + Ctrl + Left/Right arrows key to rotate the watermark.

Fig.3 Inverted 24 bits image Fig.4 Video Watermark setup dialog

4. Choosing the Setup>Video Watermarkeee command and a dialog called Video

Watermark is brought up as shown in Fig.4. Click the _| button to locate the image
saved in step 3. Use the defaults Transparent (%)(50). If everything is ok, click OK
button. The final Video Watermark is overlaid on the video window as shown in Fig.5.

10X 100micron
| 2012-04;18 18:45:42

mhm! !m

i Uli]

Fig.5 Video Window with Video Watermark overlaid
10.5 Move Watermark(M)
10.5.1 Move to(W)eee

If there is Watermark overlaid on the video window, this menu will be enabled.

Choosing the Setup>Move Watermarkeee command will bring up a Move dialog.
Where one can enter the X: and Y: offset value in their fields for the desired pixel

move distances. The default X and Y offsets are 0;

g iux"li]l]mlcmn
2012-04- 19 18:46:57

Move
X 10 =
Yo R

10.5.2 Move to zero

If the Watermark on the video window was moved, this menu will be enabled.
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Choosing this menu will move the Video Watermark to its original coordinates (0, 0).

10.6 Rotate Watermark®
10.6.1 Rotate to(R)eee

If there is Watermark overlaid on the video window, this menu will be enabled.

Choosing the Setup>Rotate Watermark>Rotate toeee command will bring up a
Rotate dialog, where one can define an Angle to Rotate the Video Watermark a

specified angle around the video center (0, 0) (default value).

10% 100micron
2012-04-18 18:48:01

Rotate

Cancel

10.6.2 Rotate to zero
If the Video Watermark was rotated, the Rotate to zero menu will be enabled.

Choosing this menu will rotate the Video Watermark to zero degree.

10.7 Gray Calibration(G)eee
This function can make the image brightness to a desired value among various
scenarios in a specified area, achieving the continuity requirement of the observation.

The Gray Calibration steps are summarized as follows:

1. Click the Exposure & Gain group name on the Camera Sidebar to expand the

Exposure & Gain group, uncheck the Auto Exposure box (If it is checked).

Selected rectangle for Gray Calibration

Gray Calibration “

Average Gray: |102.6

(3 ‘

0X 20micron
85

2. Choose the Edit>Image Select command or click the Image Select button @ on
the toolbar to select a reference region, and choose the Setup>Gray Calibrationeee
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command. A dialog called Gray Calibration will be brought up to display the current
ROI Average Gray. Now the brightness of the microscope can be adjusted until the
Average Gray reaches to the desired value. Click "OK” to finish the calibration and

return to the application area. The current gray value here is around is 102.
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11 Capture
11.1 Capture Image(C) @ F8
During the video preview, you can always choose the Capture>Image Capture

command to capture the video image.

After the image is captured, the captured image will become the current active
window. The Capture>Capture Image menu will be disabled. If you wish to capture
image again, click the video window title to activate the video window and the

Capture>Capture Image menu will be enabled again.

Note: a) The “Snap” button &= on the Camera Sidebar can continuously snap
the image even if the video window is not activated. User can click this button on the

Camera Sidebar to capture image in quick style; b) Only when the video window is
active, the Capture>Capture Image menu will be enabled; c) If the Live and Snap
resolutions are different,ImageView need to switch the resolution from Live to Snap
resolution in the backstage to capture an image with Snap resolution. After the
Snap is finished, ImageView will switch back to the Live resolution to continus the

video stream process. This will take more time to capture a still image.

L
11.2 Start Time-lapse (Auto Capture)eee O]

Choosing the “Capture>Start Time-lapse (Auto Capture)eee” command will bring up

Time-lapse (Auto Capture) dialog shown below:

Time-lapse (Auto Capture)

Directory:
D:\Test Image El

File:

oK

Cancel

Name Format:  nnnn (sequence) v

File Prefix: tp
File type: pg v Option

Sample: tp-0001.png

Time slot(second): s -

[v] Total Images 100 £y

This function can capture a sequence of pictures with the specified time interval; you
can precisely set the time interval (2 to 3600 seconds) and the total number of
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images(1 to 9999).
Directory: The file Directory can be select by clicking on the Browse button;

File: The File name including Name Format, File Prefix, File type. It can be a

combination of File Prefix, Name Format and File Type and is shown in the Sample;

Time Slot(Second): Time slot(Second,2-3600S) is a time segment to capture an

image;

Total Images: Checking Total Images will enable its edit box. You can enter the Total
Images (1-9999) to be captured. ImageView will stop the Time-lapse capture

process automatically when the Total Images are reached;

If Total Images is unchecked, ImageView will capture the images continuously until
user choose the Capture>Stop Time-lapse (Auto capture) command again to stop

the Time-lapse capture.

Click OK to begin the Time-lapse capture, or Cancel to cancel the Start

Time-lapse(Auto Capture)eee command.

After the Time-lapse capture is started, the Capture>Start Time-lapse (Auto
Capture)eee menu will be changed to the Capture>Stop Time-lapse (Auto capture)

menu. Choosing this command will stop the Time-lapse capture.

There are a variety of image format available (they are bmp, jpg, png and tif) to save
the captured image. For example, when choosing jpg format, you can set the
parameters of “Option” to adjust its compression quality or encoding method. Please

check the File>Save Aseee menu for these details.

11.3 Start Record(V)eee F9
1. You can a) choose the Capture>Start Recordeee command; b) click “Record”
button & “*  on the Camera Sidebar ; c) use the shortcut key “F9” to start
recording movies. The will bring up a Video File dialog as below; Enter the video file
name under 1.Set the name for the captured video file field and click the Browseeee
button under 2 Select the directory for the video file item to locate the video file

directory. Click Next to the next step;
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Video File n

1. Set the name for the captured video file

test

2. Select the directory for the video file

Tip

The file name extension .wmv or .mp4 or .avi will be appended
automatically to the file name.

<ok e | | cone

2. Clicking Next on the Video File dialog will display the Video Format and Encoder
dialog. The video format can be wmv/asf(recommended) H264(recommended) or

avi; Click Back to return to the Video File dialog, or Next to the next step;

Video Format and Encoder

Please select the video format and encoder
(®)wmv (recommended)
(7) H264 (recommended)

Oan

Py | [

3. An Encoder dialog will be brought up. Here you can select the Encoder format, set
the Bitrat(Kbps)(256-16384), Quality (1-100) and Key Frames Spacing (1-30). Click

Back to return to the Video Format dialog, or Next to the next step;
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Encoder
Encode Parameter
Bitrate (Mbps) 60 v
Quality (1-100) 100 =)
Key Frames Spacing: 4 2 Second(s)

<ot s coa

4. A dialog called Start to Record will be brought up. Here you can check Time Limit
(Minutes 1-1440) and enter recording time (If checked); Input Time-lapse(1-100).
There is a Summary text to display what you have been defined. Click Back to return
to the Encoder dialog, or Finish to end the setup;

Start to Record

[“]Time Limit (Minutes) 1

o] e

Time-lapse 1

Summary

Format: wmv
File: D:\Test Imageltest

Encoder: Windows Media Video 9
Quality: 100%

Bitrate: 16.00 Mbps

Key Frames Spacing: 4 (Second(s))

Record

5. After the Video capture is started. The Q - button on the Camera Sidebar

will become & | clicking ‘©_"_ | will stop the capture process,

otherwise ,it will stop untill the Time Limit is reached. After the Video capture process

o

is finished. The on the Camera Sidebar will become for the

future Record process;

6. You can choose the File>0Open Videoeee command to display the captured video
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file in the video window;

11.4 Start Broadcast(B)eee
Start a network broadcasting service. Select the Port and Encoder before start the
service. After that, ImageView will start broadcasting the video that is opened by
ImageView locally via the specified Port and Encoder. The other users could share the
video by open broadcasting function.

Choosing Capture>Start Broadcasteee will invoke a Broadcast Parameters dialog as

below:

Broadcast Parameters

Port: = E

[[]save the content to file smultaneously

Port: Set the Port and;

Save the content to file simultaneously: Check or uncheck Save the content to file

simultaneously;
Next>: Clicking the Next> button will invoke a Encoder dialog as shown below:

Encoder

Encoder: Windows Media Video 3 v

Encode Parameter

GLEebes) 153 [+ Defaults

Quality (1-100): 100

Key Frames Spacing 1 | Secondfs)

This dialog is used for the setup of video Encoder parameters for broadcasting. This
setup dialog is just the same as those of Capture>Start Recordeee setup dialog. It

mainly including Encoder, Encode Parameter such as Bitrate, Quality(1-100), Key
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Frame Spacing in second et al.

Next>: Clicking the Next> button again will invoke the Start to Broadcast dialog.
Here, one can set the broadcast Time Limit in minutes. The Encoder parameters are

also listed in the Summary window for reference;
<Back: Clicking <Back will return to Broadcast Parameters dialog;

Cancel: Clicking will end the Start Broadcasteee command and return to the video

window.

Start to Broadcast

[ Time Limit (Minutes): 1

Summary
Encoder: Windons Media Video 9
Qualty: 100%
Bitrate: 1536 Kbps
Key Frames Spading: 1 {Second(s))

<o ==

<Back: Clicking <Back will return to Encoder dialog;

Cancel: Clicking will end the Start Broadcasteee command and return to the video

window;

Finish: Clicking the Finish button will start the broadcasting process and it will end up

the process when it reaches to the Time Limit;

See File>0Open Broadcasteee to understand the Start Broadcast function.
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12 Image
12.1 Mode(M)

12.1.1 Color Quantize(Q)eee
The Color Quantizeeee command is widely used to change the image bit. ImageView
supports the mutual changes among 24 bit, 8 bit, 4bit or 1 bit images.

When the Colour Bits dialog is opened, the default colorgits Il
checked color bits is the current image's color bit. C‘;;";
Check the desired bit and click OK to end the Osbis
command. The image will converted to the g‘”"‘s

1bit

selected color bits in the image window.

12.1.2 Gray Scale(G)
Choose the Gray Scale command to convert a color image (true color image or index
color image) to a gray scale image. If the original image is 24 bit, the new image is
8 bit. Otherwise the bits of the image will not be modified.

12.1.3 Contrast Preserving Decolorization©
Choose the Image>mode>Contrast Preserving Decolorization command can convert
the color image into gray image with contrast preserved. The following pictures (a) is
the original microscopic image, (b) is the gray image produced by traditional method,

(c) is the gray image produced by Contrast Preserving Decolorization.

(@)

(b) Traditional method (c) Contrast Preserving Decolorization
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12.2 Adjust(A)
12.2.1 Brightness/Contrast(A)eee
The Image>Adjustment>Brightness/Contrasteee command offers simple
adjustments to the tonal range of an image. This command makes the same
adjustment to every pixel in the image. The Brightness/Contrast command does not
work with individual channels and is not recommended for high-end output because

it can result in the loss of details about the image.

Adjust Brightness/Contrast

Brights
oo ;

Cancel
Contrast 9

Brightness: Dragging the slider bar to the left decreases the level and dragging it to
the right increases the level. The numbers on the right of the slider bar displays the
Brightness value. Values can range from -100 to +100. Default is 0;

Contrast: Dragging the slider bar to the left decreases the level and dragging it to the
right increases the level. The numbers on the right of the slider bar displays the

Contrast value. Values can range from -100 to +100. Default is 0;

12.2.2 Color(O)eee
Choose the Image>Adjustment>Coloreee command to modify the overall mixture of

the colors in an image.

There are four color modules: RGB, CMYK, HIS and HLS.

Adjust Color n

R (i OK

G 0 Cancel

Color Modules
RGB: ImageView uses the RGB model. It assigns an intensity value to each pixel
ranging from 0 (black) to 255 (white) for each of the RGB components in a color
image.

For example, a bright red color might have an R value of 246, a G value of 20, and a
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B value of 50. When the values of all three components are equal, the result is a
shade of neutral gray. When the value of all components is 255, the result is pure

white; when the value is 0, pure black.

RGB images use 3 channels to reproduce up to 16.7 million colors on-screen. In
addition to being the default mode for new ImageView images, the RGB mode is used
by computer monitors to display colors. This means that when working in color modes
other than RGB, such as CMYK, ImageView uses RGB mode for display on-screen.

Although RGB is a standard color mode, the exact range of colors represented can

vary, depending on the application or display device.

CMYK: The CMYK mode is based on the light-absorbing quality of ink printed on
papers. As white light strikes translucent inks, certain visible wavelengths are
absorbed while others are reflected back to the eyes.

Adjust Color

® 0 OK

M o Cancel

Color Modules
In theory, pure cyan (C), magenta (M), and yellow (Y) pigments should combine to
absorb all light and produce black. For this reason these colors are called subtractive
colors. Because all printing inks contain some impurities, these three inks actually
produce a muddy brown and must be combined with black (K) ink to produce a true
black. (K is used instead of B to avoid confusion with blue.) Combining these inks to

reproduce color is called four-color process printing.

The subtractive (CMY) and additive (RGB) colors are complementary colors. Each

pair of subtractive colors creates an additive color, and vice versa.

HSI: Based on the human perception of color, the HSI model describes 3

fundamental characteristics of colors:
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Adjust Color n

H 0 OK

s ] Cancel

Color Modules
Hue is the color reflected from or transmitted through an object. It is measured as a
location on the standard color wheel, expressed as a degree between 0° and 360°. In
common use, Hue is identified by the name of the color such as red, orange, or

green.

Saturation, sometimes called chroma, is the strength or purity of the color.
Saturation represents the amount of gray in proportion to the hue, measured as a
percentage from 0% (gray) to 100% (fully saturated). On the standard color wheel,
Saturation increases from the center to the edge.

Intensity is the relative lightness or darkness of the color, usually measured as a
percentage from 0% (black) to 100% (white).

HLS: The HLS model is very similar to the HLS color model. The main difference
between them is the calculation used to produce the brightness value. In the HLS
model, a pixel's brightness (L) is derived from its three (R, G and B) color values. In
the HLS model, a pixel's brightness (L) is determined by the minimum and maximum

values of its three color values.

Adjust Color
H 0 0K

L ] Cancel

Color Modules

The values beside the slider bar show the color changes in various color channels.
For RGB channel values, they are range from -100 to +100. Default is 0;

For CMYK channel values, they are range from -100 to +100. Default is 0;
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For HSI channel values, the H value can range from -180 to 180, the S value is range
from -275 to 275, and the I value is range from -442 to 442.Default is 0;

For HLS channel values, the H value is range from -180 to 180, the L value is range
from -100 to 100, and the S value is range from -100 to 100. Default is 0;

12.2.3 HMSeoeo
Choose the Image>Adjustment>HMSeee command to adjust the HL (Highlight), M
(Midtone), and S(Shadow) parts of the image. Each part's value ranges from -100 to

100. This command is only available for 24 bits true color image.

Hight Light/Midtone/Shadow n

HL
n oK

M Cancel

16

o

12.2.4 Curve(U)eeeo
Choose the Image>Adjust>Curveeee to adjust the entire tonal range of an image.
But instead of making adjustments using only three variables (Highlight, Midtone,
Shadow), one can adjust any point on the curve along a 0-255 scale while keeping up
to any other values constant. One can also use Curve to make precise adjustments

for individual color channels on an image. The Curve dialog is shown below:

Curve n

Reset

Hightlights

Apply

OK

Midtones Cancel

Shadows g

] Grid [~ ||| o 2|

Horizontal Axis: The horizontal axis of the graph represents the original intensity

values of the pixels (Input levels).
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Vertical Axis: The vertical axis represents the new color values (Output levels). In the

default diagonal line, all of the pixels have identical Input and Output values.

Curve area: Area (specified with the blue rectangle) to setup a map between input

and output;

a) When you open the Curve dialog you see, perhaps surprisingly, not a curve
but a straight line. As a default, the input values are the same as the output, so
there’s no change;

b) By clicking in the center of the line and dragging upwards, we make our first
curve. Raising the curve increases the overall brightness of the scene.

c) Conversely, clicking in the center and dragging downwards lowers the
brightness, producing an image that’s darker overall;

d) As well as clicking in the center, we can also adjust the endpoints. Clicking the
top right point and dragging down will limit the brightest part of the image,
reducing contrast.

e) If we drag that top right point to the left rather than down, we produce the
opposite effect—increasing the contrast of the image. This is a very useful and
controllable quick fix;

f) By dragging the top and bottom points towards the center, we create a stylized,
posterized effect that turns any photograph into more of a graphic object.

g) Click once in the center of the RGB curve to "pin" that midpoint; now drag just
the top half of the curve to make this S shape, and the result is to increase the
overall contrast.

h) You can add up to any control points to the curve, locking those values. To
remove a control point, 1)drag it off the graph or 2)click the right mouse button

on that point. You cannot delete the endpoints of the curve.

Curve = Curve = curve = Curve =
= e wet L] mesa =
w P Ay o o
Ve =
cancl d Cancl { /" Canesl 1 5 T cancel
~ pa [t
- =
T 7
- Fai= ~ 1 a) ° Fa= ~ 1 b) | T ~ c) | T o d)
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Curve = Curve = curve [ | Curve [ |
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Grid: Check to overlay the grid on the Curve window;

Channel LI To adjust the color balance of the image, check the channel(R, G
or B) from the Channel button. Check the white button to select RGB channels at the
same time, which is located on the left of the R (Red), G (Green) and B (Blue)

buttons;

Curve W.: Click the Curve with your left mouse button, a spline curve (straight line)
will setup the initial input-output relation. Click on the Curve will mark the Curve with

a point. The point number can be any as long as it can be inserted on the Curve. Drag
the marked point until the image looks satisfactory. The point can be deleted by

move the mouse on it and click the right mouse button on it.

Pencil Jﬂ: Check the pencil button at the bottom of the dialog, and use your left
mouse button to draw a new arbitrary Curve in the Curve area.

Reset: Click the Reset button will reset the Curve to the initial straight line.
Apply: Apply current Curve map on the image.

12.2.5 Filter Color(F)eee
Choose the Image>Adjustment>Filter Color command to filter a special color
channel from a color image. Check either Red, or Green, or Blue color to filter. For
every pixel, if check Red color to filter, only information about the red channel will be

discarded, and Green and Blue information will remain there.

Select Color n
Color

(®)Red

. Cancel
(_)Green

() Blue
See Image>Extract Coloreee for another color operation.
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12.2.6 Extract Color(E)eee
Choose the Image>Adjustment>Extract Coloreee command to extract a special color

channel from a color image. Check either Red or Green, or Blue color to extract.

For every pixel, if selecting Red color to extract, only information about the red

channel will be kept, and Green and Blue information will be discarded.

Select Color “
Color

(®)Red

B Cancel
Oereen

() Blue

See Image>Filter Coloreee for another color operation.

12.2.7 Invert(I)
Choose the Image>Adjustment>Invert command to reverse the pixel values of the

active image without going through the lookup table.

12.2.8 Edge Preserving Smooth(S)eee
Edge Preserving Smooth is an image processing technique that smooth away
textures whilst retaining sharp edges. Examples are the Bilateral filter, the Guided

filter and Anisotropic diffusion.

Choose the Image>Adjust>Edge Preserving Smootheee command can smooth the

entire image and preserve the edge of image, as shown below:

Edge Preserving Smooth n
Filter
(®)Recursive () Normalized Convolution
Spatial Sigma: 60
Range Sigma: 40

Edge Preserving Smooth function provide two kinds of filter including Recursive and

Normalized Convolution filter, and the default filter is Recursive.
ImageView use Spatial Sigma and Range Sigma to define the filter kernel size. The
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bigger the two parameters, the stronger the image smoothed, vice versa.

12.2.9 Detail Enhance(D)eee
Choose the Image>Adjust>Detail Enhanceeee command can enhance the detail in
the image, as shown below:

Detail Enhance
Spatial Sigma: 60
Range Sigma: 40

ImageView choose Spatial Sigma and Range Sigma to define the kernal size of detail
enhance algorithm. The bigger the 2 parameters, the stronger the enhanced image

and vice versa.

The following picture is the detail enhanced image for reference with default
parameter.

a)Original image and b)Enhanced image
12.2.10 Auto Level(L)

The Image>Adjustment>Auto Level command moves the level's sliders

automatically to set highlight and shadow. It defines the lightest and darkest pixels

in each color channel as white and black and then redistributes the pixels' color

values proportionately. Since Auto Level adjusts each color channel individually, it

may remove or introduce color casts. The Auto Level command moves the level's
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sliders automatically to set highlight and shadow. It defines the lightest and darkest
pixels in each color channel as white and black and then redistributes the pixels' color
values proportionately. Since Auto Level adjusts each color channel individually, it

may remove or introduce color casts.

By default, this feature clips the white and black pixels by 0.5%--that is, it ignores
0.5% of the lightest pixels and 0.5% of the darkest pixels when identifying the
lightest and darkest pixels on the image. Choose the Options>Auto Correctioneee
command to modify this default setting. This ensures that white and black values are
representative without being determined by extreme pixel values. The Auto>

Correctioneee dialog is shown below:

Auto Range
Auto Level

Low Clipping High Clipping oK

0.005 5 0.005 |3

Auto Contrast
Low Clipping  High Clipping

0005 (2

0005 &

The Image>Adjustment>Auto Level command gives good results when an image
with an average distribution of pixel values needs a simple contrast adjustment or
when an image has an overall color cast. However, adjusting the Curves manually is

more precise.
See Image>Adjustment>Auto Contrast for another auto adjust command.

12.2.11 Auto Contrast(T)
The Image>Adjustment>Auto Contrast command automatically adjusts the overall
contrast and mixture of colors in an RGB image. Since it does not adjust channels
individually, Auto Contrast does not introduce or remove color casts. It maps the
lightest and darkest pixels in the image to white and black, which makes highlights

appear lighter and shadows appear darker.

When identifying the lightest and darkest pixels on an image, Auto Contrast clips the

white and black pixels by 0.5%--that is, it ignores the first 0.5% of either extreme.

Choose the Options>Auto Correctioneee menu to modify this default setting. This
ensures that white and black values are representative without being determined by

extreme pixel values. The Auto Correctioneee dialog is shown below:
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Auto Range
Auto Level

Low Clipping High Clipping 0K

Cancel

0005 [

0.005 [
Auto Contrast

Low Clipping High Clipping
0.005 = 0.005 =

The Auto Contrast command can improve the appearance of many photographic or

continuous-tone images. It does not improve flat-color images.
See Image>Adjustment>Auto Level for another auto operation.

12.3 Rotate(R)
Choose the Image>Rotate command to rotate the entire image. One has the

following submenus:

12.3.1 90(CW)

Rotate the image clockwise by a quarter-turn.

12.3.2 180(CW)
Rotate the image clockwise by 180 degrees.

12.3.3 270(CW)

Rotate the image clockwise by 270 degrees.

12.3.4 Arbitrary(A)eee
Rotate the image by a specified angle. If choosing this option, enter an angle
between 0 and 360 degrees in the angle text box, and check CW or CCW to rotate
clockwise or counterclockwise. For the Arbitraryeee operation, it will invoke an Image

Rotate dialog like below:

Image Rotate

Angle

®cw Cancel

oK

Cleew

Quality Bilinear v
Degree: The degree that the image to be rotated.

CW: Rotates the image clockwise.
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CCW: Rotates the image counterclockwise.

Quality: One can select one of the three methods for the image rotation among

Nearest Neighbor, Bilinear, and Bicubic. The default is Bilinear.

12.3.5 Flip Horizontal(H) du
Reverses the image in the application area so that the top right corner of the original

image is now the top left, and the top left corner of the original image is now the top

right corner.

12.3.6 Flip Vertical(V) <
Reverses the image in the application area so that the top right corner of the original
image is now the bottom right corner, and the top left corner of the original image is

now the bottom left corner.

12.4 Crop(C) Shift+C
Choose the Image>Crop command to remove the portions of an image that does not

want so that the focus is on the part of the image that is left. This document instructs

users on how to Crop an image in ImageView.

1. Choose the Open Imageeee command to open an image to Crop;

2. Choose the Edit> Image Select command or click the Image Select button = on
the Toolbar, the cursor will change to a small cross.

3. Move the cursor over the image to the desired location, click the mouse button and

hold it down to mark the first position.

4. Drag the mouse over the part of the image to be kept, a dotted rectangle appears

around the selection and release the left mouse button.

5. Optional 1: To move the rectangle: a) Move the mouse over the selected area and
when it becomes a move cursor, click and hold the left mouse button;b) Drag the

selected area to the desired position.
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6. Optional 2: To change the size of the rectangle: a) Put the mouse cursor on one of
the handles that appear on the edges of the selected area; b) Click and hold the
mouse button; c) Drag the box to the desired size.

Note: Each of the handles that appear on the edges of the box sizes the box
differently.

7. To Crop the image, choose the Image>Crop command or press Shift+C buttons.

Note: If the selected area is on the video, choosing the Image>Crop command will
capture the selected area and display it on a new image window.

12.5 Image Scale(S)eee
Choose the Image>Image Scaleeee command to change the image to a specified
size. This process actually changes spatial resolution by adding (replicating) or
removing (decimating) pixels to achieve the specified dimensions.

Width and Height: When choosing the Image Scale command; the dialog displays
the dimensions of the original image in pixels. The Width and the Height can be set
on the new image by adding or removing pixels. If Constrain Proportions is checked,
the Width and Height will stay proportionate to each other. If Constrain Proportions is
unchecked, the Width and the Height can set independently, but this will distort the

image.
Scale Image
Constrain Propartions
Cancel
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Reset: Reset the image Width and Height to the original ones.

Constrain Proportions: To maintain the current proportions of pixel Width and Height,
check Constrain Proportions. This option automatically updates the Width as the
Height is modified, and vice versa. Otherwise, uncheck the Constrain Proportions

button.

Scale method: There are 3 options for the Scale method. They are: Nearest Neighbor,

Bilinear, and Bicubic. The default is Bilinear.

12.6 Histogram(H)eee Shift+H
A Histogram illustrates how pixels in an image are distributed by graphing the

number of pixels at each color intensity level. The Histogram shows whether the
image contains enough detail in the Shadows (shown in the left part of the
Histogram), Midtones (shown in the middle), and Highlights (shown in the right part)

in order to make a good correction.

The Histogram also gives a quick picture of the tonal range of the image, or the
image key type. A low-key image has detail concentrated in the shadows, a high-key
image has detail concentrated in the highlights, and an average-key image has detail
concentrated in the Midtones. An image with a full tonal range has a number of pixels
in all areas. Identifying the tonal range helps determine the appropriate tonal

corrections.

Choose the Image>Histogrameee command to open the Histogram dialog as shown

below.

Depending on the image’s color mode, choose R, G and B, or Luminosity to view a

composite Histogram of all the channels.

If the image is RGB true color, choose Luminosity to display a Histogram representing

the luminance or intensity values of the composite channel.
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Histogram “ Histogram “
Channel Luminosity v Channel Red v
I I
Level: 26 Pixels: 13450456 Level Pixels: 13459456
Count: 37120 Count:
Percentile: 4.32% Percentile:
Histogram ﬂ Histogram n
Channel Green v Channel Blue v
|u||||“||HH‘“‘”‘”"H““"””“"L ..|u|||||||||”||”|||““| ||||L
I [ —

Level: Fixels:
Count:

Percentile:

13459456

Level: Pixels:
Count

Percentile:

13459456

Percentile:

Do one of the following:

Histogram.

underneath the pointer.

the individual color channels in color.
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Level: Displays the intensity level of the area underneath the pointer.

If the image is RGB true color, choose R, G and B to display a composite Histogram of

To view information about a specific pixel value, place the mouse pointer in the

To view information about a range of values, click down the left mouse button and
drag it in the Histogram to highlight the range.

The dialog displays the following statistical information below the Histogram:

Pixels: Represents the total number of pixels used to calculate the Histogram.

Count: Shows the total number of pixels corresponding to the intensity level

Displays the cumulative number of pixels at or below the level
underneath the pointer. This value is expressed as a percentage of all of the pixels in
the image, from 0% at the far left to 100% at the far right.
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12.7 Resolution(R)eee
Choose the Image>Resolutioneee command to set the image Resolution to calibrate
the spatial scale. By default, ImageView expresses spatial measurements in terms of
pixels. This Resolution command is used to change the terms in which ImageView
reports such measurements. This command should be run first in order to measure
objects in terms of units other than pixels.

Resolution setting n
1616097349.00 | Fixels/ | Meter (m) v

X: Horizontal PPM (Pixels per meter) of current Resolution.
Y: Vertical PPM (Pixels per meter) of current Resolution.

Note: The resolution in the Y direction need not to be filled. ImageView will always let
it equal to the X direction.

After the new Resolution is set, all of the measurements will be calculated according
to the new Resolution. (See more in the Measurements and
Options>Measurementeee menu).

12.8 Mosaic(O)eee

Mosaic is a process that can combine the images opened into a new image. This will
open the following dialog:

Mosaic Images n

Image List | Parameters

Available Images Selected Images

DemoBlue.TIF = DemoBlue.TIF

DemoGr. I ] Add DemoGm.TIF

DemoRed.TIF DemoRed.TIF

0006 0006

VideowaterMarker.bmp Add all>>

15th2004extarge.jpg

Remove

Clear
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Mosaic Images n

Image List| Parameters

Title Title
Footer

Arrangement

Rows 2 Row spacing 1

[Jaute

Columns |2 ol spacing 1
System font Font...

Page Size

(®) Default size Width |1024 Height |1280

(_) Use printer's size 8267 % 11692 Change.

| Use 1/4 Size

cance Apply

ImgList page

Available Images: Images opened with ImageView.

Add>>: Add the opened images to the Selected Images list view

Add All>> Add all the opened images to the Selected Images list view
Remove: Select the images and remove them from the Selected Images list view.
Clear: Remove all the images from the Selected Images list view.
Property page

Title: The title wanted

Footer: The footer wanted

Arrangement: The Mosaic Images distribution on the page

PageSize: The page size for the Mosaic Images

If everything is set, click OK to end the Mosaic Images operations and a new image
window will be displayed and the final results should be:
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13 Process
13.1 Stitch(T)eee = shift+T
Image stitching or photo stitching is the process of combining multiple photographic
images with overlapping fields of view to produce a segmented panorama or
high-resolution image. Commonly performed through the use of computer software,
most approaches to image stitching require nearly exact overlaps between images
and identical exposures to produce seamless results. Some digital cameras can stitch
their photos internally. Image stitching is widely used in today’s world in applications
such as “Image Stabilization” feature in camcorders which use frame-rate image
alignment, high resolution photo mosaics in digital maps and satellite photos,
medical imaging, multiple image super-resolution, video stitching and object

insertion.

ImageView also integrated this function into it. It includes Video Stitch, Image Stitch
and Browse Window Stitch.

13.1.1 Video Stitch
When the video window is active, choosing the Process>Stitcheee command will

invoke the video Stitch dialog as below:

Capture Images

Snap
Reset

Snap: 4

Next > Finish Cancel

Snap: Click to capture image from camera. One should try to move the slide to a prop
position to capture the desired images. In the moving process, the next image
should have some overlaid area with the previous left or up image to ensure the

success of the stitching process.
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Reset: When an image or images is or are captured, the Reset button will be enabled,
click Reset will remove it or them from the memory; It will be disabled when there is

no captured image;

Snap: The captured images from the camera;
Cancel: Click to cancel the stitching process;
Next>: Click Next> will step to the next step;

Finish: Click Finish will accept the other Default setup and begin to stitch the

captured images according to the above setup.

Stitching Method

Stitch

Panorama Straighten: Horizontal v
Projection Type: ylindrical v
Seam Finder: Graph Cut Color v
Exposure Compensation: Blocks Gain v
Bundle Adjust: Ray adjust v

Defaults

T ] [

Panorama Straighten: The image stitching direction. It can be Horizontal, Vertical

and None. Default is Horizontal;

Projection Type: For image segments that have been taken from the same point in
space, stitched images can be arranged using one of various map projections.
ImageView including Plane, Cylindrical, Spherical, Fisheye, Stereographic, Mercator

or Transverse Mercator map projections. The Default is Cylindrical;

Seam Finder: Seam Finder method, ImageView including None, Voronoi Diagram,
Graph Cut Color or Graph Cut Color Grad. Default is Graph Cut Color;

Exposure Compensation: Exposure Compensation is required between images to

minimize exposure differences. ImageView including None, Gain or Blocks Gain
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Exposure Compensation method. Default is Blocks Gain;

Bundle Adjust: Bundle Adjustment can be defined as the problem of simultaneously
refining the 3D coordinates describing the scene geometry as well as the parameters
of the relative motion and the optical characteristics of the camera(s) employed to
acquire the images, according to an optimality criterion involving the corresponding
image projections of all points. ImageView including Ray adjust or Reprojection error

adjust method. Default is Ray adjust;
<Back: Click <Back will return to the previous setup page;
Next>: Click Next> will step to the next step;

Finish: Click Finish will accept the other Default setup and begin to stitch images

according to the above setup;
Cancel: Click to cancel the stitching process;

Stitching Parameter
stitch
Match Confidence: 65
Panorama Confidence: 100
Match Strength: 25

Blend Strength: 5

Defaults

< Back h

Match Confidence: 1~100, Default is 65;

Panorama Confidence: 1~100, Default is 100;

Match Strength: 0~100, Default is 25;

Blend Strength: 0~100, Defaults is 5;

Defaults: Click Defaults will set all the parameters to the Default ones.
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<Back: Click <Back will return to the previous step;

Finish: Click Finish will begin to stitch images according to the above setup. After the
Finish button is clicked, ImageView will start to stitch and a progress dialog will be

shown to indicate the progress of the process.
Cancel: Click to cancel the stitching process;
Progress

The final stitched image will be created in a new image window..

In the stitched image, there are some black areas; these are happened when there
are translations among the edge images in both directions.

13.1.2 Image Stitch
If images are opened in ImageView, for example 0001.jpg, 0002.jpg, 0003.jpg,
0004.jpg are opened as shown below:

85



Process

s .’f - ,s'g
AR

0001,jpg
TR
p >
T

0003,jpg

Choosing the Process>Stitch command will invoke the image Stitch dialog as shown

stitch Stitch =]
Available Images Selected Images Available Tmages Selected Images
000Lpg - 0001 jpg = 0004.jpg
0002.jpg Add>> 0002.pg Add>>
0003.jpg 0003.jpg

0004.]

0004.Jpg Al g Add all>>

Remoe

<Back Next > <oack | Nee> || Amsh || Cancel

a) Available Images and b) Selected Images
Available Images: The images opened by ImageView; Here, 4 images are listed in the
list box. One can click the image file name to select the files to be added to the
Selected Images;

Selected Images: The images selected for stitching; Using Add>> to add the
Available Images to this list box;

Add>>: When an image or images is or are selected and highlighted in the Available
Images window, the Add>> will be enabled. Click Add>> will add it or them into the
Selected Images list box;

Add All>>: Click Add All>> will add all of the Available Images into the Selected
Images list box;
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Remove: When an image or images is or are selected and highlighted in the Selected
Images list box, the Remove button will be enabled, click Remove will remove it or
them from the Selected Images list box;

Clear: Used to clear all of the images in the Selected Images list box. When no image
in the Selected Images list box, it will be disabled;

Cancel: Click to cancel the stitching process;

Finish: Click Finish will accept the other Default setup and begin to stitch the

captured images according to the above setup;
Next>: Click Next> will step to the next step;
The other Next> steps are just the same as those of the Video Stitch process.

The final stitched image will be created in a new image window as shown below:

The Stitched image

In the stitched image, there are some black areas; these are happened when there
are translations among the edge images in both directions.

13.1.3 Browse Window Stitch
Click the Folders Sidebar to activate it. Double-click the right directory to show the
images under the directory in the Browse window. Choosing the image files to be
stitched and then clicking the right mouse button will display the context menu,
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choose the Stitch submenu to start the image stitch operation (One can also
choosing Process>Stitch to do the same operation after the files are selected in the
Browse window)

Tk - o IEd
File Edit View Browse Setup Capture Image Process Layer Measurements Options Window Help
& | riel v| NA v| 90% vtk 2. - . . 2
Folders vaHE« Browse b x
(IO 1]
\t ). EDOF ~ Onen
). HDR
-1 ImageCount { Delete File
- ). Sample
@ Stack Sort 4
=~ b Stitch Icons 4
J, stitch_01
B ) test! [Z] Refresh 5
-0 test2 Properties.
G- test3
G- ). testd G 34 Stitch... Shift+T
B ol (@ un. [Rlay. [[EVe wi| High Dynamic Range (HDR)...
[E Measurement Sheet < EDF.. Shift+F
24 bpp 1360 x 1024 34,4

After the Stitch command is selected, a dialog called Stitch will pop up as shown

below.
Stitch
Fanorama Straighten: Horizontal v
Projection Type: Cylindrical v
Seam Finder: Graph Cut Color v
Exposure Compensation: Blocks Gain v
Bundle Adjust: Ray adjust v

Defaults

o o] [ooen

The Stitch dialog and the other Next> steps are just the same as those of Video
Stitch. The final stitched image will look like below:

In the stitched image, there are some black areas; these are happened when there
are translations among the edge images in both directions.
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The stitched image

13.2 High Dynamic Range(HDR)e oo -

High Dynamic Range can fuse a sequence of multi-exposure images into a high
dynamic range image. The user can capture the multi-exposure images by adjust the

aperture of microscope or the exposure and the gain.

ImageView support High Dynamic Range function in 2 modes, which is shown in the
following part.

13.2.1 Browse window high dynamic range operation
In browse window, the user can choose images to be fused directly and there is no

need to open any image to save the system cost.

When the browse window is active, the user can choose low dynamic range images
by Ctrl+A or Ctrl+mouse left button.

Click the right mouse button on the Browse window will invoke the context menu.
Choose High Dynamic Range (or choose Process>High Dynamic Range), ImageView
will begin to calculate according to the selected images. The high dynamic range
image will be displayed in a new image window when the progress bar reaches to the
end.

13.2.2 Image window high dynamic range operation
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When the image window is active, the user can choose images from opened window
to generate high dynamic range image. This mode will lead the system to overhead

when many images were opened

(1).png (2).png (3).png

Opened image for HDR operation
Choose Process>High Dynamic Range command to fuse captured or opened images
to high dynamic range image., a dialog is called High Dynamic Range will be shown

as below:
High Dynamic Range (HDR) n High Dynamic Range (HDR)

Available Images Selected Images Available Images Selected Images
(1).png . (1).png R (1).png
(2)png ikl (2)ng d (2).png
(3).png (3).png (3)-png

Add all>>

Remove Remove

Clear Clear

a)Available Images and b) Selected Images

We assumed that 1.jpg, 2.jpg, 3.jpg 3 images have been opened.

Available Images: The images opened by ImageView; Here, 3 images are listed in the
list box. One can click the image file nhame to select the files to be added to the

Selected Images;

Selected Images: The images selected for stitching; Using Add>> to add the

Available Images to this list box;

Add>>: When an image or images is or are selected and highlighted in the Available
Images window, the Add>> will be enabled. Click Add>> will add it or them into the
Selected Images list box;
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Add All>>: Click Add All>> will add all of the Available Images into the Selected
Images list box;

Remove: When an image or images is or are selected and highlighted in the Selected
Images list box, the Remove button will be enabled, click Remove will remove it or
them from the Selected Images list box;

Clear: Used to clear all of the images in the Selected Images list box. When no image
in the Selected Images list box, it will be disabled;

Cancel: Click to cancel the stitching process;

OK: Click OK will accept the other Default setup and begin to stitch the captured
images according to the above setup.

The HDR result

I

13.3 EDFeee Shift+F

13.3.1 Browse Window EDF
Click the Folders Sidebar to activate the Browse Window. Double-click the directory
to display the images in the Browse window in Icon mode. Choosing the image files
to be fused with Ctrl+A(Select all files in the current directory) or Ctrl+left mouse
button to select the image one by one and then clicking the right mouse button will
display a context menu, choosing the EDF submenu to start the image fusion process
(One can also choose Process>EDFeee command to do the same operation after the

image files are selected in the Browse window).
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After the Process>EDF command is chosen, a dialog called Select Method is pop up
as follows:

Select Method

Maximum Contrast ]

Description

Weighted Average method produces a soft fusion result but may miss
detail. This method often gives superior results to FFDSSD method with deep
stacks, such as images produced by microscopy. It is worth noting that images
10 be processed must be in Z order (closest to furthest of furthest to closest
with the microscope objective lens relative to sample on the stage).

Maximum Contrast method is similar with weighted average method,
and the input images must be in Z order as well. The difference is that the
maximum contrast method may loose some detal though what detail is
preserved will be sharper. Maximum contrast method is a preferred method of
EDF.

FFDSSD is a method that does filtering in the frequency domain using
Fast Fourier transform (FFT) and does synthesis in the space domain. FFDSSD
can be used for images having misalignment. Users can manually or
automatically select reference images to make input images aligned.

There are 3 EDF methods in ImageView, they are:

Maximum Contrast: Maximum Contrast method is similar with weighted average
method, and the input images must be in Z order as well. The difference is that the
maximum contrast method may lose some detail however the preserved details will
be sharper. Maximum Contrast method is a preferred method in these 3 EDF
methods.
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Weighted Average: Weighted Average method produces a soft fusion result but may
lose detail. This method often gives superior results to FFDSSD method with deep
stacks, such as images produced by microscopy. It is worth noting that images to be
processed must be in Z order (Capture a series images in closest to furthest or

furthest to closest order);

FFDSSD: FFDSSD is a method that does filtering in the frequency domain using Fast
Fourier transform (FFT) and does synthesis in the space domain. FFDSSD can be
used for images having misalignment. Users can manually or automatically select

reference images to make images aligned.
Maximum Contrast

Choosing Maximum Contrast in the Select Method dialog will pop up an Options

Dialog as follows:

Options
Detail Clarity: 107
Total Brightness: 125

Background Brightness: 93

Defaults

Description

The three values are not isolated. Detail clarity affects the fine detail of the
result. Background brightness is the offset value that is used to add or subtract
the background. These two settings will result in the change of the total
brightness. For that reason, the total brightness may also need to be adjusted.

<ua | wers | [omn

Detail Clarity: Detail Clarity affects the fine detail of the result. Default:107, Range:
10~240;

Total Brightness: Total Brightness is the overall brightness. The Detail Clarity and
Background Brightness will result in the change of the Total Brightness. For that
reason, the Total Brightness may also need to be adjusted. Default:125, Range:
10~240;

Background Brightness: Background Brightness is the offset value that is used to add
or subtract the background. Default: 93; Range: 10~240;
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Default: This will set all 3 values to the Default ones;

Clicking Next> button will pop up an Auto Align dialog as follows:

Auto Align

Auto Align

(®) None
() shift + Scale

(") Shift + Scale + Rotate

Description
Select the proper Auto Align mode according to whether there is shift, scale or
rotate among the images to be processed.

The time cansumption of EDF is related to the setting of the maximum angle.
The time wil increase when the maximum angle increases and the relationship
between them is non-linear. The default maximum angle is 1.0°.

<k conce

None: Considering no Shift+Scale+Rotate among the selected images in the fusion

process;

Shift+Scale: Considering Shift+Scale among the selected images in the fusion

process; Rotation is not condsidered in this option;

Shift+Scale+Rotate: Considering Shift+Scale+Rotate among the selected images in
the fusion process; If this mode is checked, The Maximum Angle slide bar will be

enabled;

Maximum Angle: The Maximum Angle is used to set the upper limit in Rotate

alignment. The Default is 1 degree. Range:0.1~10;

User can select the proper Auto Align mode according to whether there is shift, scale
or rotate among the images to be processed. The time consumption of EDF is related
to the setting of the Maximum Angle. The time will increase when the Maximum

Angle increases and the relationship between them is non-linear. The default is 1.0°;

Clicking <Back will return to Option dialog and clicking Finish will begin the EDF
operating according to the previous setup. ImageView will display the EDF(Extended

Depth of Focus) progress bar as follow:
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EDF (Extended Depth of Focus) =]

The final EDF result is shown below:

Weighted Average

The setups of the Weight Average are the same as those of the Maximum Contrast.

About the setup details, please refer to Maximum Contrast.
FFDSSD

Choosing FFDSSD in the Select Method dialog will pop up a FFDSSD Options dialog as
below:

Determine the reference image automatically: Before EDF, FFDSSD will evaluate all
the images to determine the reference image for feature matching. After the
reference image is determined, FFDSSD will perform feature matching between the

reference image and the other images to find the alignment parameters

If the Determine the reference image automatically is unchecked, ImageView will

take the first image as reference image in the alignment operation.
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FFDSSD Options

Determine the reference image automatically

| <sack | Fner || cancel |

Clicking Finish button will begin the EDF, an EDF (Extended Depth of Focus) progress

bar dialog will display as follows:

EDF (Extended Depth of Focus) Ea

The final EDF result is shown below:

13.3.2 Image Window EDF
Similar to the Browse window EDF, Image window EDF is also a very useful tool to
generate a clear image by combining a sequence of previously captured or opened
multi-focus images. Choosing the Process>EDFeee command, the following dialog
will be brought up (assume 01.jpg 02.jpg eee 15.jpg are already opened in
ImageView):
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Select Files

Open Selected

01.jpg Add

04.jpg Add all

07.jpg Delete

10.jpg Clear

Clicking on the image file name in the Open combobox will highlight the image, and
then the Add>> button is enabled (Click on the selected images will deselect them).
Click the Add>> button, the highlighted images will be added into the Selected list
box, which will be fused later.

Clicking the Add all button will add all images in the Open combobox into the

Selected list box.

If images in the Selected combobox are highlighted, the Delete button will be
enabled. Click the Delete button, the highlighted images in the Selected combobox

will be removed.

Clicking the Clear button will remove all the images in the Selected list box, including
the unselected ones. The button will be disabled if there is no image in the Selected

combobox.

When the desired images are all selected (If more than 2 images are added in the
Selected List box, the Next> button will be enabled), clicking on the Next> button
will start the other EDF setup as those of the Browse window EDF. After all of the
setup is finished, ImageView will display the EDF(Extended Depth of Focus) progress

bar as follows:
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EDF (Extended Depth of Focus) =]

The final EDF result is shown below:

NOTE: Images used for fusing must be the same size; otherwise there will be a
prompt when adding different sizes of image to perform the EDF operation. The

prompt dialog indicates which image is not the same size with the others.

The App x

Image: "D:\Demolmage\EDOF\EDOF_12\16_Extra.jpg" is not of the
! same size.

13.3.3 Video Window EDF =
Make sure that the ImageView package and the camera are correctly installed. Turn

on the microscope's light.

1. Run ImageView and start the camera;

I

2. Choosing the Process>EDFeee command or clicking on the toolbar will bring up

a dialog called “Capture Image”;

3. Use the microscope coarse or fine focus knobs to move the sample stage up and

down, in order to find the positions where the clearest regions of the whole sample
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can be seen on the Video window;

4. Click the Capture button to capture an image into the image list which will be used
for the EDF operation.

Capture Image

Tips

Adjust the microscope to make different part of the object clear. Capture an
image when the object is in different position. The step of the adjustment is
up to the users. Typically, more details will be available if smaller step is
selected. The relative position of the object and the microscope should be
changed in one direction.

5. Unless there is 1 captured image, the Clear buttons will not be enabled. Unless
there are more than 2 captured images, the Next> buttons will not be enabled. If the
captured images are not satisfactory, click the Clear button to clear the captured
image(s) and capture new image(s).

6. If more than 2 images are captured, Clicking Cancel will end the Capture Image
and return to the Video window. If the Next> button is clicked, ImageView will pop up
a dialog called Selected Method to begin the EDF configuration process. About the
configuration detail, please check Browse Window EDF in this section.
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The final fused image will be displayed in a new active image window and its title bar

will be associated with a digit assigned by ImageView.

Note: a). Use the coarse and fine focus knobs to move the sample stage up and down;
b). Clicking the Capture button will capture the current image into the image fusion
list; c). Repeating steps 1-4 until there are enough images; d). Clicking the Fusion
button will start image fusion. Waiting for some time and a fantastic fusion result will

be displayed in a new image window;

13.4 Deinterlace(A)

When interlaced cameras is used to take the images, a complete images is divided
into 2, 3 or more fields. Since different fields are exposed and output at different time,
there is no problem for a still object. But you will see an image with interlaced
content when the object is moving. Deinterlacing algorithm is used to resolve this
problem. This function could find the difference between different fields
automatically, correct the location difference as much as possible and deinterlace the
image. But vertical resolution will be lost to some extent and there will be some small
shift.

13.5 Color Composite(C)eee L
Use the Color Composite dialog box to create and configure color composites using

black and white source images. You can access the Color Composite dialog box

through the Color Composite menu item from the Process menu.

You can combine gray-scale images into a color composite. Any group of gray-scale
images that are of the same size can be mixed in a color composite. Images of 8-,
12-, 16-bit integer or floating point format are combined into a 24-bit color
composite. Each input channel will have individual LUT adjustments, as well as a

registration offset to line it up with the rest of the images.

You can also combine individual channels from a single image. Each channel will be

listed separately, as shown here:
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Color Composite

Source Images: Adjust
DemoGm.TIF hd Oall (®) Selected
Add Delete Registration Contrast

B C [
Colors:

M| pemoBlue.TIF

Background:
None v New

Source Images: The Source Images combo box displays the images available for
color mixing. The Source Image list is initially filled with a list of the gray scale
images that are currently open. The size of the color composite is determined by the
first input image selected. Once this is entered, the list is filtered to contain only

images of the same size as the initial selection.

Add: Click the Add button to add an image to the mix. You will be prompted for the
color to be assigned to that image from the Set Color dialog.

Delete: Use this button to delete the selected image from the list.

Colors: The Colors combobox displays the images selected for color mixing.

Color Composite
Source Images: Adjust
DemoRed.TIF v Ol ® Selected
Add Delete Registration Contrast
8 c G

Colors:
M| pemoBlue. TIF

DemoGm.TIF

X: Y:

Background:
Mone ~ New
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Color Compoasite [ x |
Source Images: Adjust
Oal (®) selected

Add Delete Registration Contrast

B C G
Colors:

M| pemoBlue.TIF

Set Color. Best Fit Reset

Background:

Hone v New

To change the color within the list box, double-click to select the image name (the
Select Color dialog box appears) or highlight the name and click the Set Color button.

To delete colors/images from the Colors list box, first click on the color/image to

highlight it then press the Delete button within the Color Composite dialog box.

Color Bar: The picture item box on the left side of the Colors list indicates the color
associated with each image in the composite. The Color Bar will scroll with the

contents of the Colors list box.

Set Color: This option determines the Color value used for the selected channel in the
final image display. Clicking on the Set Color button brings up the Select Color dialog
box.

Select Color

For File:DemoGrn.TIF

Selected: Red: 000, Green: 255, Blue: 000

Current: Red: 000, Green: 255, Blue: 000

Fluoro-Jade v

Directly select a color by:

1) Dragging the Color Value Slider to the desired color on the Color Bar (range of 0 to
359°): or
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2) Clicking the appropriate Color button on the Color Palette. The Color Bar
represents Color degrees in the standard color wheel representation, and the Color
Palette contains a subset of possible Colors (pure red, green, blue, cyan, magenta,

and white): or
3) Select a dye in the dye list, and click the Select Dye button.

Note: You can navigate through the Select Color dialog box by using the <Tab> and
<Shift + Tab> keys to cycle through the items in the dialog box.

Intensity is determined by the image the Color is applied to, and saturation will

always be 100%.

The only exception to this is the “white” Color, which has by definition a saturation of
0%. Selecting a value greater than or equal to 360 (dragging the Color Value slider

over to the far right) is a choice of white, which results in a non-tinted (gray) image.
The elements of the Select Color dialog box are:

Color Bar: The Color Bar shows a rainbow displaying the Colors underneath the

appropriate point of the Color Value slider.
Note:

If Color Value Slider is the selected (highlighted) selected control, then you can also
control the slider with keyboard strokes:

Use the left/right arrow <-> or <->keys to move the slider incrementally.

Press the <Page Up> and <Page Down> to move the slider in “chunk” sections along
the Color Bar.

Use the <Home> and <End> keys to move the slider to the beginning and end of the

Color Bar.

Selected: This color block displays the new Color selected by the Color Value slider

bar or the Color Palette.

Selected Color: The Selected Color text field displays the corresponding numeric

Color value of the Selected color block described above. The Selected Color value is
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expressed as an HSV color, with the red value first, followed by the green and blue
values. If the color corresponds to a dye color, the dye name will be displayed. If the
dye color corresponds to a color palette color, the name of the color will also be

displayed.
Current: The Current color block displays the starting Color of the channel.

Color Palette: The Color Palette proves an alternate method of selecting a Color.
Clicking on an item in the Color Palette will set the Color Value slider to the correct
value and update the displays in both the Selected color block and Selected Color
text field.

For example, clicking on the white button on the Color Palette will set the Color Value
slider to the right, change the Selected color block to white, and cause the Selected

Color text box to display “"White”.

Adjust: The controls in this section are used to adjust the color composite
contribution from each image, or for the color composite preview itself. You can
adjust the input image that is currently selected in the Colors list by clicking the
selected button. When you want to adjust the color composite preview, or you want

no image is selected in the Colors list, use the All button.

Registration: Registration allows you to correct for mis-registrations of images
caused by filter-induced optical shifts. Use the directional keys to shift the selected
image in the x- and/or y- direction, with respect to the rest of the input images. One
click moves that channel one pixel in the direction indicated. Blank areas are filled

with black. The key labeled “0,0” will re-center the selected image.

The registration shift for the selected channel or the overall image is displayed in the

static text box below the directional keys.

Contrast: Use the BCG sliders along with the Best Fit and Reset buttons to adjust the

contrast of the selected image or the composite.

BCG sliders: The Brightness, Contrast, and Gamma sliders are the similar to the
Contrast Enhancement feature in ImageView. You can also adjust each channel
individually or collectively by using the Selected or All radio buttons (to the left of the
BCG sliders in the Adjust group box).
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Best Fit: Click this button to perform a Best-Fit contrast stretch on the selected input,
automatically setting the Brightness and Contrast settings accordingly (Gamma will
be reset to 50.). This method is identical to the Best Fit contrast adjustment under
the standard Contrast Enhancement feature of ImageView. Best Fit is useful for first

pass adjustments.

Reset: Pressing the Reset button automatically resets the BCG settings. If the Adjust

radio button is set on All, the BCG settings for the overall color image will be reset.

Frame: Use the frame slider to adjust the frame of the selected image that is used for
the preview, or the active frame of the composite. (Please see the discussion of Color

Composite and Image Sequences that follows this section.)

Background: Select one of the available images to be the background color in this
combo box. The rest of the image planes are subtracted from the background image
— effectively punching “holes” into it and allowing the foreground colors to show
without mixing with the background. This is most effective where the background
covers large areas and the other images have smaller objects within the background

objects.

Background allows the other inputs to be displayed “in front of” the background
inputs, minimizing color mixing. For example, ImageView can display a red dot on a

blue background without turning the dot to magenta.
Selecting None causes all images to be equally mixed.

New: Click on the New button to discard the current color composite image, and start

over.

The Source Images combo box will reset to include all gray scale images (including
floating point images). Selecting an image from the list will create a new composite
the same size as the initial selection. As mentioned previously, the source images list

will be filtered to contain only images of the same size as the initial selection.

13.6 Segmentation & Counteee
Choose the Process>Segmentation & Count command to realize the segmentation
and count of the interested image. The arrangement of Segmentation & Count is

very special and some explanations are needed here to clarify it in details:
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1. The function provides users with five methods which are Watershed(W), OTSU
Dark, OTSU Bright, RGB Histogram, HSV Histogram and Color Cube. Users can
select any one of those 5 methods, but after selecting any one of them, the others
will be disabled.

2. After segmentation, there may exist adhesions. Then what we should do is
segment connected object manually by choosing the Split Objects function.

3. When the users get the expected results, they can choose the Counting Results

menu and get the statistics and analysis results.

According to the counting result, you can go back from step 2 or 3 to step 1 or 2 to

repeat segmentation or split objects operation.

Note: If the users choose None in the Label button at the Count Options dialog, then
regardless of the type of Method set, there is no Label for Index, Area or Perimeter on
the image. But the None, Circle and Ellipse will show the segmentation results. That's
why ImageView name the menu as Segmentation & Count. That is, this function can
achieve either the image Segmentation or Count. In this regard, please refer to the

Process>Segmentation & Count > Watershed(W) in the Count Options dialog.

13.6.1 Watershed(W) eee
Watershed segmentation method is a mathematical morphology segmentation
method, which based on topological theory. The basic idea is taking the image as a
topological geomorphology on geodesy, and each image pixel gray value indicates
the altitude, boundaries of each local minimum value and its impact area called
catchment basins and the formation of watershed catchment basins. So the
formation of the watershed concept can be illustrated by simulating the immersion
process. In each local minimum value of the surface, piercing a hole, then the entire
model slowly immersed in water, with the immersion of the deepening impact of the
domain of each local minima slowly expands outward in two catchments basin at the

confluence build dams that form the watershed.

Watershed is suitable for relatively simple background target object or target object
with a relatively large difference between the background images instead of the

more complex application.
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Choose Process>Segmentation & Count > Watershed(W)..., there will pop up the
following dialog: (Note: Segmentation & Count function only works for 24 bits,
otherwise all the sub-menu items will be disabled. Users can change the Color Bits to

24 bits by choosing Image>Mode>Color Quantize...)

Count Options

Approximation: | None v [ with holes

Outline

Style: outline v Color: M pefault v Caneel

Label

Type: Index v
[V]Area (px)
Minimum Maximum
[¥]Perimeter (px)

Minimum Maximum

Approximation: Approximation including 3 options: 1)None: drawn the actual outline
of the segmented object; 2)Circle: The actual outline fitting into a perfect circle, users
can get fit Radius of each object in the Count Result dialog; 3)Ellipse: The actual
outline fitting into a ellipse, users can get fit Axis of each object in the Count Result
dialog;

With Holes: When checking With Holes function, the segmented object’s Outline will
be marked with Color. Meanwhile the holes are also marked with Color and its
parameters will be output in the image (Hole is defined as the target grayscale or the
color close to the background pixels). The left figure below is the segmentation result
without checking With Holes; the right below is on the contrary. With Holes option is

usually used to get hole parameters;

Outline: Style: Including 3 options: 1)Outline: objects are marked by outline, the
color can be user-defined; 2)Filled: the segmented objects will be filled with custom

colors; 3)None: no marked outline for the segmented object;
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Color: Custom colors used to mark the Style;

Label: Method: Including 3 options: 1)XOR: with the current pixel's XOR color to mark
the current object segmentation;2)True: marked with the specified Color;3)False:

no mark for the objects;

Note: If users choose False in the Label group box, then regardless of the type of
Method, there is no display for Index, Area or Perimeter. But the None, Circle and
Ellipse will displayed on the segmented image. That's why ImageView call it

Segmentation & Count;

Color: Custom Color used to represent the color of Label. When selecting XOR in the
Method, the Color selection will be disabled, but the ImageView will automatically

mark the segmented image with the current pixel’s XOR color;

Type: Including 3 options: 1) Index: use numbers to mark the segmented object. 2)
Area: the object area is marked by outline area size. 3) Perimeter: the object

perimeter is marked by the outline perimeter;
Area:

Minimum: determine the lower limit of the area. that is, if the object area is less
than the lower limit , it will not be included;
Maximum: determine the upper limit of the area. that is, if the object area is

greater than the upper limit , it will not be included;
Perimeter:

Minimum: determine the lower limit of the perimeter. that is, if the object
perimeter is less than the lower limit, it will not be included;
Maximum: determine the upper limit of the perimeter. that is, if the object

perimeter is greater than the upper limit, it will not be included;

The figure below shows image Segmentation & Count results with watershed method

with setting in Count Option dialog.
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13.6.2 OTSU Dark(D)eee

OTSU is proposed in 1979 by Japanese scholars, which is a method to determine the
threshold of an adaptive, also known as Otsu method, referred to as OTSU. It is
based on the gradation characteristic of the image, and divided the image into the
background and the target. The bigger the OTSU is between background and the
target, the larger difference between the two parts images. The wrong part of the the
background or the wrong part of the target will lead to smaller differences between
the two parts. Therefore, the maximum OTSU means the minimum probability of

misclassification.

OTSU Dark segmentation method means segment the dark object from the bright
background using OTSU algorithm. Its Count Options dialog is exactly the same with
the Watershed Count Options. Below are bright background with dark object (bottom
left) and its segmentation result (bottom right) for reference:
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13.6.3 OTSU Bright (B) eee
OTSU Bright segmentation method means segment the bright object from the dark

d

background using OTSU algorithm. Its Count Options dialog is exactly the same with
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the Watershed Count Options. Below are dark background with bright object (bottom
left) and its segmentation result (bottom right) for reference:

13.6.4 RGB Histoman eee
RGB Histogram segmentation is based on image histogram where image pixels
between a specified histogram upper and lower range will be color processed. The
segmented area can be adjusted by mouse to drag two vertical lines in histogram, or
by inputting precise value in RGB upper and lower edit box directly and clicking
“Enter” to make it effective. The Color representing the segmentation area can be
customized by system palette. For a 24-bit true color image, segmentation can be

realized by R, G, B channels respectively.

Choose Process>Segmentation & Count>RGB Histogrameee shows Histogram dialog,

each function is specified as below:

Histogram n
Cancel
Options
e —
[ = 79 = Green v Show All

RGB:

° % Left Value in the currently selected region of histogram segmentation,

corresponding to Left Vertical Line position in histogram. Users can segment the
pixels bigger than the Left value by inputting a value in this edit box or dragging the

Left Vertical Line in histogram. When input a Left Value in this edit box, users should
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click enter to make the value effective. Meanwhile, the Left Vertical Line will move to
the place the Left Value represents. Left Value range: O~current Right Value. The

current Left Value is 0;

L= . Right Value in the currently selected region of histogram segmentation,
corresponding to Right Vertical Line position in histogram. Users can segment the

pixels, bigger than the Left Value and smaller than Right Value, by inputting a value
in this edit box or dragging the Right Vertical Line in histogram. When input a value
in this edit box, users should click enter to make the value effective. Meanwhile, the
Right Vertical Line will move to the place the Right Value represents. Range: The

current Left Value ~255;

Red “I: A histogram channel of the currently RGB histogram. It can be R
histogram, G histogram or B histogram;

Mishowal - Show all channel RGB histogram. When uncheck Show All, only a selected

histogram channel will be shown;

: Used to identify the Color of the segmented pixels; The default is green;

grors- | When users click Optionsees button, a Count Options dialog pops up as

below. The setting of Count Options dialog is the same as that of Waltershed’s Count
Options dialog, details can be referred to Process>Segmentation &
Count>Watershed(W) eee;

Count Options “

Approximation: | None v [with holes ok

Outline

Style: Outline v Color: | Cancel

Label

weos: e v coon

Type: Index v
[v] area (px)
Minimums Maximum:
Perimeter (px)

Minimum: Maximum:

Example of RGB Histogram is as follows:
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1.0pen an image and then choose Process>Segmentation & Counting>RGB
Histogrameee menu, a Histogram dialog shows as below. When the mouse moves in
the image area, the cursor will be displayed as Color Picker Cursor;

Histogram “

Cancel

OK

Options...

o E}

) 00 150 20 253

0o [ " E Green v [v] Show All

RGB: 249, 51, 31

2.Move Color Picker Cursor to any pixel of the image, shown as above, RGB value of
the current pixel will be displayed in the bottom Histogram window. Here R is 249,
G is 51, Bis 31, showing the RGB value of the ideal segmentation area, record the

three values.

3.Move the mouse to the background area, the RGB value of Color Picker Cursor is 79,
79, 79. In order to accurately segment out the target, users can set RGB values of
the segmented pixels in the initial interval, and those of background out of the initial

interval. For example, the RGB values can be set to the initial interval as follows:

R is set to the initial interval: 200~255;
G is set to the initial interval: 0~60;

B is set to the initial interval: 0 ~ 60;

When setting completed, the segmentation effect is shown as below:
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4.Move again the Color Picker Cursor to any other unshadded pixels, then the RGB

value shown in left bottom of histogram is 237, 70, 45 as below:

Histogram “
Cancel
oK
Options...
Woes.... v
—1
% % ) % 253
0 = 60 = Green v [v] Show Al

RGB: 237, 70, 45

It's easily found that here G channel, defined 60, is too small to get the pixel
segmented. Then initial interval for G channel can be adjusted from 0~60 to 0~80 to
segment the pixels nearby. (Note: If the background pixels of a single channel is
within the initial interval, no segmentation change will take place. Only all three
channels of the background pixels are within the initial intervals can the pixels be
segmented) The segmentation effect by readjusting G initial interval is shown as
below:

5.Repeat step 4 and readjust initial interval of each RGB channel to achieve perfect

segmentation.

13.6.5 HSV Histogrameee
HSV Histogram segmentation is based on image histogram where image pixels
between a specified histogram upper and lower range will be color processed. The
segmented area can be adjusted by mouse to drag two vertical lines in histogram, or

by inputting precise value in HSV upper and lower edit box directly and clicking
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“Enter” to make it effective. The Color representing the segmentation area can be
customized by system palette. For a 24 bits true color image, segmentation can be
realized by H, S, V channels respectively.

Choose Process>Segmentation & Count>HSV Histogrameee shows Histogram dialog,
each function is specified as below:

Histogram n
Cancel
Options
A
gk 79 % Green v [+7] Show Al

® 5. Left Value in the currently selected region of histogram segmentation,

corresponding to Left Vertical Line position in histogram. Users can segment the
pixels bigger than the Left value by inputting a value in this edit box or dragging the
Left Vertical Line in histogram. When input a Left Value in this edit box, users should
click enter to make the value effective. Meanwhile, the Left Vertical Line will move to
the place the Left Value represents. Left Value range: O~current Right Value. The

current Left Value is 0;

? =l. Right Value in the currently selected region of histogram segmentation,

corresponding to Right Vertical Line position in histogram. Users can segment the
pixels, bigger than the Left Value and smaller than Right Value, by inputting a value
in this edit box or dragging the Right Vertical Line in histogram. When input a value
in this edit box, users should click enter to make the value effective. Meanwhile, the
Right Vertical Line will move to the place the Right Value represents. Right Value
range: current Left Value ~255. The current Right Value is 79;

e “: A histogram channel of the currently HSV histogram. It can be H
histogram, S histogram or V histogram;

Mshoual . Show all channel HSV histogram. When uncheck Show All, only a selected

histogram channel will be shown;
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:Used to identify the Color of the segmented pixels; The default is green;

:When users click Optionseee button, a Count Options dialog pops up as
below. The setting of Count Options dialog is the same as that of Waltershed’s Count
Options dialog, details can be referred to Process>Segmentation &
Count>Watershed(W)eee;

Count Options “

Approximation: [ Jwith holes e

Outline

Label

Wethos: oo

[v] Area (px)

[w] Perimeter (px)

Example of HSV Histogram is as follows:

1.0pen an image and then choose Process>Segmentation & Counting>HSV
Histogrameee menu, a Histogram dialog shows as below. When the mouse moves in

the image area, the cursor will be displayed as Color Picker Cursor;

Histogram

[v] Show All

2.Move Color Picker Cursor to any pixel of the image, shown as above, HSV value of
the current pixel will be displayed in the bottom Histogram window. Here H is 186,
Sis 114, Vis 206, showing the HSV value of the ideal segmentation area, record the

three values.
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3.Move the mouse to the background area, the HSV value of Color Picker Cursor is
214, 87, 228. In order to accurately segment out the target, users can set HSV
values of the segmented pixels in the initial interval, and those of background out of
the initial interval. For example, the HSV values can be set to the initial interval as

follows:

H is set to the initial interval: 60~200;
S is set to the initial interval: 90~130;
V is set to the initial interval: 0~210;

When setting completed, the segmentation effect is shown as below:
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4.Move again the Color Picker Cursor to any other unshadded pixels, then the HSV
value shown in left bottom of histogram is 194, 79, 212 as below:

W Z
. Histogram “

)

. | HsV: 194, 79, 212
K

It’s easily found that here S channel, defined 90~130, its lower limit is too bigl to get

the pixel segmented. Then initial interval for S channel can be adjusted from 90~130

to 60~130 to segment the pixels nearby. (Note: If the background pixels of a single

channel is within the initial interval, no segmentation change will take place. Only all
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three channels of the background pixels are within the initial intervals can the pixels
be segmented) The segmentation effect by readjusting S initial interval is shown as

below:

5.Repeat step 4 and readjust initial interval of each HSV channel to achieve perfect

segmentation.

13.6.6 Color Cubic(C)eee
Choose Process>Segmentation & Count>Color Cubeeee, a dialog called Color will

pop up as below;

Color n
i | | £ 3 N Cancel
RGB: OK
Tolerance Options...
R 20 : iDef. - M
e (o 2
B 20 B

At this moment, the Colorizing Pipette (Default) is checked by default. Click the
image will set the average color value in the masked area as Basic Value. ImageView
will segment the image by choosing the pixel within Basic ValuetTolerance color
range and mark it with current selected Color. By clicking the target pixel repeatedly,
ImageView can continuously add new pixels within the Basic Valuet+Tolerance color

range into the target and thus acquiring continuous segmentation colorizing.

When some undesirable pixels have been added into the segmentation data, the
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De-Colorizing Pipette can be used to wipe off the undesirable pixels. This operation
process is the same as Colorizing Pipette, that is, to set the average color value of the
clicked-pixel’s Mask Area as Basic Value and wipe off the segmentation data, which is

within the Basic ValuetTolerance color range.

4 Colorizing Pipette: Collect average color value of the clicked-pixel’s Mask Area as
Basic Value and add pixels which are within Basic ValuetTolerance color range into

the segmentation data;

% De-Colorizing Pipette: Collect average color value of the clicked-pixel’s Mask Area
as Basic Value and wipe off the segmentation data, which is within the Basic

Valuet+Tolerance color range;

3 v Mask Area: When Colorizing Pipette or De-Colorizing Pipette is used to click
the image, a Mask Area is also needed to calculate the average color value of the
clicked pixel. The Mask Area’s color value will be used as Basic Value. Color values
within the Basic ValuetTolerance range can be added to or wiped off from the
segmentation data. The default Mask Area is 3*3, other options are 1*1, 5*5, 7*7;

RGB: The average RGB values of the Mask Area;

Tolerance: There are 3 Tolerance values, they are R, G and B. User can make fast and
accurate object segmentation by selecting a proper Tolerance value according to

their experience. The default R, G and B Tolerance values are 10;

: Used to mark the color of the segmentation area; The default Color is
green;

ortiens---_|: \When clicking the Options button, a Count Options dialog as below will pop
up. This dialog is the same as that in Process>Segmentation & Count>Watershed (W)
eee, Please refer to Process>Segmentation & Count>Watershed (W)eee for the

detailed operation of this dialog;
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Count Options

Approximation: | None v [ with holes oK

Outline

style: Outline v Color: . Default |v Cancel

Label

Method: True v Color:

Type: Index v

Area (px)

Minimums: Maximum:

Perimeter (px)

Minimums: Maximum:

Here is an example to demonstrate the Color Cubic segmentation process:

1. Open an image as below:

2. Because of the inevitable noise in the image, an image smooth operation should
be done first. There are many algorithms to perform the image smooth operation and
here we are to process it as follows: choose Process>Filter menu and click
Morphological property page and a dialog will pop up with parameters as shown in
the figure below on the left side. Click OK and the final smoothed image is shown

below on the right side.
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Filters n

Image Enhancl$Edge Enhance | Morphological | Kernel

Filters Sample

() Erode () Gradient
() pilate () Distance
(@) open () Thinning
(O close () watershed
(O Top hat
O well
Options
(D2x25quare (8)3 x3 Cross ()11 x11 Cirdle
(O3x1Row ()5 x5 Circle Passes |2
(O1x3ceomn ()7 x7 Circle
ndo = ||

3. Choose Process>Segmentation & Count> Color Cubeeee, a Color dialog will pop up

as shown below;

Color n
A“ A 3*3 & Cancel
RGB: 180, 37, 62 oK
Tolerance Options...
R: 20 = @
e [0 E )
B: 20 B

4. At this moment, the Colorizing Pipette is checked. Click the pixel wish to segment.
That is to say, select the color area which is interested in. If some undesirable color
area is included in the segmentation area, just check the De-Colorizing Pipette and
click the undesirable pixels, thus the undesirable pixels will be wiped off. When the
segmentation process is completed, click OK and the Segmentation & Count

operation will be carried out.
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The result of segmentation after the first

clicking at the pointed area with

Colorizing Pipette

The result of segmentation after the
second clicking at the pointed area with
Colorizing Pipette

The result of segmentation after the
second with the De-Colorizing Pipette
(slight difference exists as inaccuracy in
position)

The result of segmentation after countless

clicking with Colorizing Pipette

5. Click Options to set Outline, Label and etc., the final results is shown below. So far

the primary segmentation is completed.
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13.6.7 Split Objects(S)
It can be found out in this segmentation, particle #16 (located in the upper middle of
the image) is not a single object but actually two separate one. However they have
been calculated as a single object. Choosing Split Objects will correct this problem.
Object splitting with Split Objects is discussed below.

As is shown in the image below, move the cursor onto target #16. Click the left

mouse button and draw a straight line.

When pressing down the left mouse button, the cursor should not touch the target —
— the starting point of the split line should be off the target that is to be separated.
Move the cursor to the bottom right of the target—— the ending point of the split line
should also be off the target that is to be separated. Release the left mouse button
when this operation is completed. A split line is shown between the two adhesive

objects as shown below:
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After the left mouse button is released, ImageView will re-count the whole image.
The result of re-counting is shown as below. The previous #16 turns out to be #12

and #17 now:

Unchecking or choosing Split Objects menu again will hide the split line. The final
result of hiding the split line is shown as below. The whole Split Objects process is

completed when the split line is hidden.

13.6.8 Count Result (T) eee
Count Result is a way to show count statistical result of the current image. Count
Result dialog includes Index. Center. Radius(major-minor axis or non), Area and
Perimeter, as is shown below. The unit of statistical result is the same as what the
user selects in the Unit for the displayed image. Click Index, Center, Radius
(major-minor axis or none), Area and Perimeter and the statistical result will be

automatically sorted according to their data. Choosing a certain item can check the
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split object in the image. In the meanwhile, Index (or Area and Perimeter) of the

other targets will be hidden automatically.

Result
Index Center Radius Area Perineter -
(108.82, 96.30) 0.54 0.25 241
2 (51.32, 95.94) 0.98 0.75 4.11
3 (119.61, 95.57) 3.32 12.82 20.68
4 (60.67, 94.36) 6.18 59.16 41.01
5 (37.57, 90.30) 142 0.25 5.69
6 (29.81, 89.42) 0.57 031 262
7 (66.49, 85.19) 0.57 0.06 262
8 (25.06, 89.02) 5.78 76.52 45.86
9 (82.24, 93.40) 12.06 173.82 10148
10 (15.70, 84.66) 4.50 162 20.56
11 (13.58, 82.36) 6.21 53.00 44.11
12 (12.70, 76.54) 0.73 0.62 341
13 (41.45, 80.95) 6.13 60.03 52.35
14 (2.65, 78.66) 5.95 64.70 40.29
15 (14.29, 72.84) 0.57 0.19 2.62
16 (83.97, 76.58) 6.20 66.13 53.76
17 (105.80, 81.50) 16.57 300.87 180.77
18 (17.99, 70.02) 7.26 82.86 62.48
10 fa 87 AS A1) 154 nia Aon v
ot

The Center column in Result is relevant to the Approximation option in the Options
dialog. When selecting Circle, radius of the circle will be listed as Radius column and
when choosing Ellipse, major-minor Axis of the Ellipse will be listed as Axis column;

when selecting None, no column shows up.

Click Export and then the statistical result, together with the image of Segmentation

& Count, will be exported to an Excel sheet for further analysis and processing.

13.7 Denoise(D)
ImageView provides 3 types of noise removal methods, Adaptive Wiener Filter,
Bilateral Filter, Non Local Means. The processing speed of the 3 methods is from fast
to slow, and the denoising quality is getting better and better. Each method is

described in detail in the following:

13.7.1 Adaptive Wiener Filter(A)
The Adaptive Wiener Filter can preserve more image details than those of median
filter, mean filter, Gauss filter. The effect is more remarkable for additive noise (such

as Gaussian noise) and multiplicative noise (such as Poisson noise).

For the Adaptive Wiener Filter algorithm, please find the details in the relevant
literatures, here only to illustrate the improvement of Adaptive Wiener Filter over the
classical Wiener filter.
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In the classical Wiener filter, the image noise intensity requires the user to manually
input, but it is difficult to accurately enter the accurate value even for experienced
users, because the value is usually very small, such as 0.0036781. Therefore in the
development of the Adaptive Wiener Filter, the noise level is automatically calculated

according to the image mean variance.

The process is quite simple, open an image, choose the Process>Denoise>Adaptive

Wiener Filter to denoise the image.

13.7.2 Bilaternal Filter(B)eeoe
The Bilateral Filter is a nonlinear filtering method that considers image spatial
proximity, pixel value similarity, image spatial information and gray level similarity to
achieve the purpose of edge preserving denoising. The Bilateral Filter has the simple,
non-iterative, local characteristics. The Bilateral Filter is good to preserve image

edge compare with Wiener filter or Gauss filter.

Choosing Process>Denoise>Bilateral Filtereee will pop-up dialog called Bilateral

Filter as shown below:

Bilateral Filter
Value domain: 5
Space domain: 20

Value domain: the range of neighborhood pixel in radius for considering, the greater

the value, the slower process speed.

Space domain: Sigma value, the higher the value, the more effective the denoising

effect.

13.7.3 Non Local Means(NLM)eeoeo
The traditional local mean filter is a pixels average method around the target pixel,
but the Non Local Means is a weighted average method to average all of the image
patches over the search window. The weight is determined according to the similarity

between the target patch and neighborhood patches in the search window.
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Compared to other famous denoising algorithms, such as Gaussian, Wiener filter,
total variation and wavelet denoising, The Non Local Means method can get better
effect.

Choosing Process>Denoise>Non Local Meanseee will pop-up dialog called Non Local

Means as shown below:

Non Local Means “

Strength 50
Template Window: 50

Search Window: 50

Strength: The denoising strength, the greater the value, the more removal the

image noise, but will lose more details;

Template Window: The template block size, used to calculate the weight, the

recommended default value is 7;

Search Window: The template patch search window size, used to calculate the
weighted average value among image patches. Large value will increase the

processing time. The recommended default value is 21.

13.8 Sharpen(N)
13.8.1 USM(U)eee
UnSharp Masking (USM) is an image sharpening technique, often available in digital
image processing software. The "unsharp" of the name derives from the fact that the
technique uses a blurred, or "unsharp", positive image to create a mask of the
original image. The unsharped mask is then combined with the negative image,

creating an image that is less blurry than the original one.

Open an image and then choose Process>Sharpen>USMeee command, a dialog will

pop up as below.
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Unsharp Mask
Radius: 1
Threshold: 5
Amount: 1

Radius: Affects the size of the edges to be enhanced, so a smaller radius enhances
smaller-scale detail. Higher Radius values can cause halos at the edges. As a result,
fine detail needs a smaller Radius. In addition, Radius and Amount interact; reducing

one allows more of the other.

Threshold: Controls the minimum brightness change that will be sharpened. This
parameter is important to prevent smooth areas from becoming speckled. The
threshold setting can be used to sharpen more-pronounced edges, while leaving
subtler edges untouched. Low values should sharpen more because fewer areas are

excluded. Higher threshold values exclude areas of lower contrast.

Amount: is listed as a percentage, and controls the magnitude of each overshoot
(how much darker and how much lighter the edge borders become). This can also be
thought of as how much contrast is added at the edges. It does not affect the width

of the edge rims.
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a) Original image; b) Sharpened image

13.8.2 Laplacian Sharpen(L)

l\s.»:\ 2 I/

The Laplacian operator is an example of a second derivative method of enhancement.
It is particularly good at finding the fine detail in an image. Any feature with a sharp
discontinuity (like noise, unfortunately) will be enhanced by a Laplacian operator.
Thus, one application of a Laplacian operator is to restore fine detail to an image

which has been smoothed to remove noise.
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Open an image and then choose Process>Sharpen>Laplacian Sharpen, no

parameter is required for this method.

a) Original image; b) Sharpened image
13.9 Color Toning(G)

LA
13.9.1 Gamma(G)eee

The Process>Color Toning>Gammaeee measures the brightness of midtone values
produced by a device (often a monitor). A higher gamma value yields an overall

darker image.

Gamma Adjustment n
Gamma o oK
0

Preview: Check this button to display the real-time effects when one changes the

slider bar’s position. Default is checked;

Gamma: Dragging the slider bar to the left decreases the level, while moving it to the

right increases the level. Values can range from 0 to 3.0. Default is 1.0.

13.9.2 Histogram Equalization(Q)eee Shift+Q
Adaptive histogram equalization (AHE) is a computer image processing technique
used to improve contrast in images. It differs from ordinary histogram equalization
(HE) in the respect that the adaptive method computes several histograms, each
corresponding to a distinct section of the image, and uses them to redistribute the
lightness values of the image. It is therefore suitable for improving the local contrast.

However, AHE has a tendency to over amplify noise in relatively homogeneous
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regions of an image. A variant of adaptive histogram equalization called contrast
limited adaptive histogram equalization (CLAHE) prevents this by limiting the

amplification.

Please open an image and then choose Process>Color Toning >Histogram

Equalizationeee, a dialog should pop up as follows.

Histogram Equalization n

Strength: 10

Cencel

Strength: The Strength will affect the enhancement effect. The larger the value, the

more obvious the effect.

a) Original image; b) Enhanced image

13.9.3LCCReece

The Local Color Correction algorithm is computed in two steps:
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A mask image is computed from the input image.

The mask image is computed from the intensity component of the color image,
defined as the average of R, G and B values i.e. I=(R+G+B)/3. The use of intensity
information avoids distortions of the chroma. The mask image is obtained by

inverting and then blurring the intensity component of the input image.
The input and mask images are combined to get the result.

The combination operation consists of a power function, where the exponent is
computed using the mask value previously found. If the mask value is greater than
128, it will result in an exponent less than 1, while if the mask value is lower than 128,
it will result in an exponent greater than 1. Moreover, if the mask value is precisely
128, the exponent will be 1, and it will have no effect on the input image. The

operation is equivalent to a pixel-wise gamma correction.

Please open an image and then choose Process>Color Toning >LCCeee, a dialog

should pop up as follows.

Local Color Correction

Strength: 50

Strength: The strength will affect the enhancement effect. The larger the value, the

more obvious the effect. Range:1~100, default is 50.

a) Original image; b) Enhanced image

13.9.4 AMSR
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There are limited dynamic range problems when real world scenes are captured from
a digital camera and displayed on monitors. Tone mapping algorithms are applied to
image processing to reduce the dynamic range of an image to be displayed on low
dynamic range devices. Multi-scale Retinex is one of the most popular methods for
dynamic range compression, color constancy and color rendition. Here, we improve
its performance by adopting the adaptive weight functions, named Adaptive
Multi-scale Retinex (AMSR).

Please open an image and then choose Process>Color Toning>AMSR, the a) Original

image; b) Enhanced image

a) Original image; b) Enhanced image
13.10 Filter(I)eee Shift+I

Choose the Process>Filtereee command to apply one of ImageView's numerous

filters on the active image. If you are not familiar with the process and effects of
filtering, some discussions about spatial filtering should be reviewed. ImageView
provides an extensive set of convolution and no convolution (morphological) filters.

You can also create custom filter kernels and apply them with the Filter commands.

Choosing the Process>Filtereee command will open the Filter dialog. Each group of
filters has its own property page or tab, where the Filter type and size can be selected.
The filtered results are almost always written to the active image. The Edit>Undo

command can be used to remove Filter operations that have been applied.

13.10.1 Image Enhance
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Filters

Image Enhance | Edge Enhance | Morphological | Kernel

Filter Sample

(®) Low Pass () Sharpness
() High Pass () Flatten
() Gauss () Median
() High Gauss () Rank

() Equalization

Option

(O)s5xs Passes |1

Strength 1

Undo Concel | [

Low Pass: Check this filter to soften an image by eliminating high-frequency
information (this has the effect of blurring sharp edges). The Low Pass filter replaces
the center pixel with the mean value in its neighborhood. The Low Pass filter can also

be used to remove noise.

High Pass: Check this filter to enhance high-frequency information. The High Pass
filter replaces the center pixel with a convolved value that significantly increases its
contrast from its neighbors. The High Pass filter leaves only elements of high

contrast.

Gauss: Check this filter to soften an image by eliminating high-frequency information
using a Gauss function. This has the effect of blurring sharp edges. The operation of
the Gauss filter is similar to the Low Pass filter, but it degrades the image less than

the Low Pass filter.

High Gauss: Check this filter to enhance fine details. This operation is similar to the
unsharp masking technique (see the Sharpen filter), but it introduces less noise into
the image. It uses a Gaussian curve type of kernel. Available in 7x7 and 9x9 kernel

sizes.

Equaliza-tion: This filter is used to enhance the contrast based on the histogram of

the local neighborhood (See Option below).

Sharpness: Check this filter to enhance fine details, or refocus an image that is
blurred. The sharpen filter sharpens the image using the unsharp masking

technique.
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Median: Check this filter to remove impulse noise from an image. The Median filter
replaces the center pixel with the Median value in its neighborhood. It will also blur

the image.

Rank: Check this filter to remove impulse noise from an image. The pixels in the
kernel are ranked by order of intensity, and the pixel in that range at the rank
percentage is chosen for comparison. For example, in a 5x5 kernel, there are 25
pixels. A rank percentage of 95% would choose second-brightest pixel for
comparison. If the difference between the selected pixel and the center pixel is
greater than the threshold value, the Rank filter replaces the value of the center pixel

with the value of the selected pixel.

Option :1. If one of the Enhancement filters is checked, the following options will be

displayed:
3 x 3: Check 3 x 3 kernel will produce a more subtle filtering effect.
5 x 5: Check 5 x 5 kernel will produce a moderate filtering effect.
7 x 7: Check 7 x 7 kernel will produces a more extreme filtering effect.

Passes: Set the filter applied times on the image. When a filter is applied multiple
times, its effect is amplified by each pass. An image that has been softened by

one pass of the Low Pass filter will be softened further by a second pass.

Strength: Enter an applied value from 1-10 that reflects how much of the filtering

effect on the image.

A value of 10 specifies the full strength (100%) of the filtered result applied to
each pixel. Values less than 10 cut the full weight of the filter.

A value of 1 indicates that only 10% of the difference between the filtered pixel
value and the original pixel value should be applied, a value of 2 indicates that 20%

of the difference should be applied, and so forth.

Rank: This value specifies which pixel in the sorted array will be used to replace
the center pixel. Pixels in the array will be sorted in ascending order. The pixels
are indexed from 0 to Kernel Size x Kernel Size-1. In the pixel index 0

corresponds to the lowest pixel value.
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The Rank will be specified in terms of a percentage of the indexes (Kernel Size x
Kernel Size-1). A 50% Rank means the middle of the array. 0% rank means the
lowest index (lowest gray value), and 100% rank means the highest index

(highest gray value).

Option: 2. If the Equalization filter is checked, the options will relate to the histogram
equalization. Local Histogram Equalization modifies the contrast of an image based

on the pixel values in a small window surrounding each pixel.

Window: Image pixels statistics (min, max, histogram, mean, standard
deviation, etc.) will be calculated on a small Window of the image. These
measurements are then used to derive the local contrast for that area of the
image. In short, an area of Window x Window around each pixel is all that is
considered when modifying the intensities in the image. Larger Window

produces smoother results, while small Window track small details more closely.

Best Fit: Choose the Best Fit button to optimize the values for the particular
image. The results are achieved by stretching the local histogram to maximize

the contrast between the brightest and darkest pixels in the local window region.

Linear: This option distributes the histogram linearly across the intensity scale.
This function produces a high contrast image with the highest possible dynamic

range.

Logarithmic: This option concentrates the histogram at the low end of the scale.
This function produces a high contrast image with little dynamic image. It will
tend to darken the image overall. It is useful for increasing the contrast in a very

light image.

Exponen-tial: This option concentrates the histogram at the high end of the scale.
This function produces a high contrast image with little dynamic image. It will
tend to lighten the image overall. It is useful for increasing the contrast in a very

dark image.

13.10.2 Edge Enhance
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Filters

Image Enhance | Edge Enhance | Morphological | Kernel
Filters.
(®) Sobel

Sample

(") Roberts
() Seulpt
() Laplace
() variance
() Horizontal

() Vertical

Options

Undo Concel | [

Sobel : Check this filter to enhance just the principal edges in an image. The Sobel
applies a mathematical formula to a 3x3 neighborhood to locate and highlight its
edges.

Roberts: Check this filter to enhance fine edges in an image. The Roberts filter is not
a convolution filter. It applies a mathematical formula upon a 4 x 4 neighborhood to

produce its effect. The upper left pixel in the neighborhood is the one that is replaced.
Sculpt: Check this filter to apply a sculpted effect on the image.

Horizontal: Check this filter to detect and emphasize horizontal edges.

Vertical: Check this filter to detect and emphasize vertical edges.

Options : 1. If one of the Edge filters has been checked, the options will relate to

kernel size and filtering strength. The following options will be displayed:
3 x 3: Check 3x3 kernels to produce a more subtle filtering effect.
5 x 5: Check 5x5 kernels to produce a moderate filtering effect.
7 x 7: Check 7x7 kernels to produce a more extreme filtering effect.

Passes: Enter the number of times that the filter will be applied to the image.
When a filter is applied multiple times, its effect is amplified by each pass. An
image that has been softened by one pass of the Image Enhancement Filter, will

be softened further by a second pass.

Strength: Enter a value from 1-10 that reflects how much of the filtering effect to
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apply to the image. A value of 10 specifies that the full strength (100%) of the
filtered result will be applied to each pixel. Values less than 10 cut the full weight
of the filter - a value of 1 indicates that only 10% of the difference between the
filtered pixel value and the original pixel value should be applied, a value of 2
indicates that 20% of the difference should be applied, and so forth.

Option 2. If Sobel or Roberts is checked, no options are available.

13.10.3 Morphological
Filters

Image Enhance | Edge Enhance | Morphological | Kernel
Filters

(®) Erode () Gradient
() pilate () Distance
(") Open (") Thinning
() Close () watershed
() Top hat

O well

Options
(2 x2square (03x3 Cross (D11 x11 Circle

(O3x1Row (®5x5 Cirde Passes|1  |&

()1 %3 colomn () 7x7 Cirde

o ol | [

Erode: Check this morphological filter if one wants to modify the size of objects in the
image. The Erode filter erodes the edges of bright objects and enlarges the edges of

dark ones.

Dilate: Check this morphological filter if one wants to modify the size of objects in the

image. The Dilation filter dilates bright objects and erodes dark ones.

Open: Check this morphological filter if one wants to modify the shape of objects in
the image. Assuming the image contains bright objects on a dark field, the Open
filter will smooth object contours, separate narrowly connected objects, and remove

small dark holes.

Close: Check this morphological filter if one wants to modify the shape of the objects
in the image. Assuming the image contains bright objects on a dark field; the Close

filter will fill gaps and enlarge protrusions to connect objects that are close together.

Tophat: Check this filter to detect and emphasize points, or grains, that are brighter
than the background. There are 3 kernel sizes for this processing. Click the radio
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button to change the kernel size to the value that most closely matches the size of

the grains to detect.

Well: Check this filter to detect and emphasize points, or grains, that are darker than
the background. There are 3 kernel sizes for this processing. Click the radio button to
change the kernel size to the value that most closely matches the size of the grains
to detect.

Gradient: Check this filter to enhance edges in an image.

Watershed: Check this filter to separate objects that are touching. The Watershed

filter erodes objects until they disappear, then dilates them again, but will not allow
them to touch. The Watershed filter will not operate upon True Color images. If one
wants to separate objects in a True Color image, he must first convert it to Gray Scale

(see Process Frame: Image>Gray Scale).

Thinning: Check this filter to reduce an image to its skeleton. When choosing this
filter, one must set the threshold that determines whether a pixel is part of the

subject or part of the background (see Options below). The Thinning filter will not
operate upon True Color images. If one wants to thin a True Color image, he must

first convert it to Gray Scale.

Distance: The distance filter is used to show the distances of pixels within blobs to
the outer boundaries of those blobs. After applying the distance filter, the
background will be black (i.e. pixels with value 0). Only the area within the blobs will
have non-zero values (will be white). The values of each pixel within the blob will be
a count of the shortest distance from that pixel to the edge of the blob. Thus, all
pixels along the blob's border will have a value of 1 (since they are one pixel away
from the edge of the blob); pixels that are a distance of 2 from the border will have
the value 2, and so on. This creates a distance map of the image. The Distance filter
will not operate upon True Color images. If one wants to use the Distance filter with

a True Color image, he must first convert it to Gray Scale.

Options 1. If Erode, Dilate, Open, or Close filters is checked, the options will relate to

the kernel size and shape. The following options will be presented:
2 x 2 Square: Check to use the 2x2 square kernel configurations.
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3 x 1 Row : Check to use the 3x1 row kernel configuration.

1 x 3 Column : Check to use the 1x3 column kernel configuration.
3 x 3 Cross : Check to use the 3x3 cross kernel configuration.

5 x 5 Circle : Check to use the 5x5 circular kernel configurations.

7 x 7 Circle : Check to use the 7x7 circular kernel configurations. This is a

two-pass filter, accomplished using a 5 x 5 circle followed by a 3x3 cross.

11 x 11 Circle : Check to use the 11 x 11 circular kernel configurations. This is a
three-pass filter, accomplished using a 5 x 5 circle followed by another 5 x 5 circle,

followed by a 3 x 3 cross.
Passes: Set the number of times iterate the filter.

Note: The circular kernels are especially effective on round objects (cells, grains and
so on) because their circular configuration preserves the circular shape of the objects

better than square configurations.

Option 2. If the Tophat, Well, or Gradient filter is selected, the options will relate to
kernel size and shape. The following options will be presented:

3 x 3: Check to use the 3x3 square kernel configurations.
5 x 5: Check to use the 5x5 square kernel configurations.
7 x 7: Check to use the 7x7 square kernel configurations.

Option 3. If Watershed, Thinning, or Distance filter is checked, the options will relate
to the threshold. The following option will be presented:

Threshold: Enter a percentage value from 1-100 that specifies the intensity value
to binarize the image. For example, a Threshold of 50% on a Gray Scale image
would set all values <127 to 0 (black) and all values >128 to the maximum value

for that image class (white).

13.10.4 Kernel
The Kernel page allows edit the kernel files for the morphological and convolution

filters.
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Filters n

Image Enhance | Edge Enhance | Morphological | Kernel
Filter type
(®) Convolution () Morphological

Kernels

higaussse ]
higauss 77 (FTo
higauss 9x9

New...

Delete
horzedae 3x3

option

Passes |1

v 4]

Strength 1

o cancel | [ o

Note: The HiPass, LowPass, Laplacian and Unsharp kernel files are used by the
HiPass, LowPass, Laplacian, and Sharpen options listed in the Image Enhancement
Filters page dialog window (i.e. there is no difference between selecting one of these
kernel files and selecting its Option button in the Filter window -- the 2 methods
ultimately do the same thing). Because these kernel files are essential to the
operation of these filtering options, they must not be deleted or renamed.

Filter type: Check to modify the kernel for a selected Filter type, either Convolution or

Morphological filters.
Editeee: Invoke the Edit Kernel dialog to modify the selected filter kernel.

Nameeee: This combobox contains the name of the selected kernel file. If one
wants to save the modified kernel file to the same file, leave it as it is. If one

wants to save the file to a new location, enter the new filename here.

Kernel Size: Click the spin buttons or enter the number to change the size of the
kernel. Either direction may take into account one to nine pixels. As one modifies
the Kernel Size, the shape of the kernel representation changes accordingly. In
the center of the dialog, there are white boxes containing coefficients that will be
multiplied with each pixel that will be taken into account by the filter kernel. One

can change any coefficient by clicking on it and adjust it as desired.

Fill: Click this button to fill every element of the kernel with a particular value.
The Fill kernel dialog appears. One may enter a value between 0 and 10. Using

the Fill button is useful for setting all coefficients to the same value. One may
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then change the coefficients that require a different value.

Offset: The pixel whose value is being modified is usually the center-most pixel.
One may, however, designate any pixel. ImageView signals the pixel to be
changed by putting a box around it. Choose the X and Y Offset spin buttons to
apply

Neweee: Click to create a new filter kernel. The Edit Kernel dialog will appear. The
functions of the dialog are the same way as the dialog for Editeee described above),

with the exception that the file name for the new kernel file must be provided.
Delete: Click to delete the selected filter kernel file.

Options: The choices in this group box will vary depending upon the kind of selected
filter.

13.11 Image Stacking(S)eee =
The image-stacking method is a form of speckle imaging commonly used for

obtaining high quality images from a number of short exposures with varying image
shifts. It has been used in astronomy for several decades, and is the basis for the
image stabilization feature on some cameras. The method involves calculation of the
differential shifts of the images. This is easily accomplished in astronomical images
since they can be aligned with the stars. Once the images have aligned, they are
averaged together. It is a basic principle of statistics that variation in a sample can be
reduced by averaging together the individual values. In fact, when using an average,
the signal-to-noise ratio should be increased by a factor of the square root of the

number of images.

Image stacking can also be used for biological microscope image and florescent
microscope image to increase the image SNR and dynamical ranges; this is why we

introduce image stacking into ImageView.

ImageView Image Stacking introduced advanced image matching techniques for
rotated, shifted and scaled images. The user can record a short video to get a high
quality stacked image at ease without considering the image rotation, shifting and
scaling between a series of images in the video. The steps of Image Stacking are

described as below:
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1.

Choose Processing>Image Stackingeee menu, a Windows Open dialog will pop

up as shown below;

Open x

« v <« Data (D) » Demolmage » Stack v O Search Stack =]

o @

L]
]

Qrganize New folder
ImageCount
Sample
SCMOSD3100KPA

w -

12(000002158-000
Stitch - 021222}.avi

Stack

File name: ‘12_(00[)002_1 58-000021222).avi v| Video Files (*.wmu* asf;*.avi*r v

e

Choose the right video file recorded before in the Open dialog, here we can open

“test.avi” for demonstration, click Open to open the avi file;

Then an Image Stacking dialog will pop up to show the progress of the each

image’s stacking progress.

Image Stacking

Cancel

If Cancel is pressed, the Image Stacking will be canceled. After the stacking is
finished, a stacked image will be displayed in a new window for further
application. The final image is shown as below. One can find the stacked image
signal to noise ratio is greatly improved. From the stacked image has some black
edges, this is because the images in the video is moved and in the stacking
process, ImageView will added 0 to the image area that has no corresponding
pixel in the reference image (we choose the first image in the video file as the

reference image).
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Note: a. ImageView support wmyv, asf, avi, mp4, m4v, 3gp, 392, 3gp2, 3gpp;
mov, mkv, flv, rm, rmvb for Image Stacking operation; b) In the Image Stacking
process, ImageView takes the first frame as the reference image, this means the first
frame is very important and should be assure the first frame to be the right image

scene and the subsequent frames have a greater overlap region with the first frame.

13.12 Line Profile(L)eee
Choose the Process>Line Profileeee command to illustrate how pixels along a
selected line are distributed by graphing the number of pixels at each color intensity
level.

Line Profile X

|7 o t-lmeHR|®

180 200 220 240 260 280 300

Choose the Measurements>Arbitrary Line, or Measurements>Horizontal Line or
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Measurements> Vertical Line command to draw a line on the image and choosing the
Process>Line Profile will bring up a Line Profile dialog as above(The procedure can be

inversed):

In a Line Profile dialog, the horizontal axis represents the spatial scale, and the
vertical axis represents the intensity values which range from 0 to 255. If the image
is a gray scale image, the gray value will be profiled. If the image is a HSV color
image, the R,G,B and the brightness values will be profiled separately with the

corresponding R, G,B and black colors. Its toolbar * = = " [ 7 ¢ HE

button functions are as follows:

. Fit the current Line Profile window to the best scale;

+ 1 Zoom in the current horizontal axis;

: Zoom out the current horizontal axis;

1+ Zoom in the current vertical axis;

= Zoom out the current vertical axis;

a. Copy the Line Profile window's content onto the clipboard;

'“ . Capture the image in the Line Profile window as a new untitled image;

. save the Line Profile image in bmp format;

I3: Export the current Y axis values of R,G,B and brightness to the *.txt file.

~': Open the windows color dialog to set the background color of the profile window;

Only when the line is selected, the Line Profile can be painted in the window. Using
Object Select button "% on the toolbar to select the line over the image or video

window.

13.13 Surface Ploteee
The Process>Surface Ploteee (or 3-D Plot) tool creates a 3-D representation of the
intensity of an image. When choosing the Surface Plot command, keep in mind that

X=image width and Y=image height, and Z=pixel gray value.

In the viewpoint window, the elevation and rotation of the image can be adjusted by

dragging the mouse on the image.
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3-D Setup [ x |
Positon Sold Image Background Color =
il - 1 L IV | Resst
Color Table

LGN I Capture

Position Solid: The left edit control indicates the relative position of the entire image
in the viewpoint window, whose default value is 0.5. The right edit control indicates

the relative height of the display of the Z scale, whose default value is 1.
Reset: Set the Position Solid's two edit controls to their default values.

Image Background Color: Choose this command to display a color dialog where one

can adjust the background color of the viewpoint window.
Capture: Capture the active image in the viewpoint window as a new image.

Color Table: Select the colors to map the gray values found in the surface plot. The
button at each end of the Color Table brings up the color dialog, which allows select
the start and end colors of the range. (Please refer to Pseudo Color for more

information)

13.14 Pseudo Color(P)eee

Note: Image must be in Gray Scale.

Choose the Pseudo Color command to "colorize" the active monochromatic image.
This is used to highlight certain features in a gray scale image such as display all
densities above a certain point in red, or, the imaging device recorded thermal

information, all temperatures below a certain point can be revealed in blue color.
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Pseudo Color
Color Table
I T

When Pseudo Color a monochromatic image, a special palette need to be build with
which the monochromatic image is displayed. Pseudo Coloring an image does not
modify the pixels' values in image bitmap (it does not convert image to true color or
palette). It simply associates a Pseudo Color palette with the image that interprets

the gray-level values in the image as color.

Pseudo Colored images are very similar in structure to palette class images, but they
differ in a couple of important ways. First, the pixels' values in a Pseudo Colored
image actually represent continuous-tone intensity information, whereas a palette
image's pixels carry no intensity significance. Secondly, a palette image includes a
palette table that is actually part of the image file.

The colors used to map the gray values can be selected. The buttons at
each end of the color strips ( or ) will bring up the color

dialog separately, which allows select the start and end colors of the
range.
13.15 Rangeeeeo Shift+R
The Process>Rangeeee command allows set the intensity levels of the image to
increase the contrast and enhance the display in low-light situations. Choose the

Range command to open the Range dialog.

LE] Range - B
Reset TSNS Update

241206

Best Fit
Ivert 120603

Cancel

0 1 1
oK g 100 200

Two vertical markers show the upper and lower limits of the intensity levels. These
markers can be moved with mouse through the drag and drop method. For a color

image, the histogram will reflect the red, green, and blue values with corresponding
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colors lines.

Two Edit controls indicate the values of the intensity levels. Choose the spin buttons
to increase or decrease these values. All values between 0 and the lower limit will be
black and all values between the upper limit and the upper end of the scale will be
white. These two edit control values corresponding to the two vertical markers show

the upper and lower limits of the intensity levels. Defaults are o and 255 respectively.

Reset: The Reset button allows Reset the black and white levels to the high and low

ends of the dynamic Range.

Best Fit: The Best Fit button automatically sets the intensity levels to the Best Fit.
Best Fit instructs ImageView to optimize the brightness and contrast values for the

particular image.
Invert: The Invert button reverses the color of the image.

Update: Update will refresh the display Range with the most current image

information.

13.16 Binary(B)eee Shift+B
Binary is a kind of gray level process. If the gray of the pixel is greater than the given
threshold, the pixel's color will be changed into white. Otherwise, the pixel's color will
be changed into black. Although the process may lose some information, it is an

important step of other processes.

Binary

241206~

Best Fit -

120603—
Cancel

:
] 00 200

The curve on the Binary dialog shows the gray distribution of the image.

The Line in the dialog indicates the threshold value. Drag the line to change the
threshold, or change the value in the Line position edit box (in the top left corner of

the dialog) to move the Line.

The Line position edit box shows the current position value of the Line; Modify the
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value will move the Line at the same time;

Click the "Best Fit" button to apply the auto threshold process to the image. It uses
an automatic threshold to make the image Binary.
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14 Layer
14.1 About layer
ImageView's Layer is like sheets of stacked acetate. You can see through transparent
areas of a Layer to the Layers below. You add a Layer to position the Objects content
on the Layer, like sliding a sheet of acetate in a stack. You can also hide/show a layer

to make content invisible/visible.

You use layers to perform tasks such as perform the Measurement on the image

without polluting the image and save it for the future adjustment or further analysis.

14.2 Organizing layers
A new image has a single Layer called Background layer. The number of additional

layers you can add to an image is limited only by your computer’s memory.

You work with layers in the Layers Sidebar. The Layer Sidebar help you organize and

manage layers just like the Layer menu.

14.3 Layers for non-destructive measurement and label
Rather than edit image pixels directly, you can label the image with text and measure
the image and leave the underlying pixels unchanged. Because of the
non-destructively to images, you can later tweak or remove the label and the
Objects.

14.4 Layer Sidebar
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Layer a
SR —

F New.. Ctri+N
Remove G New.. Ctri+N
Visible Current Name Remove
Current
Show/Hide v Background Current
™ Layer? Show/Hide

ame. [v! Layer2
— V] Layer3

I Rename...
H New.. Ctrl+N | L5

RO0OI

New... Ctri+N
Remove
Current

Show/Hide et

——
e 8 k. 00 &

: Make a New layer;

: Remove a layer;

0O W >

: Set the Current layer;

D: Show/Hide a layer;

E:Rename a layer;

F: Right mouse button context menu for the Background layer;

G: Right mouse button context menu for the Current not checked layer;
H: Right mouse button context menu for the Current checked layer;

I : Right mouse button context menu in the blank area;

Note: a). Only one layer can be checked as Current Layer. If a layer’s “Current” is
checked, the Visible will be checked automatically; b). The Current and Background
layers cannot be removed. Only the non-current and non- background layers can be
removed; c). All the Objects on the Current Layer can be selected, edited or exported;
d). The non-current Layer can be Visible (checked) or invisible (unchecked).

14.5 Layer menu and layer sidebar page context menu
The function of the Layer menu and Layer Sidebar right mouse button context menu

are the same. They are:

New... Crl+N
Remove

Current
Show/Hide

Rename.

14.6 New(N)eeeo Ctrl+N
Setup a new layer. After the new layer is setup, it will be added to the end of the Layer

Sidebar’s items and the Visible and Current will be checked.

14.7 Remove(R)eoo
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Remove the non-current Layer.

Note: the Background and Current Layer cannot be removed.

14.8 Current(C)eee
Set the selected layer as the Current Layer. User then can edit the Object on the

Current Layer or added new Object on the Current Layer.

14.9 Show/Hide(S)eee

Set the non-current Layer visible or invisible. The Current Layer cannot be toggled

between Visible and invisible state. It is always Visible.

14.10 Rename(E)eeoe
Rename a Layer.

14.11 Export to Image(M) F2
Export all the layers’ Objects to the image, this will pollute the image and cannot be

recovered a nymore.

14.12 Export to Microsoft Exceleee “ F3
Export the image plus all the Objects on the Current Layer to the Excel file.

Export Options X

Labe ot e N
Label font weight: Bold ~ Cancel

Indude calibration information

Save as the default option

Label font size: Used for the Measurement Object’s label font size, the default value
is 20(8~72);

Label font weight: Normal, Bold, Heavy. The default is Bold;

Include calibration information: If the images are calibrated, check this item will
output the calibration information in the Excel file;

Save as the default option: If this item is checked, the current setting will be saved
for the future application;

E

14.13 Export all to Microsoft Exceleee
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Export the current opened different images which have Objects on their Layer to a
single Excel file. This function can be used to capture images with measurement
objects from different video field of view who may have the same characteristic. The

output in the Excel file then can be processed to get the statistic properties.

The menu will be active only when 2 or more images are opened and have
Measurement Objects over the images.

Export Options X

Label font size: 20 =

Label font weight: Bold ~ Cancel

Indude calibration information

Save s the default option

Label font size: Used for the Measurement Object’s label font size, the default value
is 20(8~72);

Label font weight: Normal, Bold, Heavy. The default is Bold;

Include calibration information: If the images are calibrated, check this item will
output the calibration information in the Excel file;

Save as the default option: If this item is checked, the current setting will be saved
for the future application;
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15 Measurements
The Measurements menu is mainly used for the image measurement. With this menu,
you can measure the image with many geometrical shape at ease. ImageView use
Layer technique to manage the measurement object. This will never pollute the

image pixels. The Measurements menus and its submenus are shown below.

/ Arbitrary Line D

{ Object Select

>

— Horizontal Line E

B | £ angle | vWertical Line F

C | = Point

Line

G |/ Parallel X Four Points [
H |% Tvo Parallels Rl Trace Folms )
Vertical »
»/
>/

Rectangle (3 Center+Radius O
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O
L | O Roundrect
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R Armulus

Two Circles
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N
Text
Yy Polyszon / 3 Top X

Z Order » Botton Y
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=< c

[

&

Hove dovn AA

o

About the Layer technique, please check the Layer menu and Layer Sidebar in
Sec.14.

About the Measurements setup, please check Options>Measurementeee and

Measurement Sidebar in View>Sidebar menu in Sec.8.

About the Measurements menu’s toolbar buttons, please check ImageView’s toolbar
in Sec.4: UI toolbar.

15.1 Object Select(S) R

The Measurements>O0Object Select menu or the toolbar button
only when a new Measurement is made over the Background Layer.

*  will be enabled

After the Measurement is done on the specific layer, choose this menu to select the
Objects.

1. The Object can be selected by clicking on it;
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2. Select a group of Objects by including them in a rectangular area with Object
Select command or by press down the Shift key and clicking the Object with left

mouse button until all the desired Objects are selected.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.2 Angle(N)

15.2.1 Angle (3 Points)

e ‘

1. Move the mouse on the image to point 1, mark it by clicking the left mouse button;
2. Move the mouse to point 2, mark it by clicking the left mouse button;

3. Move the mouse to point 3, mark the final point by clicking the left mouse button.

A label 50.26° will be shown near point 2;

15.2.2 Angle (4 Points) A

1. Move the mouse on the image to point 1, mark it by clicking the left mouse button;

2. Move the mouse to point 2, mark it by clicking the left mouse button; Point 1 and

point 2 will be connected automatically to form L12
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3. Move the mouse to point 3, mark the final point by clicking the left mouse button.

4. Move the mouse to point 4, mark it by clicking the left mouse button; Point 3 and

point 4 will be connected automatically to form L34

After the above process, L12 and L34 will be extended with the dot line to form an
angle between L12 and L34.

A label 34.40° will be shown near vertex;

15.3 Point(P)

P1@(36331.57, 12698.41)um ‘h.
7 A
& %
- A .
"I\ r
L <)

Move mouse to the point; click the left mouse to mark it. It will show the point Label

Pn and its position x and y over the image.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a

single Object is selected. The Calculation will be effective for a single selected Object
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or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.4 Line(L)

15.4.1 Line>Arbitrary Line(A)
Draw Arbitrary Line between the two points on the specified layer.

1. Choose the Measurements>Line> Arbitrary Line command;
2. Move mouse to the 1st point; click the left mouse to mark it;

3. Move mouse to the 2nd point, click the left mouse to mark it again, a line with L1

and its length will be shown.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.4.2 Line> Horizontal Line(H)

Draw a Horizontal Line between the two points on the specified layer. When the 1st
point is marked, the 2nd point’s y coordinate will be restricted to equal to the first
point’s y coordinate automatically.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
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can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.4.3 Line> Vertical Line(V) I

Draw a Vertical Line between the two points on the specified layer. When the first
point is marked, the second point’s x coordinate will be restricted to equal to the first

point’s x coordinate automatically.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.5 Parallel(R)

1. Choose the Measurements>Parallel command;
2. Move mouse and click to mark the 1st point;
3. Move mouse and click to mark the 2nd point;
4. Move mouse and click to mark the 3rd point;

5. Move mouse again, one will find the 4th point is always restricted to parallel to the
line connecting point 1 and point 2. Click to mark the 4th point. Two parallel lines will

be labeled and numbered.
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B Appearance
Line Width 3
Line Color W oooof
Line Style
Coordinates
Start1.X a8
Startl.y E1
End1.X 2n
EndlY 133
Start2X 25
Start2y 77
End2X 248
End2Y 208
Calculation
Length 50272.90, 91227..
Slope 059
Angle 143.66
Distance 16096.83 LI

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

15.6 Two Parallels(0)

1. Move mouse and click its left button to mark the 1st point.

2. Move mouse and click its left button to mark the 2nd point. Line 1 (the 1st line)

connect these two points will be overlaid on the image
3. Move mouse and click its left button to mark the 3rd point.

4. Move mouse again, one will find the 4th point is always restricted to parallel to the
Line 1 connecting point 1 and point 2. Click to mark the 4th point. Line 2 will be drawn
which is parallel to Line 1. A dot line DL 1 located at the center of Line 1 and Line 2

will also be marked. Thus the 15 parallel is finished.

5. Repeated step 1~4 will draw Line 3 and Line 4. A dot line DL 2 located between the

center of Line 3 and Line 4 will also be marked. Thus the 2nd parallel is finished.

6. ImageView will label the distance between DL1 and DL2 in with Unit specified in

the Unit combo box. The final result is shown below:
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15.7.1 Vertical>Four Points.

1. Move mouse and click its left button to mark the 1st point.

2. Move mouse and click its left button to mark the 2nd point. A line (the 1% line)
connect these two point be overlaid on the image

3. Move mouse and click its left button to mark the 3rd point.

4. Move mouse again, one will find the 4th point is always restricted to perpendicular
to the line of point 1 and point 2. Click to mark the 4th point. Two vertical lines will be
labeled and numbered.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).
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15.7.2 Vertical>Three Points

1. Move mouse and click its left button to mark the 1%t point;

2. Move mouse and click its left button to mark the 2nd point. A line (the 1% line)

connecting these two points will be overlaid on the image;

3. Move mouse and click its left button to mark the 3rd point. The 2™ line will be

overlaid on the image which is perpendicular to the 1% one.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

O

15.8 Rectangle(T)

1. Move mouse to the 1st point; click its left mouse button to mark it;

2. Move mouse to the 2ed point; click its left mouse button to mark it. A Rectangle
will be overlaid on the image according these two diagonal points.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you

can edit the corresponding Object parameters to modify its properties; b) The
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Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.9 Ellipse(I) E‘

1. Choose the Measurements>Ellipse command;
2. Move mouse to mark the 1st point;
3. Move mouse to mark the 2nd point;

4. If it is not superposing with the shape on the image, choose the
Measurements>O0bject Select command to adjust the position to adjust the Ellipse in
order to coincide with the image shape.

B Appearance
Line Width 2
Line Color W oooott
Line Style
Fill False
Fill Color [ c0c0c0
B Coordinates
StartX 203
StartY )
EndX 271
EndY 105
B Caleulation
Center (40636.64, 11852.35)
Axes 5248.90,5926.18
Perimeter 70215.07
Area 97722085.25

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

15.10 Circle(C)

15.10.1 Circle>Center+Radius @
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Choose the Measurements>Circle>Center+Radius command to draw a circle with
Center+Radius method on the specified Layer. Its radius is C1@33583.88um.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.10.2 Circle>Two Points O

Choose the Measurements>Circle>Two Points command to draw a circle with Two

Points method on the specified layer.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

15.10.3 Circle>Three Points O
Choose the Measurements>Circle>Three Points command to draw a circle with

Three Points method on the specified layer.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you

can edit the corresponding Object parameters to modify its properties; b) The
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Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

©)
15.11 Annulus(U)

1. Find the Annulus center 1 and click mouse button to mark the Annulus center;

2. Move mouse to let the first circle superpose with the image circle, clicking the

mouse left button;

3. Move mouse to let the second circle superpose the image circle, clicking the left
mouse button. Two radiuses with number and the units will be displayed on the

Annulus;

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

73]

15.12 Two Circles(W) @7

15.12.1 Two Circle>Center+Radius(R)
Draw two circles with Center+Radius method on the specified layer. After the two

circles are drawn, a line connecting these two circle centers will be drawn.

Note: a) To check or modify the parameters of the selected Object, just select a

single Object and the Measurement Sidebar will be activated automatically. Here you
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can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.12.2 Two Circle>Three Points(3)
Draw two circles with Three Points method on the specified layer. After the two circles

are drawn, a line connecting these two circle centers will be drawn.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

15.13 Arc(A)

1. Move mouse to mark the 1st point;
2. Move mouse to mark the 2nd point;

3. Move mouse to mark the 3rd point, then an Arc with Label and its Length will be
drawn connecting these three points.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The

Appearance, Coordinates on Measurement Sidebar will be enabled only when a
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single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object
type (The type could be the same or different).

15.14 Text(X)
1. Choose the Measurements>Text command;

2. Move mouse to mark the 1st point;

3. Move mouse to mark the 2nd point, a rectangle with dash line restrict the Text
window size. After the mouse button is released, a dialog called Text will bring up for

you to enter the Text and define the Text, Frame styles and adjust the Text positions.

4. Enter the text and click the right mouse button to end the Text object.

Text n -

oK Cancel

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

oy
15.15 Polygon(G) =

1. Choose the Measurements>Polygon command;
2. Move mouse and click the left mouse button to mark the 1st point;
3. Move mouse and click the left mouse button to mark the 2nd point.

...’
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n. Move mouse and click the left mouse button to mark the nth point;

Click the right mouse button to end the Polygon command.

Note: a) To check or modify the parameters of the selected Object, just select a
single Object and the Measurement Sidebar will be activated automatically. Here you
can edit the corresponding Object parameters to modify its properties; b) The
Appearance, Coordinates on Measurement Sidebar will be enabled only when a
single Object is selected. The Calculation will be effective for a single selected Object
or multiple selected Objects. Its calculated items will depend on the selected Object

type (The type could be the same or different).

15.16 Curve(E)

15.16.1 Curve>Model 1
1. Press down the left mouse button and move mouse according to the requirement

to draw any curve in Model 1 format.

2. If the mouse left mouse button is released and move the mouse to a new position

and then click the left mouse button again will draw a line to connect the last point.

3. Release the left mouse button and click the right mouse button to end Mode 1

Curve.
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T

15.16.2 Curve>Model 2 s
The Model 2 Curve operation is almost the same that of the Polygon,
1. Choose the Measurements>Curve>Mode 2 command;
2. Move mouse to a point and click the left mouse button to mark the 1st point;

3. Move mouse to a point and click the left mouse button to mark the 2nd point.

4, eee;
n-1. Move mouse to a point and click the left mouse button to mark the (n-1)th point;

n. Move mouse to the final point and click the left mouse button to mark the nth point,

then click the right mouse button to end the current Mode 2 Curve process.

e

Choosing E button can adjust the finished Model 2 Curve.

10m
=

15.17 Scale bar(B)

Choose the Measurements>Scale bar command will bring up a Scale Bar dialog as
below:

Scale Bar
(—

o o]

Input the number in the length edit box to determine the scale bar length. The Unit

is chosen according to the current Unit in the Options>Measurement>Length Unit
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page. If the Unit is pixel, then Scale Bar dialog will be change to

Scale Bar
[z0g] = Pixels

OK Cancel

Change the default value(100) to the desired length or directly click OK, a Scale bar
will display on the image in measurement style. One can move the Scale bar to
where ever he wants(Choosing Measurements>Object Select after the Scale bar is
displayed on the Image or Video window and move the mouse to the Scale Bar and

click down the left mouse button). The final result should be:

15.18 Arrow 7'
Draw an Arrow on the image to specify the key point on the image or video.

15.19 Z Order(Z)

The Z Order submenu is shown below:

& Top
45 Bottom
4 Move up

.4 Move down

Top: Modify the selected Object's relative position to the uppermost place of all

Objects on the Current layer;

Bottom: Modify the selected Object's relative position to the lowest place of all

Objects on the Current layer;

Move Up: Modify the selected Object's relative position to the higher place of the two

on the Current layer;
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Move Down: Modify the selected Object's relative position to the lower place of the

two on the Current layer;
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16 Options

16.1 Preferences(P)eoe ‘a

There are 7 pages for the Preference dialog. They are Quick Save, File, Print, Grids,

Cursor, Capture and Misc pages.

16.1.1 Quick Save Page

The File>Quick Save menu or the Quick Save icon u on the toolbar will be

enabled when a)a new image window with the captured image from the camera;

b)an image window is created by choosing the File>Paste as New File menu.

File>Quick Save can save the file at quick way with no need to specify the file
directory, file name and file format. All those are specified in

Options>Preferenceseee>Quick Save property page.

Preferences
) Directory:
Quick Save
D:\Test Imag; p

File

File
Print

Name Format: | nnnn (sequence) v
Grids

File Prefix: test
Cursor

File type: png v Option

Capture
Sample: test-0001.png
Misc
[¥] Shows the rename dialog

The above settings will be applied to "Quick Save" menu and the
corresponding button in the toolbar. When calling "Quick Save", images will be
saved quickly according to the above settings in the specified directory.

Cancel Apply
Directory: Enter the name of the drive and directory where the new image will be
saved. You may either type the path information, or use the Browse button “* to

locate it from a standard Browse Folder dialog;

Name Format: The year, month, date, hour, minute and second or nnnn(sequence)
are used as part of the file name. If more files are saved with in a second, a (xx)
suffix is attached to the end of Name Format to avoid the possible name confliction.

For the nnnn(sequence) Name Format, no suffix is needed.

File Prefix: Enter a file name prefix for Quick Save when generating files names for a
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series of images. This prefix will be combined with Name Format to form a final file

name naming paradigm.

File Type: In this combobox, select the format in which you want the image to be
saved (can be BMP, JPG, PNG, TIF). Click Option button to set the different
parameters for encoding the file (For BMP format, the Option will be disabled. See
File>Save Aseee menu about the details of the format encoding methods); If there
are Objects over the image, the File Type will be chosen as “ImageView File Type
(*.tft)"” by ImageView.

Sample: The final file name is shown at the right of the Sample label for reference.

Show the rename file dialog: The file name can be renamed according to this item’s
setup. When this item is checked, a Rename dialog will pop up after choosing
File>Quick Save command or click the Quick Save icon d on the toolbar. The new

name can be specified again according to the requirement.

Rename n
= |

Cancel

16.1.2 File Page
One can check a file Extension for the specified file Format and its
Abbr.(abbreviation), to determine whether or not it will be displayed in the Browse

window or not (The checked Format can be displayed in the Browse window).
Extension: Used to identify the file extension;

Format: English full name of file formats;

Abbr.: File Format’'s abbreviation;

Browse: Check/uncheck to determine whether or not the file format can be displayed

in the Browse window;

Config...: To configure the image file Save As Option for JPEG, Portable Network
Graphics, Tag Image File Format, CompuServ, JPEG 2000 Standard, JPEG
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Codestream. For details, please refer to the Option button explanation in the

File>Save As dialog.

Preferences

Quick Save Extension Format Abbr. Browse N i config... |
- ‘ tt TFT TFT
bmp Windows Bitmap BMP
Print dib Windows Bitmap BMP
rle Windows Bitmap BMP
Cursor Ipeg IPEG IPEG
Jpe JPEG JPEG
Capture jif IPEG IPEG
Misc ifif JPEG IFEG
png Fortable Network Graphics  FNG
i Tag Image File Format  TIFF
tiff Tag Image File Format TIFF
gif CompuServe GIF GIF
pex PCX PCX -
oK Cancel Apply

16.1.3 Print Page
One can set the Page Header and Page Footer in following format:

Preferences

Quick Save
3 Page Header: Fage: &p/&F
File
Print Page Footer: &f Date: %Y-%m-%d
Grids
Print the measurement items

Cursor

Frint the measurement table
Capture

Fage Usage: Always use anather paper v
Misc

Segoe Ul 9pt Font...
&f File Name

&p Current Page
&P Total Pages
%A Full weekday name
%b Abbreviated month name
%B Full month name
%c Date and time representation appropriate for locale
%d Day of month as decimal number (01 - 31)
%H Hour in 24-hour format (00 - 23)
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%]I Hour in 12-hour format (01 - 12)

%j Day of year as decimal number (001 - 366)

%m Month as decimal number (01 - 12)

%M Minute as decimal number (00 - 59)

%p Current local times A.M./P.M. indicator for 12-hour clock

%S Second as decimal number (00 - 59)

%U Week of year as decimal number, with Sunday as first day of week(00-53)
%w Weekday as decimal number (0 - 6; Sunday is 0)

%W Week of year as decimal number, with Monday as first day of week(00-53)
%x Date representation for current locale

%X Time representation for current locale

%y Year without century, as decimal number (00 - 99)

%Y Year with century, as decimal number

%z %?Z Time-zone name or abbreviation; no characters if time zone is unknown
%°%% Percent sign

For example:

Choosing &f Date:%Y-%m-%d will print the file name and Date with yyyy-mm-dd

format on the page header.

Choosing Page:&p/&P will print Page: 01/11 on the page footer(Suppose the current
page is page 1 and the total pages is 11).

Print the measurement item: If there are measurement item overlaid on the image,

check it will print these objects on the image. Measurement Sheet on the page;

Print the measurement table: If there are measurement item overlaid on the image,

check it will print these objects’ Measurement Sheet on the page with;
Always use another paper: Print the Measurement Sheet data on a separate page;

Auto: Print the Measurement Sheet data just behind the image (if the image and

data can be arrange in a single page) of on a separate page (if not);

Do not use another paper: Print the Measurement Sheet data just behind the image

page;
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Font: Choose the Font for the data.

16.1.4 Grids Page
Choosing the View>Grid>Settingeee command, or choosing the Preference>eee

command and clicking the Grids page realize the same function.

Choosing the Preference>eee command and clicking the Grids page can set the Grid
Style, Line Style, and Line Color for the Grid overlaid on the video and image window
can also be set.

Preferences

Quick Save
Style: No Grid v
File
Line Style: Solid
Print

— Line Color: ‘D Default

Cursor
Capture

Misc

oK Cancel Apply

Grid Style: The Grid Style can be No Grid, Auto Grid or Manual Grid. Default is No
Grid;

Grid Line Style: The Line Style for the grid can be Solid, Dash, Dot or DashDot et al.
Default is Solid;

Grid Line Color: The color of the grid line. Default is Red (255,0,0).

16.1.5 Cursor Page

This command will set the mouse cursor for the video and image window operations.
Select the Horizontal cross in:

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels),
Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.

Select the Vertical cursor in:

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels),
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Double(5 Pixels), Double(7 Pixels), and Double(9 Pixels) formats.

Single means single line. Double means two parallel lines. 1 Pixel means the line
space between the two lines is 1 pixel in distance. The other sizes also have this

meaning.
Select the cursor shape from Cross, Point, and Null.

In the figure below, a cursor with Double horizontal and vertical lines with 9 Pixels
cross (for the alignment application, the longer one) and the Cursor as a Cross was
defined

Preferences

Quick Save Cross

Horizontal Mone v

File 1 Fixel)

Double (5 Pixels)
Double (7 Pixels)
Double (9 Pixels

(

Double (3 Pixels)
(
(

Print Vertical: None v

Rulers and Grids
Cursor

Cursor Cross.

Cross v Point
Null

Capture

Misc

L~ Cross:doublelines with o
pixels in both directions

Cursor: Cross

Cancel Apply
16.1.6 Capture Page

If one wish to capture an image with many Objects overlaid on the video window, the

following settings should be defined first.

1.Choosing the Options>Preferenceseee>Capture command, a dialog called

Preferences will be brought up as shown below;

2.Clicking the Capture page and then checking Capture with Marker and Watermark

or Capture with Measurement;

3.Click Ok to end the setup, or Apply to apply the setup, or Cancel to cancel the

setup.

4 .After the above steps are finished, if there are Marker, Watermark or Objects

overlaid above the video, choosing the Capture>Capture Image or clicking
on the Camera Sidebar will capture the image with Marker, Watermark or Objects
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overlaid on the image.

Preferences -

Quick Save Capture with Marker and Watermark
File

[] capture with Measurement
Print

Rulers and Grids

Cursor

Capture

Misc

16.1.7 Misc Page
The Misc page is mainly used for the control of the ImageView UI. It mainly includes:

Preferences x

Quick Save

revent screensaver when videa preview / capture

File I thtFie

Remind me when save file with measurement not in tft format
Print I Units of temperature

@ Celsius (1)

Grids () Fahrenheit (°F)

[ sidebars

activate the when measuring
Automatically activate the folders sidebar when opening the brorse window
Automatically show the browse window when double cicking the folders
activate the camera sidebar when startup

Cursor

Capture

Misc FH urstye
@ Windows
O Windows 7
O visual Studio 2008
O LunaBlue
(O Obsiciian Black
O Aqua
O silver
O visual Studio 2005
(O Office 2003
) Office XP
O Visual Studio 97
#§ Language (Take effect after restarting ToupWiew)
O Default
@® Englsh
(O Catalan {Catald)
O French (Frangais)
O German (Deutsch)
(O Indonesian (Bahasa Indonesia)
O Japanese (HF:5)
) Korean (23%)
O Polish (Polsk)
O Russian Pycaai)
(O simplified Chinese (BIHAAI3T)
() Sparish (Espafiol)
O Thai (Lne)
O Traditional Chinese (ZH&h37)
(O Turkish (Turkee)
#2 Enable GPU accelerated image processing
Mo
() Yes (intel(R) HD Graphics 530)
(3 Privacy
The maximum number of Recert Files: 4
[] Clear the Recent Files when exit the application
[ Restore the current directory when startup

Cancel Apply
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. ImageView’ special file format warning information;
. Units of temperature

. Sidebars;

. UI Style;

. Language;

a1 A W N

. Privacy;
settings et al.

16.2 Measurements(M)eee

This sheet has many pages. They are:

16.2.1 General page

The General page is shown below:

The calculation results keep: The combo box allows you to set the calculation results

accuracy among ldecimal and 6 decimals. Default is 2 decimals;

Label font size: The Label is used to display the Objects dimensions. the Label font

size is among 5 and 15; Default is 15;
Label Color: The Label Font color for the Objects dimensions; Default is red;

Measurement

General The calculation results keep: 2 decimals v

Length Unit
Label font size:
Angle Unit

Label color: Default
Sheet

Object Dimensions with unit

1 decimal
[¥]Label with name 3 decimals

4 decimals

5 decimals

6 decimals

Dimensions with unit: If this box is checked, the Dimension will be displayed together
with the unit for the Objects. If unchecked, only the Dimension will be displayed with
the Objects.
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Label with name: Checking Label with name will add a Prefix before the Objects
number. The Prefix for the different Object can be specified in the Measurement
Sidebar where there is an item called: Name. Here, we show an example for Line

Object with and without Prefix L1 as below:

Labelwith name checked

Label with name unchecked

16.2.2 Length Unit page
Length Unit page: One can select the Length Unit for the Measurements menu’s

Objects on the Layer Measurement operation.
Unit: The system unit defined by the ImageView. It cannot be deleted;
Current: The Unit selected or checked;

Type: Type of unit. It can be System (Defined by ImageView) or User (Defined by the

user) type;

Scale: Represents the ratio of "Meter by unit". For example, if the unit is um, then
"Meter by pm" should be 1000000, the Scale should be 1e+6;

Measurement n
General Unit Current  Symbol  Type Scale
_ Pixel Syt A
Length Unit e [ L ystem
Nanometer O nm System 1e+009
Angle Unit Micrometer O um System  1e+006 Add Unit
sheet Millimeter mm Systern 1000 Ol
eel
Centimeter O cm System 100
oot | w0 m smm s vome: [pesmeter
Inch O in System 39.37
Scale: 10 Cancel
Symbol: dm
1. Scale is the ratio between meter and the specific unit. For example:
Meter by millimeter is 1000 which can also be expressed as scientific
notation 1e3.
Meter by kilometer is 0.001, which is noted as 1e-3.
Add...
2. Symbol: such as" m" for meter, " cm" for centimetre.
oK Cancel Apply

Add: User can also define his own Unit. Clicking Addeee button and the Add Unit
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dialog will be brought up as above;

Here, one can enter the unit Name and Symbol in their fields. Here, we enter a name
called Decimeter and its Symbol is dm, its Scale for Meter by Decimeter is 10. Click
OK to end the Add Unit operation, or Cancel to cancel the Add Unit operation.

The final Length Unit list looks like the figure below:

Measurement

General Unit Current  Symbol  Type Scale
Pixel Syst A
Length Unit e d P ystem
Nanometer O nm System 1e+009
Angle Unit Micrometer (] um System 1e+006
Millimeter mm System 1000
Sheet
Centimeter O cm System 100
Object Meter O m System 1
Inch 1 in System 39.37
Decimeter O dm User 10

oK Cancel Apply

You can find the Type is now named User. This means that this Unit is not defined by
the System, but by the User.

16.2.3 Angle Unit page
On the Angle Unit page, one can select Radian, Degree, or PI as the Angle Unit.

Measurement n

—— Radian

General Degree v
Length Unit m
=]
Angle Unit [¥] Show all the angle units in the measurement sidebar. Nane .
Label Type Length
Sheet Line ¥idth 0
Line Color M o000
Object Line Style
Arrovl
ArTow:
=]
Start (27.54, T.42)
End (14.50, 18.75)
Length 17.27
Slope 0. 87

4ngle (Radian) 0.72
4ngle (Degree) 40,99

Angle (Pi) 0.23

B

Start. X 564

Start. ¥ 152
| Eni. 3 27

End. ¥ 384

178



Options

Show all the angle units in the measurement sidebar will list all the Object Units in

the Measurement Sidebar as shown above for reference.

16.2.4 Sheet page

See the View>Measurement Sheeteee menu to understand its functions.

1. To modify the Measurement Sheet'’s item order, click the item to highlight it, the Up
or Down buttons will be enabled (If the item is in the third position, the Up button will
be disabled, if the item is in the last position, the Down button will be disabled). Click

the Up or Down buttons to modify the item position;

Note: The item Index and Name are always in grayed states, this means these two

items cannot be modified (Both their hide/show states and their positions).
2. Checking/Unchecking the item will show/hide the item in the Measurement Sheet;
3. Clicking Default will return to the ImageView's default settings;

4. Both the name and order for Item 1(Index) and item 2(Name) cannot be changed.

Measurement

General Define the columns of the measurement sheet:
Length Unit [Wlindex up

B [¥]tame
Angle Unit [¥]center
T [¥]Diameter b

[v]Area

Object [¥]Length Default

[v]Angle
[v]start
[w]End
[w]Distance

16.2.5 Object page
The Object page list the Point, Line, Parallel, Two Parallels, Vertical, Angle, Rectangle,
Circle, Arc, Annulus, Two Circles, Ellipse, Polygon, Scale Bar, Text characteristics.
Their characteristics can be modified in this page according to the requirement.
Different Object has different characteristics.
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Measurement
General Set the default properties of the measurement object:
Length Unit g ~
Label Type Coordinates
§ Size 8
Angle Unit Line Color W 003etf
Sheet 8
Label Type Lensth
Object Line ¥idth 0
Line Color W £7o000
Line Style
Arrowl
Arrow2
B
Label Type Distance
Line Width 0
Line Color W ££o0c0
Line Style
B
Label Type Distance
Line ¥idth 0
Line Color I 500050 v
oK Cancel Apply

Click Defaults can return the all the modifications to the Default one.

16.3 Magnifications(F)eee
Choose the Options>Magnificationeee command to manage the calibrated

Magnification.

If one has defined the 4x, 10X, 40X, 100X Magnifications, the Magnification dialog
should look like:

Magnification
Name Resolution oK
X 20480
10X 51200 Cancel
40X 204800
Clear All...
Delet:
up
Down
Export.
Import...

1. Highlight the Magnification item and the Deleteeee button will be enabled. Click

Deleteeee to delete the selected item;

2. Highlight the Magnification item, click the Up or Down button to modify the
Magnification list order; The Up or Down button will be disabled when the highlight

item is at the first or last position;
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3. Click Clear Alleee to delete all of the Magnification items; If one wishes to use the

Magnification late, a backup should be made first;

4. Click Exporteee to back up the Magnification in a safe media. The file extension is

“* magn”;

5. After the new installation is finished, the Magnification can be import by choosing
the Options>Magnificationeee command and click Importeee to load the previously

saved “*.magn” file;
6. If everything is ok, press OK to end the Magnification management dialog.

16.4 Calibrate(D)eee L
The detailed calibration steps are as follows:

1. Run ImageView;
2. Connect the camera to the computer and microscope;
3. Start the camera (Here, it is XXXXX);

4. Switch the microscope object to 10X and put the TS-M1 micrometer in the middle
of the microscope field and try to find the ruler clearly. Set the Unit to Pixel and the
video Resolution to the maximum one (2048X1534 for XXXXX) and Zoom ratio to
100% (see it il itk [7);

Calibration Slide

TS-M1/106071 1Bie =001 mm

® Rular 1003 0.01mm= {mm

5. Choosing the Options>Calibrateeee command or clicking B, on the toolbar, a

red line with pixels number and 0.000um length is overlaid on the video window. At

the same time, a dialog called Calibrate will be displayed over the video window;
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4ax
4 10x
20X

40X

Magnification
ke ¥ 100x
Actual Length | Micrometer (ym) v
Cancel
Pixel 1088.000
Micrometer (um) 1 &
Resolution pixel/Meter  Millmeter (mm)

Centimeter (cm)
Meter (m)
Inch (in)

Pi

ixel
Actual Length

6. Try to align the two ends of the red line with the video ruler scale (Try to pull the
red line as long as possible to keep the calibration accuracy);

7. Enter or select the current microscope objective lens Magnification in the
Magnification field. The current Magnification is 10X;

8. Read the overlaid (by the red line) micro-ruler actual length and fill it in the Actual
Length field, the current Actual Length is 450um. This Actual Length will also be
displayed in the middle of the red line just behind the pixel number. At the same time,

the Resolution will be calculated and displayed simultaneously in the Resolution field.

LT T GiDl SIS S e e o
Calibrate n
Magnification | oK
Actual Length @ Micrometer (ym) v
Cancel
Pixel 574.000

End Point w
Resolution 1275556 Pixel/Meter

Pixel
Actual Length
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9. If everything is ok, click Ok to end the calibration. The Magnification 10X (This is
the number you entered in the Magnification edit box) will be available in the

e 5
Magnification dropdown combobox on the video window toolbar ;

10. If you wish to make the measurement under this Magnification, choose 10X in
the above Magnification dropdown combobox first and then choose Unit in the Unit

dropdown list box( e w = 102 T ") which is just in the left of the

Magnification’s dropdown combobox (User can also choose Unit through the
Option>Measurementseee menu, a dialog called Measurement will be brought up.
Click Length Unit page to display the Length Unit page and and checking Unit in the

Current item.

Measurement

General Unit Current  Symbel  Type Scale
Pixel O px System NA

Length Unit
Nanometer nm  Sysem  1e+009

]
] mm

Millimeter System 1000

Sheet

Centimeter O cm System 100
Object Meter ] m System 1
Inch O in System 39.37
Add... Delete

Now, you can measure the objects with the selected Unit at ease.

lun[mlllmhm’wlu I

11. The selected Resolution can be saved for the future image Measurement
operations. If the Measurements are performed on the video, the objects and
Resolution can be saved in the image with ImageView File Format (*.tft) for the

future applications;

12.The other microscope Magnification such as 4X, 40X,100X can also be defined

just as the above steps. Thus when you switch the microscope objective lens, you

just need to select the Magnification (xz 5 for example) on the toolbar to perform
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the Measurement operations.

16.5 Edit Dye List(E)eee
The Dye List can be used for the Process>Color Composite operation. The new Dye
List feature in ImageView allows you to select from a list of dyes, or add your custom
dyes to the list. The list of dyes (ImageView.dye) is stored under C:\Program
Files\ToupTek\ImageView directory.

Edit Dye List “

Name: 15 IAEDANS

Extraction Wavelength: 336

ACRCCERS

Emission Wavelength: 482

Color: Red: 000 Green: 214 Blue: 255

New... Delete Save

Relad

When you choose Options>Edit Dye Listeee command, you will see the Edit Dye List

dialog box:

The list includes any dye definitions found in the current location. When this feature
is used to prompt for a specific dye, the list indicates the currently selected dye, or

you may select a dye from the drop-down list.

Name: This list includes all dye definitions found in the current dye file. You may
select a different dye from the drop-down list, and all the remaining controls will be

updated to show the characteristics of the new dye.

Emissions Wavelength: This field displays the emissions wavelength for the dye you
have chosen. You can adjust he emissions wavelength by entering a new value. The

default color will change in response to changes in the emissions wavelength.

Excitation wavelength: The default wavelength for your dye is displayed here. You

can adjust the wavelength by entering a new value.

Color: Use the slider to adjust the emissions wavelength for your dye, which also sets
the default display color. (You can also use the Color button =l to select a specific

color using a standard Windows color selection dialog) The color will change in
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response to changes in the emissions wavelength. Here you can change the color
associated with the selected dye, or define a custom color. The color default is linked
to the selection of a wavelength for your dye. If you change the Emissions
Wavelength, the color displayed will be the standard color for that wavelength. To set

a custom color, first you should set the wavelength and then edit the color.

Color

Basic colors
I ..
Il 30|
ERNEEEEEN
HE NN 4
EEEEEEEN
4 0 0 1 Il I
Custom colors u i
LY B Hue: | 126 Red:[0
L L - Sat|240 | Green 214

Define Custom Colors >> ColoriSolid | - [ 120 Blue: 255
Cancel Add o Custom Colors

New: Clicking New will setup a new dye, this will invoke a dialog called New Dye.
Input your New Dye name and click Ok to end the dialog and click Cancel to cancel
the input. This will return to the Edit Dye List again and the new name will be the
default on in the Name list box. Try to set the Emissions wavelength, Excitation

wavelength, Color for your new dye.

New Dye
News Dye 1

Save: Click Save on Edit Dye List to save your dye selection
Close: Click the Close button to end the Edit Dye List dialog:

16.6 Auto Correction(A)eee
Set the low and high ranges for the Image>Adjust>Auto Level and
Image>Adjust>Auto Contrast menus. The default value is 0.5% for both, but

ImageView suggests this value be smaller than 1%.
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Auto Range
Auto Level

Low Gipping High Cipping
0.0050 5 0.005 2

Auto Contrast

Cancel

Low Clipping  High Clipping
0.005 2 0005 2

See Image>Adjust>Auto Level and Image>Adjust>Auto Contrast for details.
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17 Window
17.1 Close AllI(C)

Choosing the Closes All command to close all of the pictures opened or captured
inside ImageView frame. If you have made any modifications to the pictures or if you
have captured some pictures from the camera, choosing the Close All will let you
finish the saving operations quickly.

Video [ Camera XXX | 0001* 0002 0003  0004* | greencelljpg
video window images captured opened

If the above image windows exist, choosing the Window>Close All command will

bring up a Save Files dialog as below:

Save Files

File has been modified. Do you want to save changes?

Yes Mo Cancel

Yes to Al No to All Batch Save

1. Clicking Yes on the Save Files dialog will close the Video , Browse, Image windows
directly that are not changed without ask anything. If there are newly created Image
windows, ImageView will bring up a Save As dialog to prompt user to enter the File
name to save file.

Save As X
Savein: | Sample ] @@ mr
* U :
Quick access -
@ k, —
Desktop 5. 2009-large,jpg 2nd2003exlargejpg 04-2009-largejpg 4th2007exlargejpg
m
Libraries
@ 4x_02jpg 06-2010-largejpg 6th2002exlarge,jpg
Network
Fie name: [ v [se ]
Save as type: JPEG ("jpa:”jpeg:” jpe:"jf:* ffif) v Cancel
Option

Indude calibration information
[Jsave as the default option
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If Save or Cancel is clicked in the Save As dialog, ImageView will return to the Save

Files dialog to continue the next file close operation;

2. Clicking No on Save Files dialog will close the current image window without saving

operation and return to the Save Files dialog to continue the next file operation;
3. Clicking Cancel will cancel the Save Files dialog without doing anything;

4. Clicking Yes to All on Save Files dialog will always bring up a Save As dialog to let
you enter the File name to save files one by one until all of the files are saved;

5. Clicking No to All on Save Files dialog will close all of the image windows without

saving them;

6. Clicking Batch Save on Save Files dialog will transfer the save process to
File>Batch Saveeee command. Please check the File>Batch Saveeee menu for

details;

Note: If you have a lot of pictures opened and have made some modifications on
them and want to close them quickly without saving anything, you may uses this
command and choose Step 5. All the images will be closed instantly, no warning will

be given.

17.2 Reset Window Layout(R)
Choosing Window>Reset Window Layout will reset the ImageView window layout to

the original one. The reset will be effective after restart.

The App X

| Thewindow layout will be reset after restart The App

17.3 Windows(W)eee -3

Choosing the Window>Windowseee will open a dialog box that lets you manage the

currently opened windows.

The dialog allows you to manage large lists of open windows by assigning them into
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groups. Let us say you have 10 windows opened, but want to close 4 of them
scattered through the list.

Windows E

= 0001

= 0002 2%

2 0003

ook Save

= 0005 Close Window(s)

1 0006

12 0007

2 0008
\e= Video [Integrated Webcam]

1. Choose the Window>Windowseee command;

2. Select the windows you want to close. Hold Ctrl or Shift key to select more than
one at a time. Here, 4 items are selected;

Windows

Activate

Selectwindow:

4= 0001%

ox

= 0003

e

IS 0005 Close Window(s)
= 0007

= 0009

| Video [Integrated Webcam]

3. Click Close Window(s) button, those 4 selected windows will be closed, leaving the
other files or captures available for editing;

4. User can use this command to switch to the checked window on a list by hitting
Activate (or "bring up" from an icon multiple windows).
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18 Help
18.1 Help Contents(H) @ F1i
Choose the Help>Help Contents command to load ImageView help file. The help file

is in Portable Document Format (PDF).

PDF is a file format used to represent documents in a manner independent of
application software, hardware, and operating systems. Each PDF file encapsulates a
complete description of a fixed-layout flat document, including the text, fonts,
graphics, and other information needed to display it. In 1991, Adobe Systems

co-founder John Warnock outlined a system called "Camelot" that evolved into PDF.

While the PDF specification has been available free of charge since at least 2001, PDF
was originally a proprietary format controlled by Adobe. It was officially released as
an open standard on July 1, 2008, and published by the International Organization
for Standardization as ISO 32000-1:2008. In 2008, Adobe published a Public Patent
License to ISO 32000-1 granting royalty-free rights for all patents owned by Adobe

that are necessary to make, use, sell and distribute PDF compliant implementations.
If your computer still does not install the PDF reader, please try to download it from:

http://www.adobe.com/downloads/

18.2 About(A)eee
Display the related information about ImageView, including ImageView version,

Compatible, Built date and its developer’'s www etc.

About ImageView [=

@ =

Copyright (C) 2003 - 2017

Version: x64, 3.7.9229,20 170607
Compativle: Windows XP/Vista/7/8/10
Built: Jun 72017 16:21:25

Clicking on the URL link will direct you to the address of the application supplier. If
you have any problem with the camera or application, please feel free to contact your

supplier.
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